[dev-libs/libbson] prepare version for tree

This commit is contained in:
Robert Förster 2024-07-13 01:58:20 +02:00
parent 456262ff7b
commit 0ece479d4b
3 changed files with 91 additions and 0 deletions

View File

@ -1 +1,2 @@
DIST mongo-c-driver-1.24.4.tar.gz 7916661 BLAKE2B e361b52bf16eed7437428b0481d792ecf2f9cc283fdd6f23916d4a3ffb1b7d7c9ea7a7c4cf5f369e21fb6d4f564b91e07ac2ee44656855993218593dc4f1c166 SHA512 3563c061565d17a76581e188f6e184d7e41f2729812c8815afd34e03ebe6c1d25d7498a2cb1b599a09d24f6268c36473ef5113a14c7585a1532c9abf2e56e936
DIST mongo-c-driver-1.27.4.tar.gz 7188542 BLAKE2B 4cd0aa36dc101615879139bd27e2520cfed6f09ef313701daf4a9ec81e06c87eaf3cae6ed51dd7766b733971dd6c8955b6418d3b7dc384a2bf033a6162e91817 SHA512 4568ce2c96d130807a606b2b2e4428420b77619381388c9b53961676e9e9d03bf3b8685638cc2f185319f5ff582dd34e9e6ff7f2d8798cca9b11adb693011af2

View File

@ -0,0 +1,25 @@
From be865dd759a28aa268232766f304d1bc11f1e8f7 Mon Sep 17 00:00:00 2001
From: Kevin Albertson <kevin.albertson@mongodb.com>
Date: Mon, 30 Oct 2023 18:01:30 +0000
Subject: [PATCH] CDRIVER-4747 use `size_t` consistently in
`bson_utf8_validate` (#1458)
---
src/libbson/src/bson/bson-utf8.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/libbson/src/bson/bson-utf8.c b/src/libbson/src/bson/bson-utf8.c
index e122ac31f7..1cebd27069 100644
--- a/src/libbson/src/bson/bson-utf8.c
+++ b/src/libbson/src/bson/bson-utf8.c
@@ -118,8 +118,8 @@ bson_utf8_validate (const char *utf8, /* IN */
bson_unichar_t c;
uint8_t first_mask;
uint8_t seq_length;
- unsigned i;
- unsigned j;
+ size_t i;
+ size_t j;
BSON_ASSERT (utf8);

View File

@ -0,0 +1,65 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..13} )
inherit cmake python-any-r1
DESCRIPTION="Library routines related to building,parsing and iterating BSON documents"
HOMEPAGE="https://github.com/mongodb/mongo-c-driver/tree/master/src/libbson"
SRC_URI="https://github.com/mongodb/mongo-c-driver/releases/download/${PV}/mongo-c-driver-${PV}.tar.gz"
S="${WORKDIR}/mongo-c-driver-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~hppa ~loong ~ppc ~riscv ~sparc ~x86"
IUSE="examples static-libs"
# tests are covered in mongo-c-driver and are not easily runnable in here
RESTRICT="test"
BDEPEND="
$(python_gen_any_dep '
dev-python/sphinx[${PYTHON_USEDEP}]
')
"
PATCHES=(
"${FILESDIR}/${P}-CVE-2023-0437.patch"
)
python_check_deps() {
python_has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
}
src_prepare() {
cmake_src_prepare
# remove doc files
sed -i '/^\s*install\s*(FILES COPYING NEWS/,/^\s*)/ {d}' CMakeLists.txt || die
}
src_configure() {
local mycmakeargs=(
-DENABLE_BSON=ON
-DENABLE_EXAMPLES=OFF
-DENABLE_MAN_PAGES=ON
-DENABLE_MONGOC=OFF
-DENABLE_TESTS=OFF
-DENABLE_STATIC="$(usex static-libs ON OFF)"
-DENABLE_UNINSTALL=OFF
)
cmake_src_configure
}
src_install() {
if use examples; then
docinto examples
dodoc src/libbson/examples/*.c
fi
cmake_src_install
}