[dev-python/pymongo-auth-aws] replace test with sed from pymongo
This commit is contained in:
parent
50976c650d
commit
14426d85bb
@ -1,22 +0,0 @@
|
|||||||
--- a/pyproject.toml 2020-02-02 01:00:00.000000000 +0100
|
|
||||||
+++ b/pyproject.toml 2024-06-26 15:25:36.921786136 +0200
|
|
||||||
@@ -1,5 +1,5 @@
|
|
||||||
[build-system]
|
|
||||||
-requires = ["hatchling>1.24","hatch-requirements-txt>=0.4.1"]
|
|
||||||
+requires = ["hatchling>1.24"]
|
|
||||||
build-backend = "hatchling.build"
|
|
||||||
|
|
||||||
[project]
|
|
||||||
@@ -44,12 +44,6 @@
|
|
||||||
path = "pymongo_auth_aws/version.py"
|
|
||||||
validate-bump = false
|
|
||||||
|
|
||||||
-[tool.hatch.metadata.hooks.requirements_txt]
|
|
||||||
-files = ["requirements.txt"]
|
|
||||||
-
|
|
||||||
-[tool.hatch.metadata.hooks.requirements_txt.optional-dependencies]
|
|
||||||
-test = ["requirements-test.txt"]
|
|
||||||
-
|
|
||||||
[tool.ruff]
|
|
||||||
target-version = "py37"
|
|
||||||
line-length = 100
|
|
@ -32,8 +32,10 @@ BDEPEND="
|
|||||||
)
|
)
|
||||||
"
|
"
|
||||||
|
|
||||||
PATCHES=(
|
|
||||||
"${FILESDIR}/${P}-no-req-text.patch"
|
|
||||||
)
|
|
||||||
|
|
||||||
distutils_enable_tests pytest
|
distutils_enable_tests pytest
|
||||||
|
|
||||||
|
src_prepare() {
|
||||||
|
distutils-r1_src_prepare
|
||||||
|
# we do not want hatch-requirements-txt and its ton of NIH deps
|
||||||
|
sed -i -e '/requirements/d' pyproject.toml || die
|
||||||
|
}
|
||||||
|
Loading…
Reference in New Issue
Block a user