[dev-games/StormLib] version bump, converted to cmake-multilib, also still lacks static-libs support despite existence of useflag

This commit is contained in:
Robert Förster 2013-11-13 17:06:15 +01:00
parent b026612d88
commit 1d90209677
3 changed files with 18 additions and 18 deletions

View File

@ -1 +1 @@
DIST StormLib-8.10.tar.xz 397372 SHA256 c564a3ec3ec7edd875a437921239b0505ebdca95424c12ecfb643d00893506ce SHA512 0d0f503c985bfe9a8d59246d1901be032ff01a71bcc0cb4b13b9a4c066be82108f87f9722efd3bb26aaf370b282dad700eb111cad49606189f89ddf501a8de38 WHIRLPOOL 223731049ac66991083088ec6071302a1b6e95f18725b61b840931bd258eef33b6cd4802eb63f938c9f11b42668c1cc64898bf3a065b8dc307bf4f004bd36134
DIST StormLib-8.22.tar.gz 862313 SHA256 780fee850cf4508c5fc2bc4259da8f059b8ff96b1ac3f026068d0062180e0e98 SHA512 0c37716ad3db5fba781a1bd05666b2133c33702b561a0c2f69e4b206e243fcb521bc2bcb0dcd06b877d3b4f7f415b1a9125b1313c09bc998881348f23a122266 WHIRLPOOL 76a80627f36a1fde3254203809ab50258a32b0342dfc375e71be5b50852a8744313be75c5a2be05669dc94f0629f00f070b25611d52e76b836b1b467e459afed

View File

@ -4,11 +4,11 @@
EAPI="5"
inherit cmake-utils
inherit cmake-multilib
DESCRIPTION="library to read and write MPQ archives"
HOMEPAGE="http://www.zezula.net/en/mpq/main.html"
SRC_URI="http://people.znc.in/~dessa/ghost/deps/${P}.tar.xz"
SRC_URI="https://github.com/stormlib/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
RESTRICT="mirror"
@ -16,9 +16,9 @@ LICENSE="as-is"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="=dev-libs/libtomcrypt-1.17-r7
sys-libs/zlib
app-arch/bzip2"
DEPEND="=dev-libs/libtomcrypt-1.17-r7[static-libs?,${MULTILIB_USEDEP}]
sys-libs/zlib[static-libs?,${MULTILIB_USEDEP}]
app-arch/bzip2[static-libs?,${MULTILIB_USEDEP}]"
RDEPEND="${DEPEND}"
src_prepare() {
@ -29,5 +29,5 @@ src_configure() {
local mycmakeargs="
-DWITH_LIBTOMCRYPT=ON"
cmake-utils_src_configure
cmake-multilib_src_configure
}

View File

@ -1,15 +1,15 @@
--- CMakeLists.txt.old 2012-01-02 09:32:42.000000000 +0100
+++ CMakeLists.txt 2012-05-05 00:42:28.000000000 +0200
@@ -237,6 +237,8 @@
test/Test.cpp
)
--- CMakeLists.txt.old 2013-11-12 18:53:57.930000000 +0100
+++ CMakeLists.txt 2013-11-12 18:57:20.700000000 +0100
@@ -281,7 +281,7 @@
add_library(storm_static STATIC ${SRC_FILES} ${SRC_ADDITIONAL_FILES})
target_link_libraries(storm_static ${LINK_LIBS})
set_target_properties(storm_static PROPERTIES OUTPUT_NAME storm)
- install(TARGETS storm_static RUNTIME DESTINATION bin LIBRARY DESTINATION lib ARCHIVE DESTINATION lib FRAMEWORK DESTINATION /Library/Frameworks)
+ install(TARGETS storm_static RUNTIME DESTINATION bin LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} FRAMEWORK DESTINATION /Library/Frameworks)
endif()
+set(LIB_SUFFIX "" CACHE STRING "Define suffix of directory name (32/64)")
+
add_definitions(-D_7ZIP_ST -DBZ_STRICT_ANSI)
if(WIN32)
@@ -290,6 +292,6 @@
if(APPLE)
@@ -300,6 +300,6 @@
set_target_properties(storm PROPERTIES OUTPUT_NAME StormLib)
endif()