[dev-libs/libtom{crypt,math}] remove, multilib no longer needed and newer in tree
This commit is contained in:
parent
90cf051660
commit
2eaa0570b8
@ -1 +0,0 @@
|
|||||||
DIST crypt-1.17.tar.bz2 1599215 BLAKE2B 9a44e5131f603e57fbca568d37e9e531f856cb5b418e9c0773d2820ccd0db561ef8d101f1700b43d629fecd858325cd3156d1d873462a38b0dc190c3fc857628 SHA512 9335df5ae0a2c8e33e8f03ced0cfb0a8d1ac4bccd007b74818228c3b8b232446b4425356f304a08320b75542a537a46b305b92c3011dee76dfd636497bf57af2
|
|
@ -1,81 +0,0 @@
|
|||||||
--- makefile.shared.old 2013-11-11 19:07:58.870000000 +0100
|
|
||||||
+++ makefile.shared 2013-11-11 19:09:02.790000000 +0100
|
|
||||||
@@ -9,7 +9,8 @@
|
|
||||||
VERSION=0:117
|
|
||||||
|
|
||||||
# Compiler and Linker Names
|
|
||||||
-CC=libtool --mode=compile --tag=CC gcc
|
|
||||||
+LT ?= libtool
|
|
||||||
+LTCOMPILE = $(LT) --mode=compile --tag=CC $(CC)
|
|
||||||
|
|
||||||
# ranlib tools
|
|
||||||
ifndef RANLIB
|
|
||||||
@@ -229,9 +230,12 @@
|
|
||||||
#The default rule for make builds the libtomcrypt library.
|
|
||||||
default:library
|
|
||||||
|
|
||||||
+%.lo: %.c
|
|
||||||
+ $(LTCOMPILE) $(CFLAGS) $(CPPFLAGS) -o $@ -c $<
|
|
||||||
+
|
|
||||||
#ciphers come in two flavours... enc+dec and enc
|
|
||||||
-src/ciphers/aes/aes_enc.o: src/ciphers/aes/aes.c src/ciphers/aes/aes_tab.c
|
|
||||||
- $(CC) $(CFLAGS) -DENCRYPT_ONLY -c src/ciphers/aes/aes.c -o src/ciphers/aes/aes_enc.o
|
|
||||||
+src/ciphers/aes/aes_enc.lo: src/ciphers/aes/aes.c src/ciphers/aes/aes_tab.c
|
|
||||||
+ $(LTCOMPILE) $(CFLAGS) -DENCRYPT_ONLY -c src/ciphers/aes/aes.c -o src/ciphers/aes/aes_enc.o
|
|
||||||
|
|
||||||
#These are the rules to make certain object files.
|
|
||||||
src/ciphers/aes/aes.o: src/ciphers/aes/aes.c src/ciphers/aes/aes_tab.c
|
|
||||||
@@ -244,38 +248,38 @@
|
|
||||||
library: $(LIBNAME)
|
|
||||||
|
|
||||||
testprof/$(LIBTEST):
|
|
||||||
- cd testprof ; CFLAGS="$(CFLAGS)" GROUP=$(GROUP) USER=$(USER) VERSION=$(VERSION) LIBPATH=$(LIBPATH) LIBTEST=$(LIBTEST) LIBTEST_S=$(LIBTEST_S) make -f makefile.shared
|
|
||||||
+ cd testprof ; CFLAGS="$(CFLAGS)" VERSION=$(VERSION) LIBPATH=$(LIBPATH) LIBTEST=$(LIBTEST) LIBTEST_S=$(LIBTEST_S) make -f makefile.shared
|
|
||||||
|
|
||||||
objs: $(OBJECTS)
|
|
||||||
|
|
||||||
-$(LIBNAME): $(OBJECTS) testprof/$(LIBTEST)
|
|
||||||
- libtool --silent --mode=link gcc $(CFLAGS) `find . -type f | grep "[.]lo" | grep "src/" | xargs` $(EXTRALIBS) -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
|
|
||||||
+$(LIBNAME): $(OBJECTS:.o=.lo) testprof/$(LIBTEST:.o=.lo)
|
|
||||||
+ libtool --silent --mode=link --tag CC $(CC) $(CFLAGS) `find . -type f | grep "[.]lo" | grep "src/" | xargs` $(EXTRALIBS) -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
|
|
||||||
|
|
||||||
install: $(LIBNAME)
|
|
||||||
- install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
|
|
||||||
- cd testprof ; CFLAGS="$(CFLAGS)" GROUP=$(GROUP) USER=$(USER) VERSION=$(VERSION) LIBPATH=$(LIBPATH) LIBTEST=$(LIBTEST) LIBTEST_S=$(LIBTEST_S) DESTDIR=$(DESTDIR) make -f makefile.shared install
|
|
||||||
- libtool --silent --mode=install install -c libtomcrypt.la $(DESTDIR)$(LIBPATH)/libtomcrypt.la
|
|
||||||
- install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
|
|
||||||
- install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
|
|
||||||
+ install -d $(DESTDIR)$(LIBPATH)
|
|
||||||
+ cd testprof ; CFLAGS="$(CFLAGS)" VERSION=$(VERSION) LIBPATH=$(LIBPATH) LIBTEST=$(LIBTEST) LIBTEST_S=$(LIBTEST_S) DESTDIR=$(DESTDIR) make -f makefile.shared install
|
|
||||||
+ $(LT) --mode=install install -c libtomcrypt.la $(DESTDIR)$(LIBPATH)/libtomcrypt.la
|
|
||||||
+ install -d $(DESTDIR)$(INCPATH)
|
|
||||||
+ install -m 644 $(HEADERS) $(DESTDIR)$(INCPATH)
|
|
||||||
|
|
||||||
#This rule makes the hash program included with libtomcrypt
|
|
||||||
hashsum: library
|
|
||||||
- gcc $(CFLAGS) demos/hashsum.c -o hashsum.o
|
|
||||||
- gcc -o hashsum hashsum.o -ltomcrypt $(EXTRALIBS)
|
|
||||||
+ $(CC) $(CFLAGS) demos/hashsum.c -o hashsum.o
|
|
||||||
+ $(CC) -o hashsum hashsum.o -ltomcrypt $(EXTRALIBS)
|
|
||||||
|
|
||||||
#makes the crypt program
|
|
||||||
crypt: library
|
|
||||||
- gcc $(CFLAGS) demos/encrypt.c -o encrypt.o
|
|
||||||
- gcc -o crypt encrypt.o -ltomcrypt $(EXTRALIBS)
|
|
||||||
+ $(CC) $(CFLAGS) demos/encrypt.c -o encrypt.o
|
|
||||||
+ $(CC) -o crypt encrypt.o -ltomcrypt $(EXTRALIBS)
|
|
||||||
|
|
||||||
tv_gen: library $(TVS)
|
|
||||||
- gcc -o tv_gen $(TVS) -ltomcrypt $(EXTRALIBS)
|
|
||||||
+ $(CC) -o tv_gen $(TVS) -ltomcrypt $(EXTRALIBS)
|
|
||||||
|
|
||||||
test: library testprof/$(LIBTEST) $(TESTS)
|
|
||||||
- gcc -o $(TEST) $(TESTS) -ltomcrypt_prof -ltomcrypt $(EXTRALIBS)
|
|
||||||
+ $(CC) -o $(TEST) $(TESTS) -ltomcrypt_prof -ltomcrypt $(EXTRALIBS)
|
|
||||||
|
|
||||||
timing: library testprof/$(LIBTEST) $(TIMINGS)
|
|
||||||
- gcc -o $(TIMING) $(TIMINGS) -ltomcrypt_prof -ltomcrypt $(EXTRALIBS)
|
|
||||||
+ $(CC) -o $(TIMING) $(TIMINGS) -ltomcrypt_prof -ltomcrypt $(EXTRALIBS)
|
|
||||||
|
|
||||||
# $Source: /cvs/libtom/libtomcrypt/makefile.shared,v $
|
|
||||||
# $Revision: 1.80 $
|
|
@ -1,71 +0,0 @@
|
|||||||
# Copyright 1999-2019 Gentoo Authors
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
EAPI="7"
|
|
||||||
|
|
||||||
inherit autotools multilib-minimal toolchain-funcs
|
|
||||||
|
|
||||||
DESCRIPTION="modular and portable cryptographic toolkit"
|
|
||||||
HOMEPAGE="http://www.libtom.org/"
|
|
||||||
SRC_URI="https://github.com/libtom/libtomcrypt/releases/download/${PV}/crypt-${PV}.tar.bz2"
|
|
||||||
|
|
||||||
LICENSE="WTFPL-2"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="~amd64 ~ppc ~x86"
|
|
||||||
IUSE="doc static-libs"
|
|
||||||
|
|
||||||
RDEPEND="dev-libs/libtommath[static-libs?,${MULTILIB_USEDEP}]"
|
|
||||||
DEPEND="${RDEPEND}
|
|
||||||
doc? ( virtual/latex-base app-text/ghostscript-gpl )"
|
|
||||||
|
|
||||||
src_prepare() {
|
|
||||||
use doc || sed -i '/^install:/s:docs::' makefile
|
|
||||||
epatch "${FILESDIR}"/libtomcrypt-1.17-r7-libtool-tag-and-make-fix.patch
|
|
||||||
sed -i \
|
|
||||||
-e "s:--mode=link gcc:--mode=link $(tc-getCC) ${LDFLAGS} --tag CC $(tc-getCC):g" \
|
|
||||||
-e "s: gcc: $(tc-getCC):g" \
|
|
||||||
{,testprof/}makefile.shared || die
|
|
||||||
|
|
||||||
# need libtool for cross compilation. Bug #376643
|
|
||||||
cat <<-EOF > configure.ac
|
|
||||||
AC_INIT(libtomcrypt, 0)
|
|
||||||
AM_INIT_AUTOMAKE
|
|
||||||
LT_INIT
|
|
||||||
AC_CONFIG_FILES(Makefile)
|
|
||||||
AC_OUTPUT
|
|
||||||
EOF
|
|
||||||
touch NEWS README AUTHORS ChangeLog Makefile.am
|
|
||||||
eautoreconf
|
|
||||||
export LIBTOOL="${S}"/libtool
|
|
||||||
multilib_copy_sources
|
|
||||||
}
|
|
||||||
|
|
||||||
_emake() {
|
|
||||||
cd ${BUILD_DIR}
|
|
||||||
emake CC="$(tc-getCC)" -f makefile.shared \
|
|
||||||
EXTRALIBS="-ltommath" \
|
|
||||||
IGNORE_SPEED=1 \
|
|
||||||
LIBPATH="${EPREFIX}/usr/$(get_libdir)" \
|
|
||||||
INCPATH="${EPREFIX}/usr/include" \
|
|
||||||
"$@"
|
|
||||||
}
|
|
||||||
|
|
||||||
src_compile() {
|
|
||||||
append-cflags -DLTM_DESC
|
|
||||||
multilib_foreach_abi _emake
|
|
||||||
}
|
|
||||||
|
|
||||||
src_test() {
|
|
||||||
# Tests don't compile
|
|
||||||
true
|
|
||||||
}
|
|
||||||
|
|
||||||
src_install() {
|
|
||||||
multilib_foreach_abi _emake DESTDIR="${D}" install
|
|
||||||
dodoc TODO changes
|
|
||||||
if use doc ; then
|
|
||||||
dodoc doc/*
|
|
||||||
docinto notes ; dodoc notes/*
|
|
||||||
docinto demos ; dodoc demos/*
|
|
||||||
fi
|
|
||||||
}
|
|
@ -1 +0,0 @@
|
|||||||
DIST ltm-1.1.0.tar.xz 2125456 BLAKE2B 3aca7993704341f6a81e7fbef35389ac8ecd957dd78b5d576f0305d37493c3ddc32462cd787de2fb67d8e165417b18fcfde70accf991cd9433ff87591d8265ac SHA512 6d1b8b09d5b975a2b84ef6ab9cb1cc63db2f0503a906e499cb9d7eaba3f487be6e7f69bf692b188f888418c61ea563aa7e2411638d8979eac426b3d603ad1b91
|
|
@ -1,75 +0,0 @@
|
|||||||
# Copyright 1999-2019 Gentoo Authors
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
EAPI=7
|
|
||||||
|
|
||||||
inherit autotools multilib-minimal toolchain-funcs
|
|
||||||
|
|
||||||
DESCRIPTION="Optimized and portable routines for integer theoretic applications"
|
|
||||||
HOMEPAGE="http://www.libtom.net/"
|
|
||||||
SRC_URI="https://github.com/libtom/libtommath/releases/download/v${PV}/ltm-${PV}.tar.xz"
|
|
||||||
|
|
||||||
LICENSE="WTFPL-2"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
|
|
||||||
IUSE="doc examples static-libs"
|
|
||||||
|
|
||||||
src_prepare() {
|
|
||||||
default
|
|
||||||
# need libtool for cross compilation. Bug #376643
|
|
||||||
cat <<-EOF > configure.ac
|
|
||||||
AC_INIT(libtommath, 0)
|
|
||||||
AM_INIT_AUTOMAKE
|
|
||||||
LT_INIT
|
|
||||||
AC_CONFIG_FILES(Makefile)
|
|
||||||
AC_OUTPUT
|
|
||||||
EOF
|
|
||||||
touch NEWS README AUTHORS ChangeLog Makefile.am
|
|
||||||
eautoreconf
|
|
||||||
export LIBTOOL="${S}"/libtool
|
|
||||||
multilib_copy_sources
|
|
||||||
}
|
|
||||||
|
|
||||||
src_configure() {
|
|
||||||
econf $(use_enable static-libs static)
|
|
||||||
}
|
|
||||||
|
|
||||||
_emake() {
|
|
||||||
cd ${BUILD_DIR}
|
|
||||||
emake \
|
|
||||||
CC="$(tc-getCC)" \
|
|
||||||
AR="$(tc-getAR)" \
|
|
||||||
RANLIB="$(tc-getRANLIB)" \
|
|
||||||
-f makefile.shared \
|
|
||||||
IGNORE_SPEED=1 \
|
|
||||||
LIBPATH="${EPREFIX}/usr/$(get_libdir)" \
|
|
||||||
INCPATH="${EPREFIX}/usr/include" \
|
|
||||||
"$@"
|
|
||||||
}
|
|
||||||
|
|
||||||
src_compile() {
|
|
||||||
multilib_foreach_abi _emake
|
|
||||||
}
|
|
||||||
|
|
||||||
src_test() {
|
|
||||||
multilib_foreach_abi _emake test_standalone
|
|
||||||
multilib_foreach_abi ./test || die
|
|
||||||
}
|
|
||||||
|
|
||||||
src_install() {
|
|
||||||
multilib_foreach_abi _emake DESTDIR="${D}" install
|
|
||||||
# We only link against -lc, so drop the .la file.
|
|
||||||
find "${ED}" -name '*.la' -delete || die
|
|
||||||
if ! use static-libs ; then
|
|
||||||
find "${ED}" -name "*.a" -delete || die
|
|
||||||
fi
|
|
||||||
|
|
||||||
dodoc changes.txt
|
|
||||||
|
|
||||||
use doc && dodoc *.pdf
|
|
||||||
|
|
||||||
if use examples ; then
|
|
||||||
docinto demo
|
|
||||||
dodoc demo/*.c
|
|
||||||
fi
|
|
||||||
}
|
|
Loading…
Reference in New Issue
Block a user