[net-im/spectrum2] try a fix for newer protobuf

This commit is contained in:
Robert Förster 2024-01-02 17:50:38 +01:00
parent 5806fb08e2
commit 31a70a95d0
2 changed files with 20 additions and 2 deletions

View File

@ -0,0 +1,16 @@
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0c2ab857..1195c8b9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,7 @@ cmake_policy(SET CMP0037 OLD)
project(libtransport)
-set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD 14)
if(WIN32)
set(CMAKE_CXX_STANDARD 17)
endif(WIN32)

View File

@ -1,4 +1,4 @@
# Copyright 1999-2023 Gentoo Authors
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@ -64,7 +64,9 @@ DEPEND="
doc? ( app-doc/doxygen )
test? ( dev-util/cppunit )
"
PATCHES=(
"${FILESDIR}/${PN}-cxx14.patch"
)
src_prepare() {
# Respect users LDFLAGS