[dev-games/StormLib] version bump, static-libs USE does now build static *only*
This commit is contained in:
parent
172d4effc3
commit
377ffe1780
@ -1,4 +1,4 @@
|
||||
# Copyright 1999-2016 Gentoo Foundation
|
||||
# Copyright 1999-2017 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
@ -23,11 +23,12 @@ DEPEND="dev-libs/libtomcrypt[static-libs?,${MULTILIB_USEDEP}]
|
||||
RDEPEND="${DEPEND}"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}"/${PN}-multilib.patch
|
||||
"${FILESDIR}"/${PN}-fix-build-system.patch
|
||||
)
|
||||
|
||||
multilib_src_configure() {
|
||||
local mycmakeargs=(
|
||||
-DBUILD_SHARED_LIBS="$(usex static-libs no yes)"
|
||||
-DWITH_LIBTOMCRYPT=ON)
|
||||
|
||||
cmake-utils_src_configure
|
22
dev-games/StormLib/files/StormLib-fix-build-system.patch
Normal file
22
dev-games/StormLib/files/StormLib-fix-build-system.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- a/CMakeLists.txt 2017-02-01 16:58:20.420715822 +0100
|
||||
+++ b/CMakeLists.txt 2017-02-01 17:00:00.298138266 +0100
|
||||
@@ -302,7 +302,7 @@
|
||||
endif()
|
||||
if(UNIX)
|
||||
SET(VERSION_MAJOR "9")
|
||||
- SET(VERSION_MINOR "20")
|
||||
+ SET(VERSION_MINOR "21")
|
||||
SET(VERSION_PATCH "0")
|
||||
SET(VERSION_STRING "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}")
|
||||
set_target_properties(${LIBRARY_NAME} PROPERTIES VERSION "${VERSION_STRING}")
|
||||
@@ -317,8 +317,8 @@
|
||||
|
||||
install(TARGETS ${LIBRARY_NAME}
|
||||
RUNTIME DESTINATION bin
|
||||
- LIBRARY DESTINATION lib
|
||||
- ARCHIVE DESTINATION lib
|
||||
+ LIBRARY DESTINATION lib${LIB_SUFFIX}
|
||||
+ ARCHIVE DESTINATION lib${LIB_SUFFIX}
|
||||
FRAMEWORK DESTINATION /Library/Frameworks
|
||||
PUBLIC_HEADER DESTINATION include
|
||||
INCLUDES DESTINATION include)
|
@ -1,19 +0,0 @@
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -281,7 +281,7 @@
|
||||
add_library(storm_static STATIC ${SRC_FILES} ${SRC_ADDITIONAL_FILES})
|
||||
target_link_libraries(storm_static ${LINK_LIBS})
|
||||
set_target_properties(storm_static PROPERTIES OUTPUT_NAME storm)
|
||||
- install(TARGETS storm_static RUNTIME DESTINATION bin LIBRARY DESTINATION lib ARCHIVE DESTINATION lib FRAMEWORK DESTINATION /Library/Frameworks)
|
||||
+ install(TARGETS storm_static RUNTIME DESTINATION bin LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} FRAMEWORK DESTINATION /Library/Frameworks)
|
||||
endif()
|
||||
|
||||
if(APPLE)
|
||||
@@ -300,6 +300,6 @@
|
||||
set_target_properties(storm PROPERTIES OUTPUT_NAME StormLib)
|
||||
endif()
|
||||
|
||||
-install(TARGETS storm RUNTIME DESTINATION bin LIBRARY DESTINATION lib ARCHIVE DESTINATION lib FRAMEWORK DESTINATION /Library/Frameworks)
|
||||
+install(TARGETS storm RUNTIME DESTINATION bin LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} FRAMEWORK DESTINATION /Library/Frameworks)
|
||||
install(FILES src/StormLib.h src/StormPort.h DESTINATION include)
|
||||
|
Loading…
Reference in New Issue
Block a user