[www-apps/gitea] bump to 1.10.0_rc2 as continuation from PR 12597 on gentoo/gentoo
This commit is contained in:
parent
0cefd5d044
commit
3a0ff59d53
1
www-apps/gitea/Manifest
Normal file
1
www-apps/gitea/Manifest
Normal file
@ -0,0 +1 @@
|
||||
DIST gitea-1.10.0_rc2.tar.gz 28905169 BLAKE2B d34025875e344247968f43d03ee1b7fa2c41bb1c65169b6b206d3a60bd22dc09205a3e4a1b08d206c4fd2b0bb8075d2e4615a22aef8039b57f6dba7cabc222c6 SHA512 512af3bc2aa5c5caf188cb06fc6279d6fc2950e6f984a29d5e83a7c6e153d2c75edcf4a6536615e9bbe3ba948d3abf867687aa75032f2bbf1b62723fe86d1b55
|
13
www-apps/gitea/files/gitea-logflags.patch
Normal file
13
www-apps/gitea/files/gitea-logflags.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/modules/log/flags.go b/modules/log/flags.go
|
||||
index 992fc62..5578a1b 100644
|
||||
--- a/modules/log/flags.go
|
||||
+++ b/modules/log/flags.go
|
||||
@@ -31,7 +31,7 @@ const (
|
||||
Lmedfile = Lshortfile | Llongfile
|
||||
|
||||
// LstdFlags is the initial value for the standard logger
|
||||
- LstdFlags = Ldate | Ltime | Lmedfile | Lshortfuncname | Llevelinitial
|
||||
+ LstdFlags = Ldate | Ltime | Llevelinitial
|
||||
)
|
||||
|
||||
var flagFromString = map[string]int{
|
14
www-apps/gitea/files/gitea.confd-r1
Normal file
14
www-apps/gitea/files/gitea.confd-r1
Normal file
@ -0,0 +1,14 @@
|
||||
# Gitea configuration
|
||||
GITEA_CONF="/etc/gitea/app.ini"
|
||||
|
||||
# Gitea user
|
||||
GITEA_USER="git"
|
||||
|
||||
# Gitea group
|
||||
GITEA_GROUP="git"
|
||||
|
||||
# Gitea working directory
|
||||
GITEA_WORK_DIR="/var/lib/gitea"
|
||||
|
||||
# Gitea custom directory
|
||||
GITEA_CUSTOM="${GITEA_WORK_DIR}/custom"
|
22
www-apps/gitea/files/gitea.initd-r3
Normal file
22
www-apps/gitea/files/gitea.initd-r3
Normal file
@ -0,0 +1,22 @@
|
||||
#!/sbin/openrc-run
|
||||
# Copyright 2016-2019 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
description="Gitea, a self-hosted Git service"
|
||||
|
||||
: ${GITEA_CONF:=/etc/gitea/app.ini}
|
||||
: ${GITEA_USER:=git}
|
||||
: ${GITEA_GROUP:=git}
|
||||
: ${GITEA_WORK_DIR:=/var/lib/gitea}
|
||||
: ${GITEA_CUSTOM:=${GITEA_WORK_DIR}/custom}
|
||||
|
||||
command="/usr/bin/gitea web"
|
||||
command_args="--config ${GITEA_CONF}"
|
||||
command_background="true"
|
||||
command_user="${GITEA_USER}:${GITEA_GROUP}"
|
||||
error_log="/var/log/${RC_SVCNAME}/${RC_SVCNAME}.err"
|
||||
pidfile="/run/${RC_SVCNAME}.pid"
|
||||
required_files="${GITEA_CONF}"
|
||||
start_stop_daemon_args="-d ${GITEA_WORK_DIR}"
|
||||
start_stop_daemon_args="${start_stop_daemon_args} -e GITEA_WORK_DIR=${GITEA_WORK_DIR}"
|
||||
start_stop_daemon_args="${start_stop_daemon_args} -e GITEA_CUSTOM=${GITEA_CUSTOM}"
|
34
www-apps/gitea/files/gitea.service-r2
Normal file
34
www-apps/gitea/files/gitea.service-r2
Normal file
@ -0,0 +1,34 @@
|
||||
[Unit]
|
||||
Description=Gitea service
|
||||
Documentation=https://docs.gitea.io/
|
||||
|
||||
AssertPathIsDirectory=/var/lib/gitea
|
||||
AssertPathIsReadWrite=/var/lib/gitea
|
||||
|
||||
After=network.target
|
||||
Requires=network.target
|
||||
After=mysqld.service
|
||||
After=postgresql-9.3.service
|
||||
After=postgresql-9.4.service
|
||||
After=postgresql-9.5.service
|
||||
After=postgresql-9.6.service
|
||||
After=postgresql-10.service
|
||||
After=postgresql-11.service
|
||||
After=postgresql-12.service
|
||||
After=memcached.service
|
||||
After=redis.service
|
||||
|
||||
[Service]
|
||||
User=git
|
||||
Group=git
|
||||
|
||||
Environment="GITEA_WORK_DIR=/var/lib/gitea" "GITEA_CUSTOM=/var/lib/gitea/custom"
|
||||
WorkingDirectory=/var/lib/gitea
|
||||
ExecStart=/usr/bin/gitea web --config /etc/gitea/app.ini
|
||||
|
||||
Restart=always
|
||||
PrivateTmp=true
|
||||
Nice=5
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
119
www-apps/gitea/gitea-1.10.0_rc2.ebuild
Normal file
119
www-apps/gitea/gitea-1.10.0_rc2.ebuild
Normal file
@ -0,0 +1,119 @@
|
||||
# Copyright 1999-2019 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
inherit golang-vcs-snapshot tmpfiles systemd
|
||||
|
||||
MY_PV=${PV/_/-}
|
||||
#MY_P=${PN}-${MY_PV}
|
||||
|
||||
EGO_PN="code.gitea.io/gitea"
|
||||
|
||||
DESCRIPTION="A painless self-hosted Git service"
|
||||
HOMEPAGE="https://gitea.io"
|
||||
SRC_URI="https://github.com/go-gitea/gitea/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~arm ~arm64"
|
||||
IUSE="+acct pam sqlite"
|
||||
|
||||
BDEPEND="<dev-lang/go-1.13"
|
||||
COMMON_DEPEND="
|
||||
acct? (
|
||||
acct-group/git
|
||||
acct-user/git[gitea]
|
||||
)
|
||||
pam? ( sys-libs/pam )"
|
||||
DEPEND="${COMMON_DEPEND}"
|
||||
RDEPEND="${COMMON_DEPEND}
|
||||
dev-vcs/git
|
||||
acct? (
|
||||
!dev-vcs/gitolite
|
||||
!dev-vcs/gitolite-gentoo
|
||||
)
|
||||
"
|
||||
|
||||
DOCS=( custom/conf/app.ini.sample CONTRIBUTING.md README.md )
|
||||
S="${WORKDIR}/${P}/src/${EGO_PN}"
|
||||
|
||||
PATCHES=( "${FILESDIR}/gitea-logflags.patch" )
|
||||
|
||||
gitea_make() {
|
||||
local my_tags=(
|
||||
bindata
|
||||
$(usev pam)
|
||||
$(usex sqlite 'sqlite sqlite_unlock_notify' '')
|
||||
)
|
||||
local my_makeopt=(
|
||||
DRONE_TAG=${MY_PV}
|
||||
TAGS="${my_tags[@]}"
|
||||
LDFLAGS="-extldflags \"${LDFLAGS}\""
|
||||
)
|
||||
GOPATH=${WORKDIR}/${P}:$(get_golibdir_gopath) emake "${my_makeopt[@]}" "$@"
|
||||
}
|
||||
|
||||
src_prepare() {
|
||||
default
|
||||
|
||||
local sedcmds=(
|
||||
-e "s#^RUN_MODE = dev#RUN_MODE = prod#"
|
||||
-e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
|
||||
-e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
|
||||
-e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
|
||||
-e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
|
||||
-e "s#^MODE = console#MODE = file#"
|
||||
-e "s#^LEVEL = Trace#LEVEL = Info#"
|
||||
-e "s#^LOG_SQL = true#LOG_SQL = false#"
|
||||
-e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
|
||||
-e "s#^APP_ID =#;APP_ID =#"
|
||||
-e "s#^TRUSTED_FACETS =#;TRUSTED_FACETS =#"
|
||||
)
|
||||
|
||||
sed -i "${sedcmds[@]}" custom/conf/app.ini.sample || die
|
||||
if use sqlite ; then
|
||||
sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.ini.sample || die
|
||||
fi
|
||||
|
||||
gitea_make generate
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
gitea_make build
|
||||
}
|
||||
|
||||
src_install() {
|
||||
dobin gitea
|
||||
|
||||
einstalldocs
|
||||
|
||||
newconfd "${FILESDIR}/gitea.confd-r1" gitea
|
||||
newinitd "${FILESDIR}/gitea.initd-r3" gitea
|
||||
newtmpfiles - gitea.conf <<-EOF
|
||||
d /run/gitea 0755 git git
|
||||
EOF
|
||||
systemd_newunit "${FILESDIR}"/gitea.service-r2 gitea.service
|
||||
|
||||
insinto /etc/gitea
|
||||
newins custom/conf/app.ini.sample app.ini
|
||||
if use acct ; then
|
||||
fowners root:git /etc/gitea/{,app.ini}
|
||||
fperms g+w,o-rwx /etc/gitea/{,app.ini}
|
||||
|
||||
diropts -m0750 -o git -g git
|
||||
keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
|
||||
keepdir /var/log/gitea
|
||||
fi
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
if [[ -e "${EROOT}/var/lib/gitea/conf/app.ini" ]]; then
|
||||
ewarn "The configuration path has been changed to ${EROOT}/etc/gitea/app.ini."
|
||||
ewarn "Please move your configuration from ${EROOT}/var/lib/gitea/conf/app.ini"
|
||||
ewarn "and adapt the gitea-repositories hooks and ssh authorized_keys."
|
||||
ewarn "Depending on your configuration you should run something like:"
|
||||
ewarn "sed -i -e 's#${EROOT}/var/lib/gitea/conf/app.ini#${EROOT}/etc/gitea/app.ini#' \\"
|
||||
ewarn " /var/lib/gitea/gitea-repositories/*/*/hooks/*/* \\"
|
||||
ewarn " /var/lib/gitea/.ssh/authorized_keys"
|
||||
fi
|
||||
}
|
Loading…
Reference in New Issue
Block a user