[net-im/spectrum2] maybe fix build
This commit is contained in:
parent
0bf0cb3b49
commit
3d85f3b2e4
15
net-im/spectrum2/files/spectrum2-map.patch
Normal file
15
net-im/spectrum2/files/spectrum2-map.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
libtransport/Conversation.cpp | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/libtransport/Conversation.cpp b/libtransport/Conversation.cpp
|
||||||
|
index 8f7c6246..092d6058 100644
|
||||||
|
--- a/libtransport/Conversation.cpp
|
||||||
|
+++ b/libtransport/Conversation.cpp
|
||||||
|
@@ -19,6 +19,7 @@
|
||||||
|
*/
|
||||||
|
|
||||||
|
#include <iostream>
|
||||||
|
+#include <map>
|
||||||
|
#include "transport/Conversation.h"
|
||||||
|
#include "transport/ConversationManager.h"
|
||||||
|
#include "transport/User.h"
|
@ -66,6 +66,10 @@ DEPEND="
|
|||||||
test? ( dev-util/cppunit )
|
test? ( dev-util/cppunit )
|
||||||
"
|
"
|
||||||
|
|
||||||
|
PATCHES=(
|
||||||
|
"${FILESDIR}/${PN}-map.patch"
|
||||||
|
)
|
||||||
|
|
||||||
src_prepare() {
|
src_prepare() {
|
||||||
# Respect users LDFLAGS
|
# Respect users LDFLAGS
|
||||||
sed -i -e "s/-Wl,-export-dynamic/& ${LDFLAGS}/" spectrum/src/CMakeLists.txt || die
|
sed -i -e "s/-Wl,-export-dynamic/& ${LDFLAGS}/" spectrum/src/CMakeLists.txt || die
|
||||||
|
Loading…
Reference in New Issue
Block a user