[dev-libs/Ice] update to 3.6.4 state

This commit is contained in:
Robert Förster 2017-04-28 22:31:44 +02:00
parent 32598a9b3b
commit 40c57d79b2
2 changed files with 14 additions and 16 deletions

View File

@ -3,7 +3,7 @@
EAPI=6 EAPI=6
PYTHON_COMPAT=( python{2_7,3_5} pypy ) PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
RUBY_OPTIONAL="yes" RUBY_OPTIONAL="yes"
USE_RUBY="ruby23" USE_RUBY="ruby23"
@ -14,7 +14,7 @@ PHP_EXT_ZENDEXT="no"
PHP_EXT_OPTIONAL_USE=php PHP_EXT_OPTIONAL_USE=php
USE_PHP="php7-0" USE_PHP="php7-0 php7-1"
EGIT_REPO_URI="https://github.com/zeroc-ice/ice.git" EGIT_REPO_URI="https://github.com/zeroc-ice/ice.git"
EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}" EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}"
@ -37,14 +37,12 @@ RDEPEND=">=dev-libs/expat-2.0.1
!libressl? ( dev-libs/openssl:0= ) !libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= ) libressl? ( dev-libs/libressl:0= )
|| ( || (
sys-libs/db:5.3[cxx] $(for slot in ${BERKDB_SLOTS[@]} ; do printf '%s\n' "sys-libs/db:${slot}[cxx]" ; done)
sys-libs/db:5.1[cxx]
) )
dev-cpp/libmcpp dev-cpp/libmcpp
python? ( ${PYTHON_DEPS} ) python? ( ${PYTHON_DEPS} )
ruby? ( $(ruby_implementation_depend ruby23) ) ruby? ( $(ruby_implementation_depend ruby23) )
mono? ( dev-lang/mono ) mono? ( dev-lang/mono )
php? ( dev-lang/php:7.0 )
!dev-python/IcePy !dev-python/IcePy
!dev-ruby/IceRuby" !dev-ruby/IceRuby"
DEPEND="${RDEPEND} DEPEND="${RDEPEND}
@ -62,7 +60,7 @@ PHP_EXT_S="${S}/php"
PATCHES=( PATCHES=(
"${FILESDIR}/${PN}-3.6.3-no-arch-opts.patch" "${FILESDIR}/${PN}-3.6.3-no-arch-opts.patch"
"${FILESDIR}/${PN}-3.6.3-csharp.patch" "${FILESDIR}/${PN}-3.6.4-csharp.patch"
) )
pkg_setup() { pkg_setup() {
@ -130,8 +128,8 @@ src_prepare() {
src_configure() { src_configure() {
suitable_db_version() { suitable_db_version() {
local ver tested_slots=(5.3 5.1) local ver
for ver in "${tested_slots[@]}"; do for ver in "${BERKDB_SLOTS[@]}"; do
if [[ -n $(db_findver sys-libs/db:${ver}) ]]; then if [[ -n $(db_findver sys-libs/db:${ver}) ]]; then
echo "${ver}" echo "${ver}"
return 0 return 0

View File

@ -1,5 +1,5 @@
--- ice-3.6.3/csharp/src/Makefile~ 2015-06-23 17:30:20.000000000 +0200 --- ice-3.6.4/csharp/src/Makefile~ 2015-06-23 17:30:20.000000000 +0200
+++ ice-3.6.3/csharp/src/Makefile 2015-06-27 20:07:04.217188211 +0200 +++ ice-3.6.4/csharp/src/Makefile 2015-06-27 20:07:04.217188211 +0200
@@ -11,7 +11,7 @@ @@ -11,7 +11,7 @@
include $(top_srcdir)/config/Make.rules.cs include $(top_srcdir)/config/Make.rules.cs
@ -10,9 +10,9 @@
$(EVERYTHING):: $(EVERYTHING)::
@for subdir in $(SUBDIRS); \ @for subdir in $(SUBDIRS); \
--- /dev/null 2015-06-27 16:44:15.733558105 +0200 --- /dev/null 2015-06-27 16:44:15.733558105 +0200
+++ ice-3.6.3/csharp/lib/pkgconfig/IceSSL.pc 2015-06-27 20:19:30.731894653 +0200 +++ ice-3.6.4/csharp/lib/pkgconfig/IceSSL.pc 2015-06-27 20:19:30.731894653 +0200
@@ -0,0 +1,10 @@ @@ -0,0 +1,10 @@
+version = 3.6.3 +version = 3.6.4
+mono_root = /usr +mono_root = /usr
+ +
+name = IceSSL +name = IceSSL
@ -23,9 +23,9 @@
+Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll +Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
+Requires: Ice = ${version} +Requires: Ice = ${version}
--- /dev/null 2015-06-27 16:44:15.733558105 +0200 --- /dev/null 2015-06-27 16:44:15.733558105 +0200
+++ ice-3.6.3/csharp/lib/pkgconfig/IceDiscovery.pc 2015-06-27 20:20:44.312515987 +0200 +++ ice-3.6.4/csharp/lib/pkgconfig/IceDiscovery.pc 2015-06-27 20:20:44.312515987 +0200
@@ -0,0 +1,10 @@ @@ -0,0 +1,10 @@
+version = 3.6.3 +version = 3.6.4
+mono_root = /usr +mono_root = /usr
+ +
+name = IceDiscovery +name = IceDiscovery
@ -36,9 +36,9 @@
+Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll +Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
+Requires: Ice = ${version} +Requires: Ice = ${version}
--- /dev/null 2015-06-27 16:44:15.733558105 +0200 --- /dev/null 2015-06-27 16:44:15.733558105 +0200
+++ ice-3.6.3/csharp/lib/pkgconfig/IceLocatorDiscovery.pc 2015-06-27 20:21:22.206185123 +0200 +++ ice-3.6.4/csharp/lib/pkgconfig/IceLocatorDiscovery.pc 2015-06-27 20:21:22.206185123 +0200
@@ -0,0 +1,10 @@ @@ -0,0 +1,10 @@
+version = 3.6.3 +version = 3.6.4
+mono_root = /usr +mono_root = /usr
+ +
+name = IceLocatorDiscovery +name = IceLocatorDiscovery