[dev-python/pymongocrypt] replace test with sed from pymongo
This commit is contained in:
parent
3be784dbc2
commit
50976c650d
@ -1,22 +0,0 @@
|
|||||||
--- a/pyproject.toml 2020-02-02 01:00:00.000000000 +0100
|
|
||||||
+++ b/pyproject.toml 2024-06-27 00:04:16.829810520 +0200
|
|
||||||
@@ -1,5 +1,5 @@
|
|
||||||
[build-system]
|
|
||||||
-requires = ["hatchling>1.24","hatch-requirements-txt>=0.4.1"]
|
|
||||||
+requires = ["hatchling>1.24"]
|
|
||||||
build-backend = "hatchling.build"
|
|
||||||
|
|
||||||
[project]
|
|
||||||
@@ -49,12 +49,6 @@
|
|
||||||
# Used to call hatch_build.py
|
|
||||||
[tool.hatch.build.hooks.custom]
|
|
||||||
|
|
||||||
-[tool.hatch.metadata.hooks.requirements_txt]
|
|
||||||
-files = ["requirements.txt"]
|
|
||||||
-
|
|
||||||
-[tool.hatch.metadata.hooks.requirements_txt.optional-dependencies]
|
|
||||||
-test = ["requirements-test.txt"]
|
|
||||||
-
|
|
||||||
[tool.ruff.lint]
|
|
||||||
select = [
|
|
||||||
"E", "F", "W", # flake8
|
|
@ -35,12 +35,14 @@ BDEPEND="
|
|||||||
)
|
)
|
||||||
"
|
"
|
||||||
|
|
||||||
PATCHES=(
|
|
||||||
"${FILESDIR}/${P}-no-req-text.patch"
|
|
||||||
)
|
|
||||||
|
|
||||||
distutils_enable_tests pytest
|
distutils_enable_tests pytest
|
||||||
|
|
||||||
|
src_prepare() {
|
||||||
|
distutils-r1_src_prepare
|
||||||
|
# we do not want hatch-requirements-txt and its ton of NIH deps
|
||||||
|
sed -i -e '/requirements/d' pyproject.toml || die
|
||||||
|
}
|
||||||
|
|
||||||
python_test() {
|
python_test() {
|
||||||
local EPYTEST_DESELECT=(
|
local EPYTEST_DESELECT=(
|
||||||
# slow
|
# slow
|
||||||
|
Loading…
Reference in New Issue
Block a user