[dev-libs/libmongocrypt] bump

This commit is contained in:
Robert Förster 2024-08-03 07:50:31 +02:00
parent ee33e935c7
commit 5f3651dab4
5 changed files with 1 additions and 76 deletions

View File

@ -1 +1 @@
DIST libmongocrypt-1.10.1.tar.gz 4167038 BLAKE2B e4b9e5e94279a5966f1ea77cd8aa5b0666a43d4bc3209d4b2e3917485d4e645a43ad1d44a1213f41298d24ee142a9d29cd94ca3c1a78f8d6e59df36c227ecdc8 SHA512 bf849be7f97a465aa840088af3f541fb19aa652de59760ce51193c157f7dd335f54d3b46fb12b97d7fecb4da4333e12b1c8dd3a3f31acbe4f907b6d12d900e51 DIST libmongocrypt-1.11.0.tar.gz 4121234 BLAKE2B 479d841413ac9bedcda738b3c16b1f40641c6ef423b1ac124226c1e91093d3010454b43f7c456ae616b98d0d8d839ddef4792e9b254ef4658e4281ba21ee11a9 SHA512 1c7686c761a90d6a9b5a6e991ef03fa1fb89e904ee8b0837cd28ba125d258edcbd073849b0baec1f70e1becb0523c92baf9ba736aeb2e8c1fb7a551780d30bdc

View File

@ -1,49 +0,0 @@
From d8f335e3df9dccbfea1af5651b895f37a740a72e Mon Sep 17 00:00:00 2001
From: Kevin Albertson <kevin.albertson@mongodb.com>
Date: Mon, 8 Jul 2024 10:35:32 -0400
Subject: [PATCH] MONGOCRYPT-706 clear `BUILD_VERSION` before including C
driver (#855)
* MONGOCRYPT-706 clear `BUILD_VERSION` before including C driver
To prevent applying `BUILD_VERSION` intended for libmongocrypt to the C driver.
---
cmake/ImportBSON.cmake | 17 +++++++++++++++--
1 file changed, 15 insertions(+), 2 deletions(-)
diff --git a/cmake/ImportBSON.cmake b/cmake/ImportBSON.cmake
index 58d863b87..fac2cb921 100644
--- a/cmake/ImportBSON.cmake
+++ b/cmake/ImportBSON.cmake
@@ -142,9 +142,16 @@ function (_import_bson)
set (ENABLE_EXTRA_ALIGNMENT ${_extra_alignment_default} CACHE BOOL "Toggle extra alignment of bson_t")
# We don't want the subproject to find libmongocrypt
set (ENABLE_CLIENT_SIDE_ENCRYPTION OFF CACHE BOOL "Disable client-side encryption for the libmongoc subproject")
- # Set `BUILD_VERSION` so C driver does not use a `BUILD_VERSION` meant for libmongocrypt.
+ # Clear `BUILD_VERSION` so C driver does not use a `BUILD_VERSION` meant for libmongocrypt.
# Both libmongocrypt and C driver support setting a `BUILD_VERSION` to override the version.
- set (BUILD_VERSION ${MONGOC_FETCH_TAG_FOR_LIBBSON})
+ if (DEFINED CACHE{BUILD_VERSION})
+ set (saved_cached_build_version "${BUILD_VERSION}")
+ unset (BUILD_VERSION CACHE) # Undefine cache variable.
+ endif ()
+ if (DEFINED BUILD_VERSION)
+ set (saved_build_version "${BUILD_VERSION}")
+ unset (BUILD_VERSION) # Undefine normal variable.
+ endif ()
# Disable building tests in C driver:
set (ENABLE_TESTS OFF)
set (BUILD_TESTING OFF)
@@ -157,6 +164,12 @@ function (_import_bson)
else ()
add_subdirectory ("${MONGOCRYPT_MONGOC_DIR}" _mongo-c-driver EXCLUDE_FROM_ALL)
endif ()
+ if (DEFINED saved_cached_build_version)
+ set (BUILD_VERSION "${saved_cached_build_version}" CACHE STRING "Library version")
+ endif ()
+ if (DEFINED saved_build_version)
+ set (BUILD_VERSION "${saved_build_version}")
+ endif ()
if (TARGET mongoc_static)
# Workaround: Embedded mongoc_static does not set its INCLUDE_DIRECTORIES for user targets
target_include_directories (mongoc_static

View File

@ -1,24 +0,0 @@
From 0fd2c3d04a17e4957c4b4fcc838de12756de3311 Mon Sep 17 00:00:00 2001
From: Kevin Albertson <kevin.albertson@mongodb.com>
Date: Mon, 17 Jun 2024 13:33:40 -0400
Subject: [PATCH] enable policy CMP0135 (#835)
---
CMakeLists.txt | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4285f3d39..fe09b8857 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,10 @@ elseif (DEFINED CMAKE_MSVC_RUNTIME_LIBRARY)
message (WARNING "The CMAKE_MSVC_RUNTIME_LIBRARY variable is set, but CMake is too old to understand it")
endif ()
+if (POLICY CMP0135)
+ cmake_policy (SET CMP0135 NEW)
+endif ()
+
project (mongocrypt C)
# Used for the csfle-markup util:

View File

@ -25,8 +25,6 @@ DEPEND="${RDEPEND}
)" )"
PATCHES=( PATCHES=(
"${FILESDIR}/${P}-cmake.patch"
"${FILESDIR}/${P}-build-version.patch"
"${FILESDIR}/${P}-static.patch" "${FILESDIR}/${P}-static.patch"
) )