fixed ebuilds broken by carelessly "converting" them to EAPI6

This commit is contained in:
Robert Förster 2016-02-10 18:21:19 +01:00
parent c47d5cf824
commit 6312828428
10 changed files with 76 additions and 110 deletions

View File

@ -4,7 +4,7 @@
EAPI="6" EAPI="6"
inherit cmake-multilib inherit cmake-utils multilib-minimal
DESCRIPTION="library to read and write MPQ archives" DESCRIPTION="library to read and write MPQ archives"
HOMEPAGE="http://www.zezula.net/en/mpq/main.html" HOMEPAGE="http://www.zezula.net/en/mpq/main.html"
@ -23,12 +23,13 @@ DEPEND="dev-libs/libtomcrypt[static-libs?,${MULTILIB_USEDEP}]
RDEPEND="${DEPEND}" RDEPEND="${DEPEND}"
src_prepare() { src_prepare() {
epatch "${FILESDIR}/${PN}-multilib.patch" eapply "${FILESDIR}/${PN}-multilib.patch"
default
} }
src_configure() { multilib_src_configure() {
local mycmakeargs=" local mycmakeargs=(
-DWITH_LIBTOMCRYPT=ON" -DWITH_LIBTOMCRYPT=ON)
cmake-multilib_src_configure cmake-utils_src_configure
} }

View File

@ -1,5 +1,5 @@
--- CMakeLists.txt.old 2013-11-12 18:53:57.930000000 +0100 --- a/CMakeLists.txt
+++ CMakeLists.txt 2013-11-12 18:57:20.700000000 +0100 +++ b/CMakeLists.txt
@@ -281,7 +281,7 @@ @@ -281,7 +281,7 @@
add_library(storm_static STATIC ${SRC_FILES} ${SRC_ADDITIONAL_FILES}) add_library(storm_static STATIC ${SRC_FILES} ${SRC_ADDITIONAL_FILES})
target_link_libraries(storm_static ${LINK_LIBS}) target_link_libraries(storm_static ${LINK_LIBS})

View File

@ -4,9 +4,7 @@
EAPI="6" EAPI="6"
AUTOTOOLS_AUTORECONF=1 inherit autotools eutils multilib-minimal
inherit autotools-multilib eutils
DESCRIPTION="The Battle.net client library" DESCRIPTION="The Battle.net client library"
HOMEPAGE="http://code.google.com/p/bncsutil" HOMEPAGE="http://code.google.com/p/bncsutil"
@ -22,7 +20,19 @@ IUSE="static-libs"
DEPEND="dev-libs/gmp[static-libs?,${MULTILIB_USEDEP}]" DEPEND="dev-libs/gmp[static-libs?,${MULTILIB_USEDEP}]"
RDEPEND="${DEPEND}" RDEPEND="${DEPEND}"
PATCHES=( src_prepare() {
"${FILESDIR}/${PN}-werror.patch" eapply "${FILESDIR}/${PN}-werror.patch"
"${FILESDIR}/${PN}-ghost.patch" eapply "${FILESDIR}/${PN}-ghost.patch"
) eautoreconf
default
multilib_copy_sources
}
multilib_src_configure() {
econf $(use_enable static-libs static)
}
multilib_src_install() {
default
prune_libtool_files
}

View File

@ -1,7 +1,5 @@
Index: src/bncsutil/bsha1.cpp --- a/src/bncsutil/bsha1.cpp
=================================================================== +++ b/src/bncsutil/bsha1.cpp
--- src/bncsutil/bsha1.cpp (revision 5)
+++ src/bncsutil/bsha1.cpp (working copy)
@@ -141,7 +141,7 @@ @@ -141,7 +141,7 @@
MEXP(void) calcHashBuf(const char* input, size_t length, char* result) { MEXP(void) calcHashBuf(const char* input, size_t length, char* result) {
@ -11,10 +9,8 @@ Index: src/bncsutil/bsha1.cpp
uint32_t* ldata; uint32_t* ldata;
char data[1024]; char data[1024];
memset(data, 0, 1024); memset(data, 0, 1024);
Index: src/bncsutil/cdkeydecoder.cpp --- a/src/bncsutil/cdkeydecoder.cpp
=================================================================== +++ b/src/bncsutil/cdkeydecoder.cpp
--- src/bncsutil/cdkeydecoder.cpp (revision 5)
+++ src/bncsutil/cdkeydecoder.cpp (working copy)
@@ -31,7 +31,8 @@ @@ -31,7 +31,8 @@
#include <cctype> // for isdigit(), isalnum(), and toupper() #include <cctype> // for isdigit(), isalnum(), and toupper()
#include <cstring> // for memcpy() #include <cstring> // for memcpy()
@ -43,10 +39,8 @@ Index: src/bncsutil/cdkeydecoder.cpp
table[a] = (decode / 5); table[a] = (decode / 5);
table[b] = (decode % 5); table[b] = (decode % 5);
} }
Index: src/bncsutil/checkrevision.cpp --- a/src/bncsutil/checkrevision.cpp
=================================================================== +++ b/src/bncsutil/checkrevision.cpp
--- src/bncsutil/checkrevision.cpp (revision 5)
+++ src/bncsutil/checkrevision.cpp (working copy)
@@ -83,13 +83,14 @@ @@ -83,13 +83,14 @@
checkrevision_seeds.push_back(0x11BF6A18); checkrevision_seeds.push_back(0x11BF6A18);
checkrevision_seeds.push_back(0xC57292E6); checkrevision_seeds.push_back(0xC57292E6);
@ -174,10 +168,8 @@ Index: src/bncsutil/checkrevision.cpp
switch (platform) { switch (platform) {
case BNCSUTIL_PLATFORM_X86: case BNCSUTIL_PLATFORM_X86:
Index: src/bncsutil/debug.c --- a/src/bncsutil/debug.c
=================================================================== +++ b/src/bncsutil/debug.c
--- src/bncsutil/debug.c (revision 5)
+++ src/bncsutil/debug.c (working copy)
@@ -18,7 +18,7 @@ @@ -18,7 +18,7 @@
#include <time.h> #include <time.h>
#endif #endif
@ -273,10 +265,8 @@ Index: src/bncsutil/debug.c
return (size_t) 0; return (size_t) 0;
return (size_t) info.dwSize.X; return (size_t) info.dwSize.X;
#else #else
Index: src/bncsutil/debug.h --- a/src/bncsutil/debug.h
=================================================================== +++ b/src/bncsutil/debug.h
--- src/bncsutil/debug.h (revision 5)
+++ src/bncsutil/debug.h (working copy)
@@ -6,86 +6,99 @@ @@ -6,86 +6,99 @@
* April 1, 2006 * April 1, 2006
*/ */
@ -444,10 +434,8 @@ Index: src/bncsutil/debug.h
- -
-#endif /* DEBUG */ -#endif /* DEBUG */
\ No newline at end of file \ No newline at end of file
Index: src/bncsutil/file.cpp --- a/src/bncsutil/file.cpp
=================================================================== +++ b/src/bncsutil/file.cpp
--- src/bncsutil/file.cpp (revision 5)
+++ src/bncsutil/file.cpp (working copy)
@@ -44,7 +44,7 @@ @@ -44,7 +44,7 @@
DWORD access; DWORD access;
DWORD share_mode; DWORD share_mode;
@ -616,10 +604,8 @@ Index: src/bncsutil/file.cpp
return; return;
} }
Index: src/bncsutil/keytables.h --- a/src/bncsutil/keytables.h
=================================================================== +++ b/src/bncsutil/keytables.h
--- src/bncsutil/keytables.h (revision 5)
+++ src/bncsutil/keytables.h (working copy)
@@ -128,4 +128,4 @@ @@ -128,4 +128,4 @@
} // extern "C" } // extern "C"
#endif #endif
@ -627,10 +613,8 @@ Index: src/bncsutil/keytables.h
-#endif /* BNCSUTIL_KEYTABLES_H */ -#endif /* BNCSUTIL_KEYTABLES_H */
\ No newline at end of file \ No newline at end of file
+#endif /* BNCSUTIL_KEYTABLES_H */ +#endif /* BNCSUTIL_KEYTABLES_H */
Index: src/bncsutil/libinfo.cpp --- a/src/bncsutil/libinfo.cpp
=================================================================== +++ b/src/bncsutil/libinfo.cpp
--- src/bncsutil/libinfo.cpp (revision 5)
+++ src/bncsutil/libinfo.cpp (working copy)
@@ -49,9 +49,8 @@ @@ -49,9 +49,8 @@
rev = ver; rev = ver;
if (rev > 99 || rev < 0) return 0; if (rev > 99 || rev < 0) return 0;
@ -643,10 +627,8 @@ Index: src/bncsutil/libinfo.cpp
} }
- -
\ No newline at end of file \ No newline at end of file
Index: src/bncsutil/mutil.h --- a/src/bncsutil/mutil.h
=================================================================== +++ b/src/bncsutil/mutil.h
--- src/bncsutil/mutil.h (revision 5)
+++ src/bncsutil/mutil.h (working copy)
@@ -27,6 +27,9 @@ @@ -27,6 +27,9 @@
#ifndef MUTIL_H #ifndef MUTIL_H
#define MUTIL_H #define MUTIL_H
@ -679,10 +661,8 @@ Index: src/bncsutil/mutil.h
+// #include <bncsutil/debug.h> +// #include <bncsutil/debug.h>
#endif /* MUTIL_H */ #endif /* MUTIL_H */
Index: src/bncsutil/mutil_types.h --- a/src/bncsutil/mutil_types.h
=================================================================== +++ b/src/bncsutil/mutil_types.h
--- src/bncsutil/mutil_types.h (revision 5)
+++ src/bncsutil/mutil_types.h (working copy)
@@ -26,6 +26,10 @@ @@ -26,6 +26,10 @@
#ifndef BNCSUTIL_MUTIL_TYPES_H_INCLUDED #ifndef BNCSUTIL_MUTIL_TYPES_H_INCLUDED
#define BNCSUTIL_MUTIL_TYPES_H_INCLUDED #define BNCSUTIL_MUTIL_TYPES_H_INCLUDED
@ -701,10 +681,8 @@ Index: src/bncsutil/mutil_types.h
+#endif /* WIN32 */ +#endif /* WIN32 */
+ +
#endif /* BNCSUTIL_MUTIL_TYPES_H_INCLUDED */ #endif /* BNCSUTIL_MUTIL_TYPES_H_INCLUDED */
Index: src/bncsutil/oldauth.cpp --- a/src/bncsutil/oldauth.cpp
=================================================================== +++ b/src/bncsutil/oldauth.cpp
--- src/bncsutil/oldauth.cpp (revision 5)
+++ src/bncsutil/oldauth.cpp (working copy)
@@ -64,4 +64,4 @@ @@ -64,4 +64,4 @@
bncsutil_debug_message_a("hashPassword(\"%s\") =", password); bncsutil_debug_message_a("hashPassword(\"%s\") =", password);
bncsutil_debug_dump(outBuffer, 20); bncsutil_debug_dump(outBuffer, 20);
@ -712,10 +690,8 @@ Index: src/bncsutil/oldauth.cpp
-} -}
\ No newline at end of file \ No newline at end of file
+} +}
Index: src/bncsutil/oldauth.h --- a/src/bncsutil/oldauth.h
=================================================================== +++ b/src/bncsutil/oldauth.h
--- src/bncsutil/oldauth.h (revision 5)
+++ src/bncsutil/oldauth.h (working copy)
@@ -46,4 +46,4 @@ @@ -46,4 +46,4 @@
} // extern "C" } // extern "C"
#endif #endif
@ -723,10 +699,8 @@ Index: src/bncsutil/oldauth.h
-#endif /* BNCSUTIL_OLDAUTH_H */ -#endif /* BNCSUTIL_OLDAUTH_H */
\ No newline at end of file \ No newline at end of file
+#endif /* BNCSUTIL_OLDAUTH_H */ +#endif /* BNCSUTIL_OLDAUTH_H */
Index: src/bncsutil/pe.c --- a/src/bncsutil/pe.c
=================================================================== +++ b/src/bncsutil/pe.c
--- src/bncsutil/pe.c (revision 5)
+++ src/bncsutil/pe.c (working copy)
@@ -37,7 +37,7 @@ @@ -37,7 +37,7 @@
cm_pe_optional_header_t* opt_header; cm_pe_optional_header_t* opt_header;
cm_pe_windows_header_t* win_header; cm_pe_windows_header_t* win_header;
@ -761,10 +735,8 @@ Index: src/bncsutil/pe.c
-} -}
\ No newline at end of file \ No newline at end of file
+} +}
Index: src/bncsutil/stack.c --- a/src/bncsutil/stack.c
=================================================================== +++ b/src/bncsutil/stack.c
--- src/bncsutil/stack.c (revision 5)
+++ src/bncsutil/stack.c (working copy)
@@ -20,7 +20,8 @@ @@ -20,7 +20,8 @@
* A copy of the GNU Lesser General Public License is included in the BNCSutil * A copy of the GNU Lesser General Public License is included in the BNCSutil
* distribution in the file COPYING. If you did not receive this copy, * distribution in the file COPYING. If you did not receive this copy,
@ -782,10 +754,8 @@ Index: src/bncsutil/stack.c
-} -}
\ No newline at end of file \ No newline at end of file
+} +}
Index: src/bncsutil/stack.h --- a/src/bncsutil/stack.h
=================================================================== +++ b/src/bncsutil/stack.h
--- src/bncsutil/stack.h (revision 5)
+++ src/bncsutil/stack.h (working copy)
@@ -51,4 +51,4 @@ @@ -51,4 +51,4 @@
void* cm_stack_peek(cm_stack_t stack); void* cm_stack_peek(cm_stack_t stack);
unsigned int cm_stack_size(cm_stack_t stack); unsigned int cm_stack_size(cm_stack_t stack);

View File

@ -1,7 +1,5 @@
Index: configure.ac --- a/configure.ac
=================================================================== +++ b/configure.ac
--- configure.ac (revision 5)
+++ configure.ac (working copy)
@@ -1,6 +1,6 @@ @@ -1,6 +1,6 @@
AC_INIT([bncsutil], [1.3.2], [bugs@example.com]) AC_INIT([bncsutil], [1.3.2], [bugs@example.com])

View File

@ -1,7 +1,5 @@
Index: ghost/ghost.cpp --- a/ghost/ghost.cpp
=================================================================== +++ b/ghost/ghost.cpp
--- ghost/ghost.cpp (revision 573)
+++ ghost/ghost.cpp (working copy)
@@ -233,15 +233,23 @@ @@ -233,15 +233,23 @@
{ {
srand( time( NULL ) ); srand( time( NULL ) );

View File

@ -1,7 +1,5 @@
Index: ghost/ghost.cpp --- a/ghost/ghost.cpp
=================================================================== +++ b/ghost/ghost.cpp
--- ghost/ghost.cpp (revision 600)
+++ ghost/ghost.cpp (working copy)
@@ -677,12 +677,20 @@ @@ -677,12 +677,20 @@
if( m_AdminGamePort == m_HostPort ) if( m_AdminGamePort == m_HostPort )
CONSOLE_Print( "[GHOST] warning - admingame_port and bot_hostport are set to the same value, you won't be able to host any games" ); CONSOLE_Print( "[GHOST] warning - admingame_port and bot_hostport are set to the same value, you won't be able to host any games" );
@ -100,10 +98,8 @@ Index: ghost/ghost.cpp
void CGHost :: EventBNETConnecting( CBNET *bnet ) void CGHost :: EventBNETConnecting( CBNET *bnet )
{ {
if( m_AdminGame ) if( m_AdminGame )
Index: ghost/ghost.h --- a/ghost/ghost.h
=================================================================== +++ b/ghost/ghost.h
--- ghost/ghost.h (revision 600)
+++ ghost/ghost.h (working copy)
@@ -134,6 +134,8 @@ @@ -134,6 +134,8 @@
bool m_TCPNoDelay; // config value: use Nagle's algorithm or not bool m_TCPNoDelay; // config value: use Nagle's algorithm or not
uint32_t m_MatchMakingMethod; // config value: the matchmaking method uint32_t m_MatchMakingMethod; // config value: the matchmaking method

View File

@ -1,7 +1,5 @@
Index: ghost/ghostdbsqlite.cpp --- a/ghost/ghostdbsqlite.cpp
=================================================================== +++ b/ghost/ghostdbsqlite.cpp
--- ghost/ghostdbsqlite.cpp (revision 580)
+++ ghost/ghostdbsqlite.cpp (working copy)
@@ -23,8 +23,9 @@ @@ -23,8 +23,9 @@
#include "config.h" #include "config.h"
#include "ghostdb.h" #include "ghostdb.h"

View File

@ -1,7 +1,5 @@
Index: ghost/ghost.cpp --- a/ghost/ghost.cpp
=================================================================== +++ b/ghost/ghost.cpp
--- ghost/ghost.cpp (revision 600)
+++ ghost/ghost.cpp (working copy)
@@ -48,7 +48,7 @@ @@ -48,7 +48,7 @@
#endif #endif
@ -29,10 +27,8 @@ Index: ghost/ghost.cpp
{ {
CONSOLE_Print( "[GHOST] extracting Scripts\\blizzard.j from MPQ file to [" + m_MapCFGPath + "blizzard.j]" ); CONSOLE_Print( "[GHOST] extracting Scripts\\blizzard.j from MPQ file to [" + m_MapCFGPath + "blizzard.j]" );
UTIL_FileWrite( m_MapCFGPath + "blizzard.j", (unsigned char *)SubFileData, BytesRead ); UTIL_FileWrite( m_MapCFGPath + "blizzard.j", (unsigned char *)SubFileData, BytesRead );
Index: ghost/map.cpp --- a/ghost/map.cpp
=================================================================== +++ b/ghost/map.cpp
--- ghost/map.cpp (revision 600)
+++ ghost/map.cpp (working copy)
@@ -26,7 +26,7 @@ @@ -26,7 +26,7 @@
#include "map.h" #include "map.h"
@ -78,10 +74,8 @@ Index: ghost/map.cpp
{ {
istringstream ISS( string( SubFileData, BytesRead ) ); istringstream ISS( string( SubFileData, BytesRead ) );
Index: ghost/socket.h --- a/ghost/socket.h
=================================================================== +++ b/ghost/socket.h
--- ghost/socket.h (revision 600)
+++ ghost/socket.h (working copy)
@@ -79,8 +79,6 @@ @@ -79,8 +79,6 @@
#define SOCKET_ERROR -1 #define SOCKET_ERROR -1

View File

@ -38,12 +38,13 @@ src_prepare() {
cp "${FILESDIR}/CMakeLists.txt" "${S}" cp "${FILESDIR}/CMakeLists.txt" "${S}"
cp -r "${FILESDIR}/cmake" "${S}" cp -r "${FILESDIR}/cmake" "${S}"
cp "${FILESDIR}/ghost++.cfg" "${S}" cp "${FILESDIR}/ghost++.cfg" "${S}"
default
} }
src_configure() { src_configure() {
local mycmakeargs=" local mycmakeargs=(
-DCONFIGPATH="${EROOT}etc/ghost++/" $(cmake-utils_use_find_package mysql MySQL)
$(cmake-utils_use_with mysql MYSQL)" -DCONFIGPATH="${EROOT}etc/ghost++/")
cmake-utils_src_configure cmake-utils_src_configure
} }