[app-emulation/qemu] sync
This commit is contained in:
parent
ca4f63d31c
commit
6e9ee5f42d
50
app-emulation/qemu/files/qemu-2.1.2-vnc-sanitize-bits.patch
Normal file
50
app-emulation/qemu/files/qemu-2.1.2-vnc-sanitize-bits.patch
Normal file
@ -0,0 +1,50 @@
|
|||||||
|
https://bugs.gentoo.org/527088
|
||||||
|
|
||||||
|
From e6908bfe8e07f2b452e78e677da1b45b1c0f6829 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Petr Matousek <pmatouse@redhat.com>
|
||||||
|
Date: Mon, 27 Oct 2014 12:41:44 +0100
|
||||||
|
Subject: [PATCH] vnc: sanitize bits_per_pixel from the client
|
||||||
|
|
||||||
|
bits_per_pixel that are less than 8 could result in accessing
|
||||||
|
non-initialized buffers later in the code due to the expectation
|
||||||
|
that bytes_per_pixel value that is used to initialize these buffers is
|
||||||
|
never zero.
|
||||||
|
|
||||||
|
To fix this check that bits_per_pixel from the client is one of the
|
||||||
|
values that the rfb protocol specification allows.
|
||||||
|
|
||||||
|
This is CVE-2014-7815.
|
||||||
|
|
||||||
|
Signed-off-by: Petr Matousek <pmatouse@redhat.com>
|
||||||
|
|
||||||
|
[ kraxel: apply codestyle fix ]
|
||||||
|
|
||||||
|
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
|
||||||
|
---
|
||||||
|
ui/vnc.c | 10 ++++++++++
|
||||||
|
1 file changed, 10 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/ui/vnc.c b/ui/vnc.c
|
||||||
|
index 0fe6eff..8bca597 100644
|
||||||
|
--- a/ui/vnc.c
|
||||||
|
+++ b/ui/vnc.c
|
||||||
|
@@ -2026,6 +2026,16 @@ static void set_pixel_format(VncState *vs,
|
||||||
|
return;
|
||||||
|
}
|
||||||
|
|
||||||
|
+ switch (bits_per_pixel) {
|
||||||
|
+ case 8:
|
||||||
|
+ case 16:
|
||||||
|
+ case 32:
|
||||||
|
+ break;
|
||||||
|
+ default:
|
||||||
|
+ vnc_client_error(vs);
|
||||||
|
+ return;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
vs->client_pf.rmax = red_max;
|
||||||
|
vs->client_pf.rbits = hweight_long(red_max);
|
||||||
|
vs->client_pf.rshift = red_shift;
|
||||||
|
--
|
||||||
|
2.1.2
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
# Copyright 1999-2014 Gentoo Foundation
|
# Copyright 1999-2014 Gentoo Foundation
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-2.1.2.ebuild,v 1.1 2014/10/16 13:21:59 vapier Exp $
|
# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-2.1.2-r1.ebuild,v 1.1 2014/10/31 00:17:46 vapier Exp $
|
||||||
|
|
||||||
EAPI=5
|
EAPI=5
|
||||||
|
|
||||||
@ -259,6 +259,7 @@ src_prepare() {
|
|||||||
|
|
||||||
epatch "${FILESDIR}"/qemu-1.7.0-cflags.patch
|
epatch "${FILESDIR}"/qemu-1.7.0-cflags.patch
|
||||||
epatch "${FILESDIR}"/${PN}-2.1.1-readlink-self.patch
|
epatch "${FILESDIR}"/${PN}-2.1.1-readlink-self.patch
|
||||||
|
epatch "${FILESDIR}"/${PN}-2.1.2-vnc-sanitize-bits.patch #527088
|
||||||
[[ -n ${BACKPORTS} ]] && \
|
[[ -n ${BACKPORTS} ]] && \
|
||||||
EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
|
EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
|
||||||
epatch
|
epatch
|
Loading…
Reference in New Issue
Block a user