[dev-libs/Ice] bump. this is for tree now

This commit is contained in:
Robert Förster 2022-09-10 09:52:17 +02:00
parent 509b398bd0
commit 7d1fb3067d
7 changed files with 2 additions and 40 deletions

View File

@ -51,7 +51,6 @@ S="${WORKDIR}/${P,}"
PHP_EXT_S="${S}/php"
PATCHES=(
"${FILESDIR}/${P}-fix-python-version-check.patch"
"${FILESDIR}/${P}-fix-musl-build.patch"
)

View File

@ -51,7 +51,6 @@ S="${WORKDIR}/${P,}"
PHP_EXT_S="${S}/php"
PATCHES=(
"${FILESDIR}/${P}-fix-python-version-check.patch"
"${FILESDIR}/${P}-fix-musl-build.patch"
)

View File

@ -51,7 +51,6 @@ S="${WORKDIR}/${P,}"
PHP_EXT_S="${S}/php"
PATCHES=(
"${FILESDIR}/${P}-fix-python-version-check.patch"
"${FILESDIR}/${P}-fix-musl-build.patch"
)

View File

@ -53,7 +53,7 @@ S="${WORKDIR}/${PN}"
PHP_EXT_S="${S}/php"
PATCHES=(
"${FILESDIR}/${PN}-3.7.7-fix-musl-build.patch"
"${FILESDIR}/${PN}-3.7.8-fix-musl-build.patch"
)
pkg_setup() {

View File

@ -1,2 +1,2 @@
DIST Ice-3.7.1.pdf 9351739 BLAKE2B 527f2c37aea19aedbfc580efd93ce4fae2eb7264342bb485822593e2da6fb75a61eea2b1a46187898af07f138d10bf9a213d0b2a0685c18cd1d4c624709a935b SHA512 199b59f14b87b2896ba970bf5aa32f6fd858cbd3fed18eac93acafe4e296db1361ca2d2000ed49f3390ed66c1d4ff8c1fcd3f14ab8197d7804c87fce422c8486
DIST Ice-3.7.7.tar.gz 10848321 BLAKE2B 51c695e9c9d75293122e3bc914662c264b4c354efe085697e3d5a8b1c89abedc1d34a809b1767a0f6f64f22c086a19d71bdd9622e7bca7d0184b5b53f0a7fd1a SHA512 73c3a2bb14c9e145383e4026206edd3e03b29c60a33af628611bfdab71d69a3aed108ce4e6cbfd67eb852560110e3495b4bd238c8cdf0de9d1f8e2f1088513ee
DIST Ice-3.7.8.tar.gz 11056950 BLAKE2B 66686d6e66a997badef53ee30782775047a2fa39d70fa8ed73c5e7a1bad3c3899efd8d68f557a416caacd65860a73834a6bdc3188730fa19a3f1e47f028c5e21 SHA512 eb5863cb5e83000199c27a5a505a19e5f1ec05e8575eb9cdc03f6db30447212e3b02e6adc70fb2ae6ddc63cfd93bc2b6b290f38919364ee9f08b238a0aa11e88

View File

@ -1,35 +0,0 @@
From 8daf1ed1f4ea0dd0f548d37875bdf5fbd7e9e950 Mon Sep 17 00:00:00 2001
From: Jose <pepone@users.noreply.github.com>
Date: Wed, 13 Jul 2022 09:08:03 +0200
Subject: [PATCH] Fix python version check (#1381)
---
python/config/Make.rules | 1 -
python/python/Makefile | 2 +-
2 files changed, 1 insertion(+), 2 deletions(-)
diff --git a/python/config/Make.rules b/python/config/Make.rules
index 7a1c0f47480..d414db7933b 100644
--- a/python/config/Make.rules
+++ b/python/config/Make.rules
@@ -16,7 +16,6 @@ PYTHON ?= python3
-include $(lang_srcdir)/config/Make.rules.$(os)
# PYTHON must be set to a value that has a corresponding PYTHON-config
-python-version := $(shell $(PYTHON) -c "import sys; print(\"{0}.{1}\".format(sys.version_info[0], sys.version_info[1]))")
python-config := $(PYTHON)-config
ifeq ($(os),Linux)
diff --git a/python/python/Makefile b/python/python/Makefile
index f5bb725a3af..ba1df33e586 100644
--- a/python/python/Makefile
+++ b/python/python/Makefile
@@ -32,7 +32,7 @@ install:: | $(DESTDIR)$(install_pythondir)/Ice
$(E) "Installing generated code"
$(Q)$(INSTALL) -m 644 Ice/__init__.py $(DESTDIR)$(install_pythondir)/Ice
# Ice/Future requires python >= 3.5
-ifeq ($(shell $(PYTHON) -c "print(1 if $(python-version) >= 3.5 else 0)"),1)
+ifeq ($(shell $(PYTHON) -c "import sys; print(1 if sys.version_info[:2] >= (3, 5) else 0)"),1)
$(Q)$(MKDIR) -p -m 755 $(DESTDIR)$(install_pythondir)/Ice/Py3
$(Q)$(INSTALL) -m 644 Ice/Py3/IceFuture.py $(DESTDIR)$(install_pythondir)/Ice/Py3/
endif