[net-nds/389-ds-base] version bump

This commit is contained in:
Robert Förster 2020-12-07 16:29:54 +01:00
parent 31f95d1e0b
commit 7e7549c302
3 changed files with 37 additions and 154 deletions

View File

@ -78,7 +78,7 @@ IUSE="${IUSE_PLUGINS} +autobind auto-dn-suffix debug doc +ldapi selinux systemd"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# these don't work with userpriv but somehow also not without it
# lib389 tests (which is most of the suite) can't find their own modules.
RESTRICT="test"
# always list newer first
@ -111,7 +111,8 @@ DEPEND="
systemd? ( >=sys-apps/systemd-244 )
"
BDEPEND="virtual/pkgconfig
BDEPEND=">=sys-devel/autoconf-2.69-r5
virtual/pkgconfig
${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/argparse-manpage[${PYTHON_MULTI_USEDEP}]
@ -149,7 +150,6 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-db-gentoo.patch"
"${FILESDIR}/${P}-musl-and-nspr-build.patch"
)
distutils_enable_tests pytest
@ -162,35 +162,43 @@ src_prepare() {
Makefile.am || die
fi
# GH issue 4092
sed -i \
-e 's|@localstatedir@/run|/run|' \
ldap/admin/src/defaults.inf.in || die
default
eautoreconf
}
src_configure() {
econf \
$(use_enable accountpolicy acctpolicy) \
$(use_enable bitwise) \
$(use_enable dna) \
$(use_enable pam-passthru) \
$(use_enable autobind) \
$(use_enable auto-dn-suffix) \
$(use_enable debug) \
$(use_enable ldapi) \
$(use_with selinux) \
$(use_with systemd) \
$(use_with systemd systemdsystemunitdir "$(systemd_get_systemunitdir)") \
$(use_with systemd systemdgroupname "dirsrv.target") \
$(use_with systemd tmpfiles-d "/usr/lib/tmpfiles.d") \
$(use_with !systemd initddir "/etc/init.d") \
$(use_enable test cmocka) \
--enable-rust \
--enable-rust-offline \
--with-pythonexec="${PYTHON}" \
--with-fhs \
--with-openldap \
--with-db-inc="$(db_includedir)" \
local myeconfargs=(
$(use_enable accountpolicy acctpolicy)
$(use_enable bitwise)
$(use_enable dna)
$(use_enable pam-passthru)
$(use_enable autobind)
$(use_enable auto-dn-suffix)
$(use_enable debug)
$(use_enable ldapi)
$(use_with selinux)
$(use_with systemd)
$(use_with systemd systemdgroupname "dirsrv.target")
$(use_with systemd tmpfiles-d "/usr/lib/tmpfiles.d")
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
$(use_with !systemd initddir "/etc/init.d")
$(use_enable test cmocka)
--enable-rust
--enable-rust-offline
--with-pythonexec="${PYTHON}"
--with-fhs
--with-openldap
--with-db-inc="$(db_includedir)"
--disable-cockpit
)
econf "${myeconfargs[@]}"
rm "${S}"/.cargo/config || die
}
@ -213,7 +221,8 @@ src_compile() {
src_test () {
emake check
pytest -vv dirsrvtests/tests/suites/basic/
cd "${S}"/src/lib389 || die
distutils-r1_src_test
}
src_install() {
@ -237,7 +246,7 @@ src_install() {
dodoc -r html/.
fi
cd src/lib389 || die
cd "${S}"/src/lib389 || die
distutils-r1_src_install
python_fix_shebang "${ED}"

View File

@ -1,4 +1,4 @@
DIST 389-ds-base-1.4.4.7.tar.bz2 6126035 BLAKE2B 3bc4d1090df297015a17ca396dfef05fbe360769b6ccdc9d06670e7704a4824fbb72e169dcac695808ad864b3b364a1dcd389024f95855ca3cde3749a1f89271 SHA512 c0980c2b69ac64f57675d763b5874db139a374cb8196ba969d907a9ac2fb42bffd47c8b971bf6f1514df144185a5d2c9487656c2359cbcefb66bba85bdd99092
DIST 389-ds-base-1.4.4.9.tar.bz2 6181459 BLAKE2B 8d9bbc649a7ac3bec001b82e7a90de66faff5d1d14a016346ec78a4df0911ceb19f992effd0883c5565aee8e6e57bf1eda132df4b670e5ec8b362710ea061e8d SHA512 556edae2764baad7fa99eba8005cbb203a6bb6c9f9bd91194b29c2e187ebe788230438c528757424d86be00636d08d75c894440c67506765a4d1b65fa7b05206
DIST ansi_term-0.11.0.crate 17087 BLAKE2B 9bd35c045a01ce4c6c4a5db1b4f15e9412bb97426eec19d4421dffbec633de8d13452c13c1dc1b30998690b78d7ed38311aca700087f13a81f66bd1d5d7300c4 SHA512 a637466a380748f939b3af090b8c0333f35581925bc03f4dda9b3f95d338836403cf5487ae3af9ff68f8245a837f8ab061aabe57a126a6a2c20f2e972c77d1fa
DIST atty-0.2.14.crate 5470 BLAKE2B 2db856a9e898a430258f059aeaf7c844a153293e8856d90ac81f7d91a888c89198768ad5cb09303c23241fe85c560a55148fa56a303651a82b0edb895616bfab SHA512 d7b6c4b9a0f898d91ddbc41a5ee45bbf45d1d269508c8cc87ee3e3990500e41e0ec387afb1f3bc7db55bedac396dd86c6509f4bf9e5148d809c3802edcc5e1d9
DIST autocfg-1.0.0.crate 12870 BLAKE2B 79e495d53298574afd3b292da7c9c363dcb3ea434fd44258efaf3628e95ebfc731f03083f8a1060272a2a3478a6452cdc41539e2dac08465cc6e6283844bf260 SHA512 451fc63148792ba1952b884170e3481359b01bacca5ec0456f43ca58f8e092b8f81c9764f8b00d4104059ff608089be5858220ee868127c064cc890c767ec3a3

View File

@ -1,126 +0,0 @@
From c88e97fecac4403f73242b673df195c4ae860db5 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Kaz=C4=B1m=20SARIKAYA?= <kazimsarikaya@sanaldiyar.com>
Date: Tue, 27 Oct 2020 06:34:47 +0000
Subject: [PATCH] build problems at alpine linux
---
ldap/servers/plugins/sync/sync_persist.c | 3 ---
ldap/servers/slapd/libglobs.c | 8 ++++++++
ldap/servers/slapd/main.c | 2 ++
ldap/servers/slapd/slapi2nspr.c | 3 +++
4 files changed, 13 insertions(+), 3 deletions(-)
diff --git a/ldap/servers/plugins/sync/sync_persist.c b/ldap/servers/plugins/sync/sync_persist.c
index 598c6868d..2085a4314 100644
--- a/ldap/servers/plugins/sync/sync_persist.c
+++ b/ldap/servers/plugins/sync/sync_persist.c
@@ -9,9 +9,6 @@
#include <config.h>
#endif
-#include <nspr4/prlog.h>
-#include <bits/stdint-intn.h>
-
#include "sync.h"
/* Main list of established persistent synchronizaton searches */
diff --git a/ldap/servers/slapd/libglobs.c b/ldap/servers/slapd/libglobs.c
index 7d5374c90..e82ccaa5b 100644
--- a/ldap/servers/slapd/libglobs.c
+++ b/ldap/servers/slapd/libglobs.c
@@ -251,10 +251,12 @@ slapi_onoff_t init_cn_uses_dn_syntax_in_dns;
slapi_onoff_t init_global_backend_local;
slapi_onoff_t init_enable_nunc_stans;
#if defined(LINUX)
+#if defined(__GLIBC__)
slapi_int_t init_malloc_mxfast;
slapi_int_t init_malloc_trim_threshold;
slapi_int_t init_malloc_mmap_threshold;
#endif
+#endif
slapi_onoff_t init_extract_pem;
slapi_onoff_t init_ignore_vattrs;
slapi_onoff_t init_enable_upgrade_hash;
@@ -1133,6 +1135,7 @@ static struct config_get_and_set
(void **)&global_slapdFrontendConfig.cn_uses_dn_syntax_in_dns, CONFIG_ON_OFF,
(ConfigGetFunc)config_get_cn_uses_dn_syntax_in_dns, &init_cn_uses_dn_syntax_in_dns, NULL},
#if defined(LINUX)
+#if defined(__GLIBC__)
{CONFIG_MALLOC_MXFAST, config_set_malloc_mxfast,
NULL, 0,
(void **)&global_slapdFrontendConfig.malloc_mxfast,
@@ -1148,6 +1151,7 @@ static struct config_get_and_set
(void **)&global_slapdFrontendConfig.malloc_mmap_threshold,
CONFIG_INT, (ConfigGetFunc)config_get_malloc_mmap_threshold,
&init_malloc_mmap_threshold, NULL},
+#endif
#endif
{CONFIG_IGNORE_TIME_SKEW, config_set_ignore_time_skew,
NULL, 0,
@@ -1794,9 +1798,11 @@ FrontendConfig_init(void)
cfg->rootdn = slapi_ch_strdup(SLAPD_DEFAULT_DIRECTORY_MANAGER);
init_enable_nunc_stans = cfg->enable_nunc_stans = LDAP_OFF;
#if defined(LINUX)
+#if defined(__GLIBC__)
init_malloc_mxfast = cfg->malloc_mxfast = DEFAULT_MALLOC_UNSET;
init_malloc_trim_threshold = cfg->malloc_trim_threshold = DEFAULT_MALLOC_UNSET;
init_malloc_mmap_threshold = cfg->malloc_mmap_threshold = DEFAULT_MALLOC_UNSET;
+#endif
#endif
init_extract_pem = cfg->extract_pem = LDAP_ON;
/*
@@ -8548,6 +8554,7 @@ config_get_extract_pem()
}
#if defined(LINUX)
+#if defined(__GLIBC__)
int
config_set_malloc_mxfast(const char *attrname, char *value, char *errorbuf, int apply __attribute__((unused)))
{
@@ -8675,6 +8682,7 @@ config_get_malloc_mmap_threshold()
return retVal;
}
#endif
+#endif
char *
slapi_err2string(int result)
diff --git a/ldap/servers/slapd/main.c b/ldap/servers/slapd/main.c
index 26d284f18..33f1fd1b1 100644
--- a/ldap/servers/slapd/main.c
+++ b/ldap/servers/slapd/main.c
@@ -529,6 +529,7 @@ main(int argc, char **argv)
daemon_ports_t ports_info = {0};
#ifdef LINUX
+#if defined(__GLIBC__)
char *m = getenv("SLAPD_MXFAST");
if (m) {
int val = atoi(m);
@@ -538,6 +539,7 @@ main(int argc, char **argv)
mallopt(M_MXFAST, val);
}
}
+#endif
#endif
/*
diff --git a/ldap/servers/slapd/slapi2nspr.c b/ldap/servers/slapd/slapi2nspr.c
index 232d1599e..30a687bec 100644
--- a/ldap/servers/slapd/slapi2nspr.c
+++ b/ldap/servers/slapd/slapi2nspr.c
@@ -189,11 +189,14 @@ slapi_new_rwlock_prio(int32_t prio_writer)
pthread_rwlockattr_t attr;
pthread_rwlockattr_init(&attr);
+
+#if defined(__GLIBC__)
if (prio_writer) {
pthread_rwlockattr_setkind_np(&attr, PTHREAD_RWLOCK_PREFER_WRITER_NONRECURSIVE_NP);
} else {
pthread_rwlockattr_setkind_np(&attr, PTHREAD_RWLOCK_PREFER_READER_NP);
}
+#endif
rwlock = (pthread_rwlock_t *)slapi_ch_malloc(sizeof(pthread_rwlock_t));
if (rwlock) {