[dev-db/timescaledb] bump
This commit is contained in:
parent
c2a41f091e
commit
9e2efadd1c
@ -1,2 +1,2 @@
|
|||||||
DIST timescaledb-2.15.3.tar.gz 7441097 BLAKE2B 35d6edb31be79045ab8b8b409e4fcd28acac261f96be946dfa079bc544890391a6fe1f4695b0c88c8d56aca674563b4f347bb1f5519923b38aeb992e4a527f1c SHA512 c259bea088a03286a392812b23eda05ba7e5c714f9b52cd25b39ea9a280c5147e43d13a71027c43a5029df03e021a0022feb1ae311baae577ec3c56f1d7dfcae
|
|
||||||
DIST timescaledb-2.16.1.tar.gz 7449327 BLAKE2B 4eac0f41596db1b7669850cbb576a2d710998f7207f566fb9b4965804e6810f1571d18058a126acdae7862bf77424db44f27720f3600d1191ae1a3c3cf8680ae SHA512 4972ccc385a3c7bda8fab8736c63f75c5b290a3a0206add84718326fcd07c24a52dbbae2114e857fb78246bf5a4b5ec3310cc2219a163af4d5f30f1766e37fae
|
DIST timescaledb-2.16.1.tar.gz 7449327 BLAKE2B 4eac0f41596db1b7669850cbb576a2d710998f7207f566fb9b4965804e6810f1571d18058a126acdae7862bf77424db44f27720f3600d1191ae1a3c3cf8680ae SHA512 4972ccc385a3c7bda8fab8736c63f75c5b290a3a0206add84718326fcd07c24a52dbbae2114e857fb78246bf5a4b5ec3310cc2219a163af4d5f30f1766e37fae
|
||||||
|
DIST timescaledb-2.17.2.tar.gz 7567447 BLAKE2B c2d5d9883377ffce57184c9c29413d12a41c7ef7891abb088aa72d0d7c410db28370c53585d7ec286fd52b3fe5c89b10f3b6deb547b6a1de132dc9c6697aa8cb SHA512 fc74d41062735bd4136ac71b0e10aecf34a64cdb29fd2ff31eae3f406beb8db00866e8ed7e142d47852e1586a6ad2ffa1652fbd792a45e995174b62464963d1e
|
||||||
|
@ -1,75 +0,0 @@
|
|||||||
From 4861ca61a54dc39a9daa26c583d1598623219d37 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Sven Klemm <sven@timescale.com>
|
|
||||||
Date: Wed, 26 Jun 2024 12:45:41 +0200
|
|
||||||
Subject: [PATCH] Don't link against openssl directly
|
|
||||||
|
|
||||||
This patch changes our build process to no longer link against
|
|
||||||
openssl directly but instead rely on postgres linking it.
|
|
||||||
Linking to openssl directly is causing problems when the openssl
|
|
||||||
version we link against does not match the version postgres links
|
|
||||||
against. While this is easy to prevent where we fully control the
|
|
||||||
build process it is repeatedly causing problems e.g. in ABI tests.
|
|
||||||
This patch changes only changes the behaviour for non-Windows as
|
|
||||||
we are running into linker problems on Windows with this change.
|
|
||||||
Until we can find a workaround for those problems Windows binaries
|
|
||||||
we still link OpenSSL directly.
|
|
||||||
---
|
|
||||||
CMakeLists.txt | 7 +++++--
|
|
||||||
src/CMakeLists.txt | 4 +++-
|
|
||||||
tsl/src/CMakeLists.txt | 3 ---
|
|
||||||
3 files changed, 8 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index 6888b1eb6ef..da217000d5b 100644
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -596,7 +596,10 @@ if(USE_OPENSSL AND (NOT PG_USE_OPENSSL))
|
|
||||||
)
|
|
||||||
endif(USE_OPENSSL AND (NOT PG_USE_OPENSSL))
|
|
||||||
|
|
||||||
-if(USE_OPENSSL)
|
|
||||||
+# While we dont link directly against OpenSSL on non-Windows, doing this on
|
|
||||||
+# Windows causes linker errors. So on Windows we link directly against the
|
|
||||||
+# OpenSSL libraries.
|
|
||||||
+if(USE_OPENSSL AND MSVC)
|
|
||||||
# Try to find a local OpenSSL installation
|
|
||||||
find_package(OpenSSL)
|
|
||||||
|
|
||||||
@@ -635,7 +638,7 @@ if(USE_OPENSSL)
|
|
||||||
message(STATUS "OpenSSL libraries: ${_path}")
|
|
||||||
endforeach()
|
|
||||||
message(STATUS "Using OpenSSL version ${OPENSSL_VERSION}")
|
|
||||||
-endif(USE_OPENSSL)
|
|
||||||
+endif(USE_OPENSSL AND MSVC)
|
|
||||||
|
|
||||||
if(CODECOVERAGE)
|
|
||||||
message(STATUS "Code coverage is enabled.")
|
|
||||||
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
|
||||||
index 8c3d72e3e80..a945e5cbcaa 100644
|
|
||||||
--- a/src/CMakeLists.txt
|
|
||||||
+++ b/src/CMakeLists.txt
|
|
||||||
@@ -104,7 +104,9 @@ if(USE_OPENSSL)
|
|
||||||
set(TS_USE_OPENSSL ${USE_OPENSSL})
|
|
||||||
target_include_directories(${PROJECT_NAME} SYSTEM
|
|
||||||
PUBLIC ${OPENSSL_INCLUDE_DIR})
|
|
||||||
- target_link_libraries(${PROJECT_NAME} ${OPENSSL_LIBRARIES})
|
|
||||||
+ if(MSVC)
|
|
||||||
+ target_link_libraries(${PROJECT_NAME} ${OPENSSL_LIBRARIES})
|
|
||||||
+ endif(MSVC)
|
|
||||||
endif(USE_OPENSSL)
|
|
||||||
|
|
||||||
configure_file(config.h.in config.h)
|
|
||||||
diff --git a/tsl/src/CMakeLists.txt b/tsl/src/CMakeLists.txt
|
|
||||||
index 4029c421599..e2524cc5a46 100644
|
|
||||||
--- a/tsl/src/CMakeLists.txt
|
|
||||||
+++ b/tsl/src/CMakeLists.txt
|
|
||||||
@@ -29,9 +29,6 @@ set_target_properties(
|
|
||||||
PROPERTIES OUTPUT_NAME ${TSL_LIBRARY_NAME}-${PROJECT_VERSION_MOD} PREFIX "")
|
|
||||||
|
|
||||||
target_include_directories(${TSL_LIBRARY_NAME} PRIVATE ${PG_INCLUDEDIR})
|
|
||||||
-if(USE_OPENSSL)
|
|
||||||
- target_include_directories(${TSL_LIBRARY_NAME} PRIVATE ${OPENSSL_INCLUDE_DIR})
|
|
||||||
-endif(USE_OPENSSL)
|
|
||||||
|
|
||||||
target_compile_definitions(${TSL_LIBRARY_NAME} PUBLIC TS_TSL)
|
|
||||||
target_compile_definitions(${TSL_LIBRARY_NAME} PUBLIC TS_SUBMODULE)
|
|
@ -3,7 +3,7 @@
|
|||||||
|
|
||||||
EAPI=8
|
EAPI=8
|
||||||
|
|
||||||
POSTGRES_COMPAT=( {13..16} )
|
POSTGRES_COMPAT=( {14..16} )
|
||||||
POSTGRES_USEDEP="ssl"
|
POSTGRES_USEDEP="ssl"
|
||||||
|
|
||||||
inherit cmake postgres-multi
|
inherit cmake postgres-multi
|
||||||
@ -22,10 +22,6 @@ RESTRICT="test"
|
|||||||
DEPEND="${POSTGRES_DEP}"
|
DEPEND="${POSTGRES_DEP}"
|
||||||
RDEPEND="${DEPEND}"
|
RDEPEND="${DEPEND}"
|
||||||
|
|
||||||
PATCHES=(
|
|
||||||
"${FILESDIR}/${P}-no-openssl.patch"
|
|
||||||
)
|
|
||||||
|
|
||||||
src_prepare() {
|
src_prepare() {
|
||||||
postgres-multi_src_prepare
|
postgres-multi_src_prepare
|
||||||
postgres-multi_foreach cmake_src_prepare
|
postgres-multi_foreach cmake_src_prepare
|
Loading…
Reference in New Issue
Block a user