[dev-libs/libtommath] bump, remove old
This commit is contained in:
parent
6da296bef4
commit
a6060e3bee
@ -1 +1 @@
|
||||
DIST ltm-0.42.0.tar.bz2 1968961 SHA256 7b5c258304c34ac5901cfddb9f809b9b3b8ac7d04f700cf006ac766a923eb217 SHA512 c5bb26a260477de4e9abee9f65735754efa69c39c89caa3a06dd8ad3eda9d27fff687a432e91e3410b2bcc6a9e3d59921b6cdf6ca7f1ca6c69ed199a002e5790 WHIRLPOOL dd9879213b64d64f70620f98edfd027565a9cdf68dea03e427b0c1055f58347aa2ce9ad6f29b854b6aa50631e68bef29adc882d9db28cc73cb033ea6f3cae98f
|
||||
DIST libtommath-1.0.tar.gz 643248 SHA256 5a0d4f9a72dfbacb05cb5dbc545cffe58b08c103506de68b278dc76d05cfe010 SHA512 2744caa886d179a23a96b51dbf0c9090a7a4e923bb4b9c22d3e92fde73e11222861806018f565f3d5425d2ba31b9bb9e1dbf098bfc37d1fd26d33ceb81a8657e WHIRLPOOL 4830fb5a1802908652e4d4629cc205a55a267d60400041685f3c13fb03d2aff5b3e7f9a0b99e7813aaebf6cb41399c9a373de6296514215ac2fdfde90531d5ce
|
||||
|
@ -1,47 +0,0 @@
|
||||
--- makefile.shared
|
||||
+++ makefile.shared
|
||||
@@ -3,7 +3,8 @@
|
||||
#Tom St Denis
|
||||
VERSION=0:41
|
||||
|
||||
-CC = libtool --mode=compile --tag=CC gcc
|
||||
+LT ?= libtool
|
||||
+LTCOMPILE = $(LT) --mode=compile --tag=CC $(CC)
|
||||
|
||||
CFLAGS += -I./ -Wall -W -Wshadow -Wsign-compare
|
||||
|
||||
@@ -82,21 +83,24 @@
|
||||
|
||||
objs: $(OBJECTS)
|
||||
|
||||
+%.lo: %.c
|
||||
+ $(LTCOMPILE) $(CFLAGS) $(CPPFLAGS) -o $@ -c $<
|
||||
+
|
||||
-$(LIBNAME): $(OBJECTS)
|
||||
- libtool --mode=link gcc *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
|
||||
+$(LIBNAME): $(OBJECTS:.o=.lo)
|
||||
+ $(LT) --mode=link --tag=CC $(CC) $(CFLAGS) $(LDFLAGS) *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
|
||||
|
||||
install: $(LIBNAME)
|
||||
- install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
|
||||
- libtool --mode=install install -c $(LIBNAME) $(DESTDIR)$(LIBPATH)/$(LIBNAME)
|
||||
- install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
|
||||
- install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
|
||||
+ install -d $(DESTDIR)$(LIBPATH)
|
||||
+ $(LT) --mode=install install -c $(LIBNAME) $(DESTDIR)$(LIBPATH)/$(LIBNAME)
|
||||
+ install -d $(DESTDIR)$(INCPATH)
|
||||
+ install -m 644 $(HEADERS) $(DESTDIR)$(INCPATH)
|
||||
|
||||
test: $(LIBNAME) demo/demo.o
|
||||
- gcc $(CFLAGS) -c demo/demo.c -o demo/demo.o
|
||||
- libtool --mode=link gcc -o test demo/demo.o $(LIBNAME_S)
|
||||
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c demo/demo.c -o demo/demo.o
|
||||
+ $(LT) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -o test demo/demo.o $(LIBNAME_S)
|
||||
|
||||
mtest: test
|
||||
- cd mtest ; gcc $(CFLAGS) mtest.c -o mtest
|
||||
+ cd mtest ; $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) mtest.c -o mtest
|
||||
|
||||
timing: $(LIBNAME)
|
||||
- gcc $(CFLAGS) -DTIMER demo/timing.c $(LIBNAME_S) -o ltmtest
|
||||
+ $(LT) --mode=link $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME_S) -o ltmtest
|
@ -2,25 +2,23 @@
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI="5"
|
||||
EAPI=5
|
||||
|
||||
inherit autotools-multilib eutils multilib toolchain-funcs
|
||||
|
||||
DESCRIPTION="highly optimized and portable routines for integer based number theoretic applications"
|
||||
HOMEPAGE="http://www.libtom.net/"
|
||||
SRC_URI="http://www.libtom.net/files/ltm-${PV}.tar.bz2"
|
||||
HOMEPAGE="https://github.com/libtom/libtommath"
|
||||
SRC_URI="https://github.com/libtom/libtommath/archive/v${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="WTFPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
|
||||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
|
||||
IUSE="doc examples static-libs"
|
||||
|
||||
DEPEND="sys-devel/libtool"
|
||||
RDEPEND=""
|
||||
|
||||
src_prepare() {
|
||||
epatch "${FILESDIR}/${P}-makefile.patch"
|
||||
|
||||
# need libtool for cross compilation. Bug #376643
|
||||
cat <<-EOF > configure.ac
|
||||
AC_INIT(libtommath, 0)
|
||||
@ -31,10 +29,13 @@ src_prepare() {
|
||||
EOF
|
||||
touch NEWS README AUTHORS ChangeLog Makefile.am
|
||||
eautoreconf
|
||||
# export LT="${S}"/libtool
|
||||
multilib_copy_sources
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
econf $(use_enable static-libs static)
|
||||
}
|
||||
|
||||
_emake() {
|
||||
cd ${BUILD_DIR}
|
||||
emake CC="$(tc-getCC)" -f makefile.shared \
|
Loading…
Reference in New Issue
Block a user