[net-im/ejabberd] nuke. in tree version is fine now
This commit is contained in:
parent
33a6b2b675
commit
cc0503b3af
@ -1 +0,0 @@
|
||||
DIST ejabberd-19.08.tar.gz 1887606 BLAKE2B a59a6f2f88a3ebbe16312615172ec8869b57c5d8a2f27c5fc8ea4cb16484a68dfd2b26742841673a7c65ced38352f9a669a548739d498b7c25f961d8c2759c67 SHA512 56514b226c0a3cf5510f1cc3a1b8b8a6846601dd45ef0e6ecb984ce118263eba3b190eaec772282b4e4c8b4075d28f3b609968bb5deb9a9aadde66f1ce6516c8
|
@ -1,306 +0,0 @@
|
||||
# Copyright 1999-2019 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=6
|
||||
|
||||
SSL_CERT_MANDATORY=1
|
||||
|
||||
inherit eutils pam rebar ssl-cert systemd
|
||||
|
||||
DESCRIPTION="Robust, scalable and extensible XMPP server"
|
||||
HOMEPAGE="https://www.ejabberd.im/ https://github.com/processone/ejabberd/"
|
||||
SRC_URI="https://www.process-one.net/downloads/${PN}/${PV}/${P}.tgz
|
||||
-> ${P}.tar.gz"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
REQUIRED_USE="mssql? ( odbc )"
|
||||
IUSE="captcha debug full-xml hipe ldap mssql mysql odbc pam postgres redis
|
||||
roster-gw sip sqlite stun zlib"
|
||||
|
||||
RESTRICT="test"
|
||||
|
||||
# TODO: luerl seems to be optional. review it
|
||||
CDEPEND="
|
||||
>=dev-erlang/cache_tab-1.0.20
|
||||
>=dev-erlang/eimp-1.0.12
|
||||
>=dev-erlang/fast_tls-1.1.2
|
||||
>=dev-erlang/fast_xml-1.1.37
|
||||
>=dev-erlang/fast_yaml-1.0.20
|
||||
>=dev-erlang/jiffy-0.14.8
|
||||
>=dev-erlang/jose-1.8.4
|
||||
>=dev-erlang/lager-3.6.10
|
||||
>=dev-erlang/luerl-0.3
|
||||
>=dev-erlang/mqtree-1.0.4
|
||||
>=dev-erlang/p1_oauth2-0.6.5
|
||||
>=dev-erlang/p1_utils-1.0.16
|
||||
>=dev-erlang/pkix-1.0.3
|
||||
>=dev-erlang/stringprep-1.0.17
|
||||
>=dev-erlang/xmpp-1.4.0
|
||||
>=dev-erlang/yconf-1.0.0
|
||||
>=dev-lang/erlang-19.1[hipe?,odbc?,ssl]
|
||||
>=net-im/jabber-base-0.01
|
||||
ldap? ( =net-nds/openldap-2* )
|
||||
mysql? ( >=dev-erlang/p1_mysql-1.0.11 )
|
||||
odbc? ( dev-db/unixODBC )
|
||||
pam? ( >=dev-erlang/epam-1.0.6 )
|
||||
postgres? ( >=dev-erlang/p1_pgsql-1.1.8 )
|
||||
redis? ( >=dev-erlang/eredis-1.0.8 )
|
||||
sip? ( >=dev-erlang/esip-1.0.30 )
|
||||
sqlite? ( >=dev-erlang/sqlite3-1.1.6 )
|
||||
stun? ( >=dev-erlang/stun-1.0.29 )
|
||||
zlib? ( >=dev-erlang/ezlib-1.0.6 )"
|
||||
DEPEND="${CDEPEND}
|
||||
>=sys-apps/gawk-4.1"
|
||||
RDEPEND="${CDEPEND}
|
||||
captcha? ( media-gfx/imagemagick[truetype,png] )"
|
||||
|
||||
DOCS=( CHANGELOG.md README.md )
|
||||
PATCHES=( "${FILESDIR}/${PN}-19.02-ejabberdctl.patch"
|
||||
"${FILESDIR}/${PN}-19.02-0002-Dont-overwrite-service-file.patch" )
|
||||
|
||||
EJABBERD_CERT="${EPREFIX}/etc/ssl/ejabberd/server.pem"
|
||||
# Paths in net-im/jabber-base
|
||||
JABBER_ETC="${EPREFIX}/etc/jabber"
|
||||
JABBER_LOG="${EPREFIX}/var/log/jabber"
|
||||
JABBER_SPOOL="${EPREFIX}/var/spool/jabber"
|
||||
|
||||
# Adjust example configuration file to Gentoo.
|
||||
# - Use our sample certificates.
|
||||
# - Correct PAM service name.
|
||||
adjust_config() {
|
||||
sed -e "s|\"/path/to/ssl.pem\"|\"${EJABBERD_CERT}\"|g" \
|
||||
-e "s|\"pamservicename\"|\"xmpp\"|" \
|
||||
-i "${S}/ejabberd.yml.example" \
|
||||
|| die 'failed to adjust example config'
|
||||
}
|
||||
|
||||
# Set paths to ejabberd lib directory consistently to point always to directory
|
||||
# suffixed with version.
|
||||
correct_ejabberd_paths() {
|
||||
sed -e "/^EJABBERDDIR[[:space:]]*=/{s:ejabberd:${P}:}" \
|
||||
-i "${S}/Makefile.in" \
|
||||
|| die 'failed to set ejabberd path in Makefile.in'
|
||||
sed -e "/EJABBERD_BIN_PATH=/{s:ejabberd:${P}:}" \
|
||||
-i "${S}/ejabberdctl.template" \
|
||||
|| die 'failed to set ejabberd path in ejabberdctl.template'
|
||||
sed -e 's|\(captcha_cmd:[[:space:]]*"\).\+"|\1'$(get_ejabberd_path)'/priv/bin/captcha.sh"|' \
|
||||
-i "${S}/ejabberd.yml.example" \
|
||||
|| die 'failed to correct path to captcha.sh in example config'
|
||||
}
|
||||
|
||||
# Get epam-wrapper from 'files' directory and correct path to lib directory in
|
||||
# it. epam-wrapper is placed into work directory. It is assumed no epam-wrapper
|
||||
# file exists there already.
|
||||
customize_epam_wrapper() {
|
||||
local epam_wrapper_src="$1"
|
||||
local epam_wrapper_dst="${S}/epam-wrapper"
|
||||
|
||||
[[ -e ${epam_wrapper_dst} ]] && die 'epam-wrapper already exists'
|
||||
sed -r -e "s@^(ERL_LIBS=).*\$@\1${EPREFIX}$(get_erl_libs)@" \
|
||||
"${epam_wrapper_src}" >"${epam_wrapper_dst}" \
|
||||
|| die 'failed to install epam-wrapper'
|
||||
}
|
||||
|
||||
# Check if there already exists a certificate.
|
||||
ejabberd_cert_exists() {
|
||||
local cert
|
||||
|
||||
for cert in $(gawk -- \
|
||||
'match($0, /^[[:space:]]*certfile: "([^"]+)"/, m) {print m[1];}' \
|
||||
"${EROOT%/}${JABBER_ETC}/ejabberd.yml"); do
|
||||
[[ -f ${cert} ]] && return 0
|
||||
done
|
||||
|
||||
return 1
|
||||
}
|
||||
|
||||
# Generate and install sample ejabberd certificate. It's installed into
|
||||
# EJABBERD_CERT path.
|
||||
ejabberd_cert_install() {
|
||||
SSL_ORGANIZATION="${SSL_ORGANIZATION:-ejabberd XMPP Server}"
|
||||
install_cert "${EJABBERD_CERT%.*}"
|
||||
chown root:jabber "${EROOT%/}${EJABBERD_CERT}" || die
|
||||
chmod 0440 "${EROOT%/}${EJABBERD_CERT}" || die
|
||||
}
|
||||
|
||||
# Get path to ejabberd lib directory.
|
||||
#
|
||||
# This is the path ./configure script Base for this path is path set in
|
||||
# ./configure script which is /usr/lib by default. If libdir is explicitely set
|
||||
# to something else than this should be adjusted here as well.
|
||||
get_ejabberd_path() {
|
||||
echo "/usr/$(get_libdir)/${P}"
|
||||
}
|
||||
|
||||
# Make ejabberd.service for systemd from upstream provided template.
|
||||
make_ejabberd_service() {
|
||||
sed -r \
|
||||
-e 's!@ctlscriptpath@!/usr/sbin!g' \
|
||||
-e 's!(User|Group)=(.*)!\1=jabber!' \
|
||||
"${PN}.service.template" >"${PN}.service" \
|
||||
|| die 'failed to make ejabberd.service'
|
||||
}
|
||||
|
||||
# Set paths to defined by net-im/jabber-base.
|
||||
set_jabberbase_paths() {
|
||||
sed -e "/^ETCDIR[[:space:]]*=/{s:@sysconfdir@/ejabberd:${JABBER_ETC}:}" \
|
||||
-e "/^LOGDIR[[:space:]]*=/{s:@localstatedir@/log/ejabberd:${JABBER_LOG}:}" \
|
||||
-e "/^SPOOLDIR[[:space:]]*=/{s:@localstatedir@/lib/ejabberd:${JABBER_SPOOL}:}" \
|
||||
-i "${S}/Makefile.in" \
|
||||
|| die 'failed to set paths in Makefile.in'
|
||||
sed -e "s|\(ETC_DIR:=\"\){{sysconfdir}}[^\"]*|\1${JABBER_ETC}|" \
|
||||
-e "s|\(LOGS_DIR:=\"\){{localstatedir}}[^\"]*|\1${JABBER_LOG}|" \
|
||||
-e "s|\(SPOOL_DIR:=\"\){{localstatedir}}[^\"]*|\1${JABBER_SPOOL}|" \
|
||||
-i "${S}/ejabberdctl.template" \
|
||||
|| die 'failed to set paths ejabberdctl.template'
|
||||
}
|
||||
|
||||
# Skip installing docs because it's only COPYING that's installed by Makefile.
|
||||
skip_docs() {
|
||||
gawk -i inplace '
|
||||
/# Documentation/, /^[[:space:]]*#?[[:space:]]*$/ {
|
||||
if ($0 ~ /^[[:space:]]*#?[[:space:]]*$/) {
|
||||
print $0;
|
||||
} else {
|
||||
next;
|
||||
}
|
||||
}
|
||||
1
|
||||
' "${S}/Makefile.in" || die 'failed to remove docs section from Makefile.in'
|
||||
}
|
||||
|
||||
src_prepare() {
|
||||
default
|
||||
|
||||
rebar_remove_deps
|
||||
correct_ejabberd_paths
|
||||
set_jabberbase_paths
|
||||
make_ejabberd_service
|
||||
skip_docs
|
||||
adjust_config
|
||||
customize_epam_wrapper "${FILESDIR}/epam-wrapper"
|
||||
|
||||
rebar_fix_include_path fast_xml
|
||||
rebar_fix_include_path p1_utils
|
||||
rebar_fix_include_path xmpp
|
||||
|
||||
# Fix bug #591862. ERL_LIBS should point directly to ejabberd directory
|
||||
# rather than its parent which is default. That way ejabberd directory
|
||||
# takes precedence is module lookup.
|
||||
local ejabberd_erl_libs="$(get_ejabberd_path):$(get_erl_libs)"
|
||||
sed -e "s|\(ERL_LIBS=\){{libdir}}.*|\1${ejabberd_erl_libs}|" \
|
||||
-i "${S}/ejabberdctl.template" \
|
||||
|| die 'failed to set ERL_LIBS in ejabberdctl.template'
|
||||
|
||||
sed -e "s|\(AC_INIT(ejabberd, \)m4_esyscmd([^)]*)|\1[$PV]|" \
|
||||
-i configure.ac || die "Failed to write correct version to configure"
|
||||
# eautoreconf # required in case of download from github
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
econf \
|
||||
--docdir="${EPREFIX}/usr/share/doc/${PF}/html" \
|
||||
--enable-user=jabber \
|
||||
--disable-system-deps \
|
||||
$(use_enable debug) \
|
||||
$(use_enable full-xml) \
|
||||
$(use_enable hipe) \
|
||||
$(use_enable mssql) \
|
||||
$(use_enable mysql) \
|
||||
$(use_enable odbc) \
|
||||
$(use_enable pam) \
|
||||
$(use_enable postgres pgsql) \
|
||||
$(use_enable redis) \
|
||||
$(use_enable roster-gw roster-gateway-workaround) \
|
||||
$(use_enable sqlite) \
|
||||
$(use_enable sip) \
|
||||
$(use_enable stun) \
|
||||
$(use_enable zlib)
|
||||
|
||||
# more options to support
|
||||
# --enable-elixir requires https://github.com/elixir-lang/elixir
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
emake REBAR='rebar -v' src
|
||||
}
|
||||
|
||||
src_install() {
|
||||
default
|
||||
|
||||
if use pam; then
|
||||
local epam_path="$(get_ejabberd_path)/priv/bin/epam"
|
||||
|
||||
pamd_mimic_system xmpp auth account || die "cannot create pam.d file"
|
||||
into "$(get_ejabberd_path)/priv"
|
||||
newbin epam-wrapper epam
|
||||
fi
|
||||
|
||||
newconfd "${FILESDIR}/${PN}.confd" "${PN}"
|
||||
newinitd "${FILESDIR}/${PN}.initd" "${PN}"
|
||||
systemd_dounit "${PN}.service"
|
||||
systemd_dotmpfilesd "${FILESDIR}/${PN}.tmpfiles.conf"
|
||||
|
||||
insinto /etc/logrotate.d
|
||||
newins "${FILESDIR}/${PN}.logrotate" "${PN}"
|
||||
}
|
||||
|
||||
pkg_preinst() {
|
||||
if use pam; then
|
||||
einfo "Adding jabber user to epam group to allow ejabberd to use PAM" \
|
||||
"authentication"
|
||||
# See
|
||||
# <https://docs.ejabberd.im/admin/configuration/#pam-authentication>.
|
||||
# epam binary is installed by dev-erlang/epam package, therefore SUID
|
||||
# is set by that package. Instead of jabber group it uses epam group,
|
||||
# therefore we need to add jabber user to epam group.
|
||||
usermod -a -G epam jabber || die
|
||||
fi
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
if [[ ! ${REPLACING_VERSIONS} ]]; then
|
||||
echo
|
||||
elog "For configuration instructions, please see"
|
||||
elog " http://www.process-one.net/en/ejabberd/docs/"
|
||||
echo
|
||||
if [[ " ${REPLACING_VERSIONS} " =~ \ 2\. ]]; then
|
||||
ewarn "If you have used pubsub in ejabberd-2.* you may encounter issues after"
|
||||
ewarn "migration to ${PV}. pubsub data may not be migrated automatically and"
|
||||
ewarn "you may need to run migration script manually, see:"
|
||||
ewarn
|
||||
ewarn " https://github.com/processone/ejabberd/issues/479#issuecomment-124497456"
|
||||
ewarn
|
||||
ewarn "In case you don't care about all stored moods, activities, geoinfo and you"
|
||||
ewarn "know you don't store in pubsub anything important, you can just remove"
|
||||
ewarn "pubsub tables:"
|
||||
ewarn
|
||||
ewarn " rm ${EROOT%/}${JABBER_SPOOL}/pubsub_*"
|
||||
ewarn
|
||||
ewarn "See also: https://bugs.gentoo.org/show_bug.cgi?id=588244"
|
||||
echo
|
||||
fi
|
||||
elif [[ -f ${EROOT}etc/jabber/ejabberd.cfg ]]; then
|
||||
elog "Ejabberd now defaults to using a YAML format for its config file."
|
||||
elog "The old ejabberd.cfg file can be converted using the following instructions:"
|
||||
echo
|
||||
elog "1. Make sure all processes related to the previous version of ejabberd aren't"
|
||||
elog " running. Usually this just means the ejabberd and epmd daemons and possibly"
|
||||
elog " the pam-related process (epam) if pam support is enabled."
|
||||
elog "2. Run \`ejabberdctl start\` with sufficient permissions. Note that this can"
|
||||
elog " fail to start ejabberd properly for various reasons. Check ejabberd's main"
|
||||
elog " log file at /var/log/jabber/ejabberd.log to confirm it started successfully."
|
||||
elog "3. Run"
|
||||
elog " \`ejabberdctl convert_to_yaml /etc/jabber/ejabberd.cfg /etc/jabber/ejabberd.yml.new\`"
|
||||
elog " with sufficient permissions, edit and rename /etc/jabber/ejabberd.yml.new to"
|
||||
elog " /etc/jabber/ejabberd.yml, and finally restart ejabberd with the new config"
|
||||
elog " file."
|
||||
echo
|
||||
fi
|
||||
|
||||
if ! ejabberd_cert_exists; then
|
||||
ejabberd_cert_install
|
||||
fi
|
||||
}
|
@ -1,15 +0,0 @@
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index a0b4553d..4675b88a 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -204,8 +204,8 @@ install: all copy-files
|
||||
chmod 755 ejabberd.init
|
||||
#
|
||||
# Service script
|
||||
- $(SED) -e "s*@ctlscriptpath@*$(SBINDIR)*g" ejabberd.service.template \
|
||||
- > ejabberd.service
|
||||
+ [ -f ejabberd.service ] || $(SED) -e "s*@ctlscriptpath@*$(SBINDIR)*g" \
|
||||
+ ejabberd.service.template > ejabberd.service
|
||||
chmod 644 ejabberd.service
|
||||
#
|
||||
# Spool directory
|
@ -1,38 +0,0 @@
|
||||
Subject: [PATCH] Adjust ejabberdctl for Gentoo jabberbase setup
|
||||
|
||||
Set SHELL since the generic jabber user used on Gentoo for jabber
|
||||
servers doesn't have a valid shell set by default and fix EXEC_CMD
|
||||
otherwise it fails with This account is currently not available again
|
||||
due to jabber not having a valid shell.
|
||||
|
||||
Also, workaround the assumption that jabber's /root is a directory when
|
||||
instead it defaults to /dev/null on Gentoo.
|
||||
---
|
||||
|
||||
diff --git a/ejabberdctl.template b/ejabberdctl.template
|
||||
index 571b90b..71336c0 100755
|
||||
--- a/ejabberdctl.template
|
||||
+++ b/ejabberdctl.template
|
||||
@@ -82,6 +82,7 @@ fi
|
||||
ERL_LIBS={{libdir}}
|
||||
ERL_CRASH_DUMP="$LOGS_DIR"/erl_crash_$(date "+%Y%m%d-%H%M%S").dump
|
||||
ERL_INETRC="$ETC_DIR"/inetrc
|
||||
+HOME=$SPOOL_DIR
|
||||
|
||||
# define ejabberd parameters
|
||||
EJABBERD_OPTS="$EJABBERD_OPTS\
|
||||
@@ -105,12 +106,13 @@ export ERL_MAX_ETS_TABLES
|
||||
export CONTRIB_MODULES_PATH
|
||||
export CONTRIB_MODULES_CONF_DIR
|
||||
export ERL_LIBS
|
||||
+export HOME
|
||||
|
||||
# run command either directly or via su $INSTALLUSER
|
||||
exec_cmd()
|
||||
{
|
||||
case $EXEC_CMD in
|
||||
- as_install_user) su -s /bin/sh -c '"$0" "$@"' "$INSTALLUSER" -- "$@" ;;
|
||||
+ as_install_user) su -p -s /bin/sh -c '"$0" "$@"' "$INSTALLUSER" -- "$@" ;;
|
||||
as_current_user) "$@" ;;
|
||||
esac
|
||||
}
|
@ -1,5 +0,0 @@
|
||||
# Please configure everything at /etc/jabber/ejabberdctl.cfg
|
||||
# Put here only command line arguments for ejabberdctl (if any are required)
|
||||
|
||||
#EJABBERDCTL_OPTS=""
|
||||
|
@ -1,54 +0,0 @@
|
||||
#!/sbin/openrc-run
|
||||
# Copyright 1999-2018 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
extra_started_commands="reload"
|
||||
|
||||
depend() {
|
||||
use dns
|
||||
need epmd net
|
||||
provide jabber-server
|
||||
}
|
||||
|
||||
start() {
|
||||
if ejabberdctl status >/dev/null 2>&1; then
|
||||
ewarn "ejabberd is already started (manually?)."
|
||||
return 0
|
||||
fi
|
||||
ebegin "Starting ejabberd"
|
||||
/usr/sbin/ejabberdctl ${EJABBERDCTL_OPTS} start
|
||||
eend $?
|
||||
}
|
||||
|
||||
reload() {
|
||||
ebegin "Reloading ejabberd configuration"
|
||||
/usr/sbin/ejabberdctl ${EJABBERDCTL_OPTS} reload_config
|
||||
eend $?
|
||||
}
|
||||
|
||||
stop() {
|
||||
ejabberdctl status >/dev/null 2>&1
|
||||
if test $? = 3; then
|
||||
ewarn "ejabberd is already stopped (manually?)."
|
||||
return 0
|
||||
fi
|
||||
ebegin "Stopping ejabberd"
|
||||
if /usr/sbin/ejabberdctl stop >/dev/null 2>&1; then
|
||||
cnt=0
|
||||
sleep 1
|
||||
while ejabberdctl status >/dev/null 2>&1 || test $? = 1; do
|
||||
echo -n .
|
||||
cnt=`expr $cnt + 1`
|
||||
if [ $cnt -ge 60 ] ; then
|
||||
eend 1
|
||||
break
|
||||
fi
|
||||
sleep 1
|
||||
done
|
||||
eend 0
|
||||
else
|
||||
eend 1
|
||||
einfo "Please, run '/usr/sbin/ejabberdctl stop' to see what's going on."
|
||||
fi
|
||||
eend 0
|
||||
}
|
@ -1,13 +0,0 @@
|
||||
/var/log/jabber/*.log {
|
||||
su jabber jabber
|
||||
weekly
|
||||
rotate 4
|
||||
missingok
|
||||
nocreate
|
||||
sharedscripts
|
||||
notifempty
|
||||
compress
|
||||
postrotate
|
||||
/usr/sbin/ejabberdctl reopen-log > /dev/null 2>&1 || true
|
||||
endscript
|
||||
}
|
@ -1,2 +0,0 @@
|
||||
d /run/lock/ejabberdctl 0750 jabber jabber
|
||||
d /run/ejabberd 0750 jabber jabber
|
@ -1,21 +0,0 @@
|
||||
#!/bin/sh
|
||||
|
||||
ERL_LIBS=/usr/lib/erlang/lib
|
||||
|
||||
for bin in "$ERL_LIBS"/epam-*/priv/bin/epam; do
|
||||
if [ -x "$bin" ]; then
|
||||
if [ -z "$epam" ]; then
|
||||
epam="$bin"
|
||||
else
|
||||
echo "Multiple epam libraries - don't know what to do" >&2
|
||||
exit 1
|
||||
fi
|
||||
fi
|
||||
done
|
||||
|
||||
if [ -z "$epam" ]; then
|
||||
echo "Couldn't find epam package" >&2
|
||||
exit 1
|
||||
fi
|
||||
|
||||
exec "$epam"
|
@ -1,34 +0,0 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>hanno@gentoo.org</email>
|
||||
<name>Hanno Böck</name>
|
||||
</maintainer>
|
||||
<longdescription>
|
||||
Free and Open Source distributed fault-tolerant Jabber server. It's
|
||||
mostly written in Erlang, and works on many platforms.
|
||||
</longdescription>
|
||||
<use>
|
||||
<flag name="captcha">Support for CAPTCHA Forms (XEP-158) on registration</flag>
|
||||
<flag name="full-xml">Use XML features in XMPP stream (ex: CDATA),
|
||||
requires XML compliant clients</flag>
|
||||
<flag name="hipe">Compile natively with HiPE, not recommended</flag>
|
||||
<flag name="mssql">Enable Microsoft SQL Server support (via ODBC) for
|
||||
data storage</flag>
|
||||
<flag name="mysql">Enable MySQL support for data storage</flag>
|
||||
<flag name="nls">Enable character set conversion for mod_irc</flag>
|
||||
<flag name="odbc">Enable ODBC support to access data storage</flag>
|
||||
<flag name="postgres">Enable PostgreSQL support for data storage</flag>
|
||||
<flag name="redis">Enable Redis support for transient data</flag>
|
||||
<flag name="riak">Enable support for Riak - distributed NoSQL key-value
|
||||
data store</flag>
|
||||
<flag name="roster-gw">Turn on workaround for processing gateway subscriptions</flag>
|
||||
<flag name="sqlite">Enable SQLite database support</flag>
|
||||
<flag name="zlib">Enable Stream Compression (XEP-0138) using zlib</flag>
|
||||
<!-- TODO Add later: flag name="tools">Build development tools</flag -->
|
||||
</use>
|
||||
<upstream>
|
||||
<remote-id type="github">processone/ejabberd</remote-id>
|
||||
</upstream>
|
||||
</pkgmetadata>
|
Loading…
Reference in New Issue
Block a user