[dev-libs/Ice] bump and update live ebuild. untested for now.

This commit is contained in:
Robert Förster 2016-10-11 18:19:03 +02:00
parent 6182fb3852
commit cc403dd79c
6 changed files with 96 additions and 120 deletions

View File

@ -15,7 +15,7 @@ PHP_EXT_ZENDEXT="no"
PHP_EXT_OPTIONAL_USE=php
USE_PHP="php5-6"
USE_PHP="php7-0"
inherit toolchain-funcs versionator php-ext-source-r2 python-r1 mono-env ruby-ng db-use
@ -40,8 +40,8 @@ RDEPEND=">=dev-libs/expat-2.0.1
python? ( ${PYTHON_DEPS} )
ruby? ( $(ruby_implementation_depend ruby23) )
mono? ( dev-lang/mono )
php? ( dev-lang/php:5.6 )
php_namespaces? ( dev-lang/php:5.6 )
php? ( dev-lang/php:7.0 )
php_namespaces? ( dev-lang/php:7.0 )
!dev-python/IcePy
!dev-ruby/IceRuby"
DEPEND="${RDEPEND}
@ -54,10 +54,6 @@ DEPEND="${RDEPEND}
REQUIRED_USE="php_namespaces? ( php )"
# Maintainer notes:
# - yes, we have to do the trickery with the move for the python functions
# since the build and test frameworks deduce various settings from the path
# and they can't be tricked by a symlink. And we also need
# SUPPORT_PYTHON_ABIS=1 otherwise we can't get pyc/pyo anymore the sane way.
# TODO: java bindings
S="${WORKDIR}/${P/I/i}"
@ -103,26 +99,20 @@ src_prepare() {
csharp/config/Make.rules.cs || die "sed failed"
# skip mono tests, bug #498484
sed -i \
-e '/SUBDIRS/s|\ test||' \
csharp/Makefile || die "sed failed"
# sed -i \
# -e '/SUBDIRS/s|\ test||' \
# csharp/Makefile || die "sed failed"
# skip udp test due to multicast
# skip IceSSL tests due to requirement of internet connection
sed -i \
-e 's|allTests.py|allTests.py --rfilter=udp --rfilter=IceSSL --rfilter=IceGrid\/simple|' \
cpp/Makefile || die "sed failed"
# sed -i \
# -e 's|allTests.py|allTests.py --rfilter=udp --rfilter=IceSSL --rfilter=IceGrid\/simple|' \
# cpp/Makefile || die "sed failed"
# mainly broken .ice files
sed -i \
-e 's|allTests.py|allTests.py --rfilter=operations --rfilter=slicing\/objects|' \
python/Makefile || die "sed failed"
if ! use test ; then
sed -i \
-e '/SUBDIRS/s|\ test||' \
{cpp,csharp,php,python,ruby}/Makefile || die "sed failed"
fi
# sed -i \
# -e 's|allTests.py|allTests.py --rfilter=operations --rfilter=slicing\/objects|' \
# python/Makefile || die "sed failed"
}
suitable_db_version() {
@ -144,7 +134,8 @@ src_configure() {
install_mandir=\"${ED}/usr/share/man\"
embedded_runpath_prefix=\"${EPREFIX}/usr\"
LP64=yes
new_dtags=yes"
new_dtags=yes
NOTEST=$(usex test no yes)"
use ncurses && OPTIONS="${MAKE_RULES} USE_READLINE=yes" || MAKE_RULES="${MAKE_RULES} USE_READLINE=no"
use debug && OPTIONS="${MAKE_RULES} OPTIMIZE=no" || MAKE_RULES="${MAKE_RULES} OPTIMIZE=yes"
@ -161,9 +152,6 @@ src_configure() {
if use python ; then
S=${S}/python python_copy_sources
# make a place for the build hackery
rm -r "${S}"/python || die
fi
if use ruby ; then
@ -208,9 +196,6 @@ src_compile() {
mkdir -p "${WORKDIR}/${slot}"
cp -r "${PHP_EXT_S}" "${WORKDIR}/${slot}/" || die "Failed to copy source ${PHP_EXT_S} to PHP target directory"
cd "${WORKDIR}/${slot}"
sed -i \
-e "s|php-config|${EPREFIX}/usr/$(get_libdir)/${slot}/bin/php-config|" \
php/src/IcePHP/Makefile || die "sed failed"
ln -s "${S}/cpp"
ln -s "${S}/config"
ln -s "${S}/slice"
@ -219,7 +204,7 @@ src_compile() {
if use php_namespaces ; then
MAKE_RULES_PHP="USE_NAMESPACES=yes"
fi
emake -C php ${MAKE_RULES} ${MAKE_RULES_PHP} || die "emake php failed"
emake -C php ${MAKE_RULES} ${MAKE_RULES_PHP} PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${slot}/bin/php-config" || die "emake php failed"
done
cd "${S}"
fi
@ -227,11 +212,9 @@ src_compile() {
if use python ; then
building() {
# build requires that the directory is named 'python'
mv "${BUILD_DIR}" "${S}"/python || die
emake -C python ${MAKE_RULES} || die "emake python-${EPYTHON} failed"
mv "${S}"/python "${BUILD_DIR}"
}
BUILD_DIR=python python_foreach_impl building
python_foreach_impl building
fi
if use ruby ; then
@ -251,14 +234,12 @@ src_test() {
if use python ; then
testing() {
mv "${BUILD_DIR}" "${S}"/python || die
emake -C python ${MAKE_RULES} \
install_pythondir="\"${D}/$(python_get_sitedir)\"" \
install_libdir="\"${D}/$(python_get_sitedir)\"" \
test || die "emake python-${EPYTHON} test failed"
mv "${S}"/python "${BUILD_DIR}"
}
BUILD_DIR=python python_foreach_impl testing
python_foreach_impl testing
fi
if use ruby ; then
@ -312,14 +293,12 @@ src_install() {
installation() {
mkdir -p "${D}/$(python_get_sitedir)" || die
mv "${BUILD_DIR}" "${S}"/python || die
emake -C python ${MAKE_RULES} \
install_pythondir="\"${D}/$(python_get_sitedir)\"" \
install_libdir="\"${D}/$(python_get_sitedir)\"" \
install || die "emake python-${EPYTHON} install failed"
mv "${S}"/python "${BUILD_DIR}"
}
BUILD_DIR=python python_foreach_impl installation
python_foreach_impl installation
fi
if use ruby ; then

View File

@ -15,7 +15,7 @@ PHP_EXT_ZENDEXT="no"
PHP_EXT_OPTIONAL_USE=php
USE_PHP="php5-6"
USE_PHP="php7-0"
EGIT_REPO_URI="https://github.com/zeroc-ice/ice.git"
EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}"
@ -45,8 +45,8 @@ RDEPEND=">=dev-libs/expat-2.0.1
python? ( ${PYTHON_DEPS} )
ruby? ( $(ruby_implementation_depend ruby23) )
mono? ( dev-lang/mono )
php? ( dev-lang/php:5.6 )
php_namespaces? ( dev-lang/php:5.6 )
php? ( dev-lang/php:7.0 )
php_namespaces? ( dev-lang/php:7.0 )
!dev-python/IcePy
!dev-ruby/IceRuby"
DEPEND="${RDEPEND}
@ -59,10 +59,6 @@ DEPEND="${RDEPEND}
REQUIRED_USE="php_namespaces? ( php )"
# Maintainer notes:
# - yes, we have to do the trickery with the move for the python functions
# since the build and test frameworks deduce various settings from the path
# and they can't be tricked by a symlink. And we also need
# SUPPORT_PYTHON_ABIS=1 otherwise we can't get pyc/pyo anymore the sane way.
# TODO: java bindings
S="${WORKDIR}/${PN}"
@ -74,8 +70,8 @@ src_unpack() {
}
src_prepare() {
epatch "${FILESDIR}/${PN}-3.6.2-no-arch-opts.patch"
epatch "${FILESDIR}/${PN}-3.6.2-csharp.patch"
epatch "${FILESDIR}/${PN}-3.6.3-no-arch-opts.patch"
epatch "${FILESDIR}/${PN}-3.6.3-csharp.patch"
sed -i \
-e 's|\(install_configdir[[:space:]]*\):=|\1?=|' \
-e 's|-L\$\(libdir\)||' \
@ -108,26 +104,20 @@ src_prepare() {
csharp/config/Make.rules.cs || die "sed failed"
# skip mono tests, bug #498484
sed -i \
-e '/SUBDIRS/s|\ test||' \
csharp/Makefile || die "sed failed"
# sed -i \
# -e '/SUBDIRS/s|\ test||' \
# csharp/Makefile || die "sed failed"
# skip udp test due to multicast
# skip IceSSL tests due to requirement of internet connection
sed -i \
-e 's|allTests.py|allTests.py --rfilter=udp --rfilter=IceSSL --rfilter=IceGrid\/simple|' \
cpp/Makefile || die "sed failed"
# sed -i \
# -e 's|allTests.py|allTests.py --rfilter=udp --rfilter=IceSSL --rfilter=IceGrid\/simple|' \
# cpp/Makefile || die "sed failed"
# mainly broken .ice files
sed -i \
-e 's|allTests.py|allTests.py --rfilter=operations --rfilter=slicing\/objects|' \
python/Makefile || die "sed failed"
if ! use test ; then
sed -i \
-e '/SUBDIRS/s|\ test||' \
{csharp,python,ruby}/Makefile || die "sed failed"
fi
# sed -i \
# -e 's|allTests.py|allTests.py --rfilter=operations --rfilter=slicing\/objects|' \
# python/Makefile || die "sed failed"
}
suitable_db_version() {
@ -167,9 +157,6 @@ src_configure() {
if use python ; then
S=${S}/python python_copy_sources
# make a place for the build hackery
rm -r "${WORKDIR}/${PN}"/python || die
fi
if use ruby ; then
@ -214,9 +201,6 @@ src_compile() {
mkdir -p "${WORKDIR}/${slot}"
cp -r "${PHP_EXT_S}" "${WORKDIR}/${slot}/" || die "Failed to copy source ${PHP_EXT_S} to PHP target directory"
cd "${WORKDIR}/${slot}"
sed -i \
-e "s|php-config|${EPREFIX}/usr/$(get_libdir)/${slot}/bin/php-config|" \
php/src/IcePHP/Makefile || die "sed failed"
ln -s "${S}/cpp"
ln -s "${S}/config"
ln -s "${S}/slice"
@ -225,7 +209,7 @@ src_compile() {
if use php_namespaces ; then
MAKE_RULES_PHP="USE_NAMESPACES=yes"
fi
emake -C php ${MAKE_RULES} ${MAKE_RULES_PHP} || die "emake php failed"
emake -C php ${MAKE_RULES} ${MAKE_RULES_PHP} PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${slot}/bin/php-config" || die "emake php failed"
done
cd "${S}"
fi
@ -233,11 +217,9 @@ src_compile() {
if use python ; then
building() {
# build requires that the directory is named 'python'
mv "${BUILD_DIR}" "${S}"/python || die
emake -C python ${MAKE_RULES} || die "emake python-${EPYTHON} failed"
mv "${S}"/python "${BUILD_DIR}"
}
BUILD_DIR=python python_foreach_impl building
python_foreach_impl building
fi
if use ruby ; then
@ -257,14 +239,12 @@ src_test() {
if use python ; then
testing() {
mv "${BUILD_DIR}" "${S}"/python || die
emake -C python ${MAKE_RULES} \
install_pythondir="\"${D}/$(python_get_sitedir)\"" \
install_libdir="\"${D}/$(python_get_sitedir)\"" \
test || die "emake python-${EPYTHON} test failed"
mv "${S}"/python "${BUILD_DIR}"
}
BUILD_DIR=python python_foreach_impl testing
python_foreach_impl testing
fi
if use ruby ; then
@ -314,14 +294,12 @@ src_install() {
installation() {
mkdir -p "${D}/$(python_get_sitedir)" || die
mv "${BUILD_DIR}" "${S}"/python || die
emake -C python ${MAKE_RULES} \
install_pythondir="\"${D}/$(python_get_sitedir)\"" \
install_libdir="\"${D}/$(python_get_sitedir)\"" \
install || die "emake python-${EPYTHON} install failed"
mv "${S}"/python "${BUILD_DIR}"
}
BUILD_DIR=python python_foreach_impl installation
python_foreach_impl installation
fi
if use ruby ; then

View File

@ -1,2 +1,2 @@
DIST Ice-3.6.2.pdf 8848309 SHA256 5f91e72a9323f2cbb64568f40375f4a232fa28a278ff78709f3bbda20c196961 SHA512 631af62750a70555c37a93ec8608988506713448a4eb52b19b40f6f5ab49983a8704813974335d396fb9cc1fb4b976ef509ca0b19060a6e551d28a4f04a73271 WHIRLPOOL 93d59b330862a3aba481a71a73f7cd462d4131cf4785454355cba1c5655d204b37c8fbbae4662924b2389327d0c2f5785a01518e4ab3c6ccf88f594b85d6ffe2
DIST Ice-3.6.2.tar.gz 5393239 SHA256 5e9305a5eb6081c8f128d63a5546158594e9f115174fc91208f645dbe2fc02fe SHA512 fb6b70edd551c66ba801a3a0af0d9101206e771e607e2feffa53fdac95215837bedce2f44251f04d1915c02130b1341daf96d3357b13e4b59d4fae01c14d8e5f WHIRLPOOL 84d4991d8d4379242dcdf0ec0b60242c4a72579ce462a40d107a61088deddb7aa703b8a4f342f7c30e8cd35371471ec9e7592fc94132e4917815f111d4ec77a9
DIST Ice-3.6.3.pdf 8844957 SHA256 bf6edd649d44dcac1951d7d62b112fb535b8f29f58973cfdcd5cabf8940bb3b9 SHA512 44638a315b0da9c26519c053c48ab8ee216c43410f53844465535a972ae01031f1603769e9b3169fdf9358de67e0d0c7e238b2918b5d5b1c4cb95cb922fa922a WHIRLPOOL 65087b4c643e2c7f2cf66b3b9fb433823f75c8b5a44b838d39077f2dab85c57ff4e022931ec8ba21cbc6deda2e55257f6c0d2d0a360d50e9b1a615253ad7ed0a
DIST Ice-3.6.3.tar.gz 5512741 SHA256 82ff74e6d24d9fa396dbb4d9697dc183b17bc9c3f6f076fecdc05632be80a2dc SHA512 6e17d21f55a8504af87a64c498a0c4d2084ed96a85c7a66d00319324774f671ace6afa03108d8d4e9bedf5fcfc2f3dba247949a27deecacdd0d298bd0bfe0a45 WHIRLPOOL 4e2d50aaf62f805a0c5471ab907c7680607de5fe101c96a740a3bc1b8ddc7ea93d768ba5886b26772647eb173417195bd808399192b2d2c7d5adb40cf38fc95f

View File

@ -1,31 +0,0 @@
--- ice-3.6.0/cpp/config/Make.rules.Linux~ 2015-06-27 16:56:56.000000000 +0200
+++ ice-3.6.0/cpp/config/Make.rules.Linux 2015-06-27 17:23:45.810591931 +0200
@@ -71,14 +71,6 @@
CXXARCHFLAGS += -mtune=v8 -pipe -Wno-deprecated -DICE_USE_MUTEX_SHARED
endif
- ifeq ($(MACHINE),x86_64)
- ifeq ($(LP64),yes)
- CXXARCHFLAGS += -m64
- else
- CXXARCHFLAGS += -m32
- endif
- endif
-
CXXFLAGS += $(CXXARCHFLAGS) -fvisibility=hidden -Wall -Werror -pthread
# If MAXWARN is set then enable extra warnings
--- ice-3.6.0/config/Make.common.rules~ 2015-06-23 17:30:20.000000000 +0200
+++ ice-3.6.0/config/Make.common.rules 2015-06-28 01:53:57.149666595 +0200
@@ -104,11 +104,6 @@
LP64 = yes
endif
endif
- ifneq ($(STATICLIBS),yes)
- ifneq ($(LP64),yes)
- binsuffix = 32
- endif
- endif
endif
ifeq ($(shell test -d $(usr_dir)/lib/i386-linux-gnu && echo 0),0)

View File

@ -1,5 +1,5 @@
--- ice-3.6.2/csharp/src/Makefile~ 2015-06-23 17:30:20.000000000 +0200
+++ ice-3.6.2/csharp/src/Makefile 2015-06-27 20:07:04.217188211 +0200
--- ice-3.6.3/csharp/src/Makefile~ 2015-06-23 17:30:20.000000000 +0200
+++ ice-3.6.3/csharp/src/Makefile 2015-06-27 20:07:04.217188211 +0200
@@ -11,7 +11,7 @@
include $(top_srcdir)/config/Make.rules.cs
@ -10,9 +10,9 @@
$(EVERYTHING)::
@for subdir in $(SUBDIRS); \
--- /dev/null 2015-06-27 16:44:15.733558105 +0200
+++ ice-3.6.2/csharp/lib/pkgconfig/IceSSL.pc 2015-06-27 20:19:30.731894653 +0200
+++ ice-3.6.3/csharp/lib/pkgconfig/IceSSL.pc 2015-06-27 20:19:30.731894653 +0200
@@ -0,0 +1,10 @@
+version = 3.6.2
+version = 3.6.3
+mono_root = /usr
+
+name = IceSSL
@ -23,9 +23,9 @@
+Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
+Requires: Ice = ${version}
--- /dev/null 2015-06-27 16:44:15.733558105 +0200
+++ ice-3.6.1/csharp/lib/pkgconfig/IceDiscovery.pc 2015-06-27 20:20:44.312515987 +0200
+++ ice-3.6.3/csharp/lib/pkgconfig/IceDiscovery.pc 2015-06-27 20:20:44.312515987 +0200
@@ -0,0 +1,10 @@
+version = 3.6.2
+version = 3.6.3
+mono_root = /usr
+
+name = IceDiscovery
@ -36,9 +36,9 @@
+Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
+Requires: Ice = ${version}
--- /dev/null 2015-06-27 16:44:15.733558105 +0200
+++ ice-3.6.1/csharp/lib/pkgconfig/IceLocatorDiscovery.pc 2015-06-27 20:21:22.206185123 +0200
+++ ice-3.6.3/csharp/lib/pkgconfig/IceLocatorDiscovery.pc 2015-06-27 20:21:22.206185123 +0200
@@ -0,0 +1,10 @@
+version = 3.6.2
+version = 3.6.3
+mono_root = /usr
+
+name = IceLocatorDiscovery

View File

@ -0,0 +1,50 @@
--- ice-3.6.3/cpp/config/Make.rules.Linux~ 2015-06-27 16:56:56.000000000 +0200
+++ ice-3.6.3/cpp/config/Make.rules.Linux 2015-06-27 17:23:45.810591931 +0200
@@ -79,19 +79,6 @@
CXXARCHFLAGS += -mtune=v8 -pipe -Wno-deprecated -DICE_USE_MUTEX_SHARED
endif
- #
- # Only use multilib -m32/-m64 options for amd64 arch, x32 arch can also run
- # in amd64 macines but doesn't use multilib, in this case MACHINE_TYPE will
- # be x86_64 and HOST_ARCH x32.
- #
- ifeq ($(HOST_ARCH),amd64)
- ifeq ($(LP64),yes)
- CXXARCHFLAGS += -m64
- else
- CXXARCHFLAGS += -m32
- endif
- endif
-
CXXFLAGS += $(CXXARCHFLAGS) -fvisibility=hidden -Wall -Werror -pthread
# If MAXWARN is set then enable extra warnings
--- ice-3.6.3/config/Make.common.rules~ 2015-06-23 17:30:20.000000000 +0200
+++ ice-3.6.3/config/Make.common.rules 2015-06-28 01:53:57.149666595 +0200
@@ -101,25 +101,7 @@
ifeq ($(LP64),)
LP64 = yes
endif
-
- #
- # x86 binaries build on x86_64 machine use 32 binsuffix
- #
- ifneq ($(STATICLIBS),yes)
- ifneq ($(LP64),yes)
- binsuffix = 32
- endif
- endif
endif
-
- #
- # x86 builds uses 32 binsuffix
- #
- ifneq ($(STATICLIBS),yes)
- ifeq ($(findstring $(MACHINE_TYPE),i386 i486 i586 i686),$(MACHINE_TYPE))
- binsuffix = 32
- endif
- endif
endif
ifeq ($(CPP11),yes)