[dev-python/pymongo-auth-aws] bump, tree candidate after checking keywords

This commit is contained in:
Robert Förster 2024-06-26 15:40:16 +02:00
parent cec770b120
commit cdb55721c8
4 changed files with 25 additions and 134 deletions

View File

@ -1 +1 @@
DIST pymongo-auth-aws-1.1.0.tar.gz 12188 BLAKE2B bf74c4d3f790d37aab82b5f9512af3f924b35392794907ecc9177194c7fcbf15dfc11e207fbfd86b18acb1404c11f0fdb63bf77ad253d7a0a3150426d3e3e8a9 SHA512 4be046628b83cb015986298d396f66f89e52f0ea26e2e8acb0c7f922f5c5b6377e1a17fc8564be1c7a82e15e252a705e35788fda5c4bf5edc81d68bbfc4f6d38
DIST pymongo_auth_aws-1.2.0.tar.gz 18576 BLAKE2B 25b0d573b099a5f6c20103dc1e295bbe54e772a374e857873120638c6a3550c86192d8d3f5626098399a493a0cb149b30df40810dfe7f5633493b5e7736e546b SHA512 35b5423d3e73b69e2c3d1d0a97a3c6cacac9b2ba9e4345c35fde44a1b3e5f9fa12f0df9525b54de5052455d28a51df07d6b4685c304eeee3de6c5916719ba463

View File

@ -1,129 +0,0 @@
https://github.com/mongodb/pymongo-auth-aws/commit/40198b0aa9d76657badb1dcf3c60298d005dca5b minus hatch-requirements-txt
--- a/dev/null 2024-04-07 00:22:51.151700697 +0200
+++ b/pyproject.toml 2024-06-21 21:07:25.763896995 +0200
@@ -0,0 +1,59 @@
+[build-system]
+requires = ["hatchling>1.24"]
+build-backend = "hatchling.build"
+
+[project]
+name = "pymongo-auth-aws"
+dynamic = ["version", "dependencies", "optional-dependencies"]
+description = "MONGODB-AWS authentication support for PyMongo"
+readme = "README.rst"
+license = {file="LICENSE"}
+requires-python = ">=3.8"
+authors = [
+ { name = "Shane Harvey", email = "drivers-python-noreply@mongodb.com" },
+]
+keywords = [
+ "MONGODB-AWS",
+ "mongo",
+ "mongodb",
+ "pymongo",
+ "pymongo-auth-aws",
+]
+classifiers = [
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: Apache Software License",
+ "Operating System :: MacOS :: MacOS X",
+ "Operating System :: Microsoft :: Windows",
+ "Operating System :: POSIX",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
+ "Programming Language :: Python :: 3.12",
+ "Topic :: Database",
+]
+
+[project.urls]
+Homepage = "https://github.com/mongodb/pymongo-auth-aws"
+
+[tool.hatch.version]
+path = "pymongo_auth_aws/version.py"
+
+[tool.ruff]
+target-version = "py37"
+line-length = 100
+
+[tool.ruff.lint]
+unfixable = [
+ "RUF100", # Unused noqa
+ "T20", # Removes print statements
+ "F401", # Unused imports
+]
+
+[tool.ruff.lint.per-file-ignores]
+"pymongo_auth_aws/__init__.py" = ["F401"]
+"test/*.py" = ["E402"]
--- a/setup.py 2022-09-13 15:56:51.000000000 +0200
+++ b/dev/null 2024-04-07 00:22:51.151700697 +0200
@@ -1,53 +0,0 @@
-import os
-
-from setuptools import setup, find_packages
-
-with open('README.rst', 'rb') as f:
- LONG_DESCRIPTION = f.read().decode('utf8')
-
-# Single source the version.
-version_file = os.path.realpath(os.path.join(
- os.path.dirname(__file__), 'pymongo_auth_aws', 'version.py'))
-version = {}
-with open(version_file) as fp:
- exec(fp.read(), version)
-
-setup(
- name="pymongo-auth-aws",
- version=version['__version__'],
- description="MONGODB-AWS authentication support for PyMongo",
- long_description=LONG_DESCRIPTION,
- long_description_content_type='text/x-rst',
- packages=find_packages(exclude=['test']),
- install_requires=['boto3', 'botocore'],
- extras_require={
- "test": ["pymongo"]
- },
- author="Shane Harvey",
- author_email="drivers-python-noreply@mongodb.com",
- url="https://github.com/mongodb/pymongo-auth-aws",
- keywords=["mongo", "mongodb", "pymongo-auth-aws", "pymongo", "MONGODB-AWS"],
- test_suite="test",
- license="Apache License, Version 2.0",
- python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*",
- classifiers=[
- "Development Status :: 5 - Production/Stable",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: Apache Software License",
- "Operating System :: MacOS :: MacOS X",
- "Operating System :: Microsoft :: Windows",
- "Operating System :: POSIX",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
- "Programming Language :: Python :: 3.5",
- "Programming Language :: Python :: 3.6",
- "Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: 3.8",
- "Programming Language :: Python :: 3.9",
- "Programming Language :: Python :: 3.10",
- "Programming Language :: Python :: Implementation :: CPython",
- "Programming Language :: Python :: Implementation :: PyPy",
- "Topic :: Database"]
-)
--- a/setup.cfg 2022-09-13 15:57:03.103746400 +0200
+++ b/dev/null 2024-04-07 00:22:51.151700697 +0200
@@ -1,7 +0,0 @@
-[bdist_wheel]
-universal = 1
-
-[egg_info]
-tag_build =
-tag_date = 0
-

View File

@ -0,0 +1,22 @@
--- a/pyproject.toml 2020-02-02 01:00:00.000000000 +0100
+++ b/pyproject.toml 2024-06-26 15:25:36.921786136 +0200
@@ -1,5 +1,5 @@
[build-system]
-requires = ["hatchling>1.24","hatch-requirements-txt>=0.4.1"]
+requires = ["hatchling>1.24"]
build-backend = "hatchling.build"
[project]
@@ -44,12 +44,6 @@
path = "pymongo_auth_aws/version.py"
validate-bump = false
-[tool.hatch.metadata.hooks.requirements_txt]
-files = ["requirements.txt"]
-
-[tool.hatch.metadata.hooks.requirements_txt.optional-dependencies]
-test = ["requirements-test.txt"]
-
[tool.ruff]
target-version = "py37"
line-length = 100

View File

@ -4,7 +4,6 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@ -33,9 +32,8 @@ BDEPEND="
)
"
# adjust after 1.1.0
PATCHES=(
"${FILESDIR}/{P}-hatchling.patch"
"${FILESDIR}/${P}-no-req-text.patch"
)
distutils_enable_tests pytest