diff --git a/net-analyzer/netdata/metadata.xml b/net-analyzer/netdata/metadata.xml
index 1625cf3..cf45a7a 100644
--- a/net-analyzer/netdata/metadata.xml
+++ b/net-analyzer/netdata/metadata.xml
@@ -11,7 +11,6 @@
Enable the Netdata database engine
Install sys-apps/ipmitool required for monitoring IPMI sensors.
Enable optimization of JSON using dev-libs/json-c
- Enable support for Amazon Kenesis as a backend
Build with Link Time Optimization (LTO)
Enable support for the mongodb backend
Enable the nfacct plugin
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index 4d70378..ef78eed 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python{3_9,3_10} )
+PYTHON_COMPAT=( python{3_9,3_10,3_11} )
inherit autotools fcaps linux-info python-single-r1 systemd toolchain-funcs
@@ -20,7 +20,7 @@ HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="caps cloud +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc kinesis +lto mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
+IUSE="caps cloud +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc +lto mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
REQUIRED_USE="
mysql? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -53,7 +53,6 @@ RDEPEND="
compression? ( sys-libs/zlib )
ipmi? ( sys-libs/freeipmi )
jsonc? ( dev-libs/json-c:= )
- kinesis? ( dev-libs/aws-sdk-cpp[kinesis] )
mongodb? ( dev-libs/mongo-c-driver )
nfacct? (
net-firewall/nfacct
@@ -79,7 +78,7 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
FILECAPS=(
- 'cap_dac_read_search,cap_sys_ptrace=ep' 'usr/libexec/netdata/plugins.d/apps.plugin' -- 'cap_setuid=ep' 'usr/libexec/netdata/plugins.d/slabinfo.plugin' -- 'cap_setuid=ep' 'usr/libexec/netdata/plugins.d/cgroup-network' -- 'cap_net_raw' 'usr/libexec/netdata/plugins.d/fping.plugin' -- 'cap_perfmon=ep' 'usr/libexec/netdata/plugins.d/perf.plugin'
+ 'cap_dac_read_search,cap_sys_ptrace=ep' 'usr/libexec/netdata/plugins.d/apps.plugin' -- 'cap_setuid=ep' 'usr/libexec/netdata/plugins.d/slabinfo.plugin' -- 'cap_setuid=ep' 'usr/libexec/netdata/plugins.d/cgroup-network' -- 'cap_perfmon=ep' 'usr/libexec/netdata/plugins.d/perf.plugin'
)
pkg_setup() {
@@ -109,7 +108,7 @@ src_configure() {
$(use_enable dbengine) \
$(use_enable nfacct plugin-nfacct) \
$(use_enable ipmi plugin-freeipmi) \
- $(use_enable kinesis exporting-kinesis) \
+ --disable-exporting-kinesis \
$(use_enable lto lto) \
$(use_enable mongodb exporting-mongodb) \
$(use_enable prometheus exporting-prometheus-remote-write) \