[dev-python/aiosqlite] bump for red 3.5
This commit is contained in:
parent
c8483a247b
commit
d3535c2d68
@ -1 +1 @@
|
||||
DIST aiosqlite-0.15.0.tar.gz 24363 BLAKE2B eb22c1c3f21d00b72d63c9e684b92808de03f3516c31f83e1b54a64a3900301d012fcb66969b80a49a60bcea0805600b59ddd9272e504dca14cf018bf43dd7eb SHA512 8f23caa28b3f7659cea0c6f7c2d1e3eeee0d278ae2ba26e2e3290eb7de7c037581718b98745bd69fd1aa058aa2c263ecf7130ca9cc007b023d6b4b3ae0ee4b5a
|
||||
DIST aiosqlite-0.17.0.tar.gz 25941 BLAKE2B 869d165bc8c791cb94159f6508f5113d915f5531117d0d79ac1f297de16cbb78574a7eaafc1bceccc9e4397f88f490b90d49becb4b7cc2c0d51e14f0afd7561b SHA512 50f9965ef7dafe91a2f41dc41489395e437080aa4b7853800d806d21f4f8042d92ff6cfd2aeadefa7ca5e4debd14f39d93ca28c89f3116b3b61b2e8829533e6e
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
EAPI="7"
|
||||
|
||||
PYTHON_COMPAT=( python3_8 )
|
||||
PYTHON_COMPAT=( python3_9 )
|
||||
DISTUTILS_USE_SETUPTOOLS="no"
|
||||
|
||||
inherit distutils-r1
|
||||
@ -21,4 +21,9 @@ RESTRICT="test"
|
||||
|
||||
DOCS=( CHANGELOG.md README.rst )
|
||||
|
||||
PATCHES=(
|
||||
# https://github.com/omnilib/aiosqlite/commit/a157e0b7d126daeeda4e5b7dcf2b6cb9cf9ac274
|
||||
"${FILESDIR}/${P}-typing.patch"
|
||||
)
|
||||
|
||||
distutils_enable_sphinx docs
|
38
dev-python/aiosqlite/files/aiosqlite-0.17.0-typing.patch
Normal file
38
dev-python/aiosqlite/files/aiosqlite-0.17.0-typing.patch
Normal file
@ -0,0 +1,38 @@
|
||||
From a157e0b7d126daeeda4e5b7dcf2b6cb9cf9ac274 Mon Sep 17 00:00:00 2001
|
||||
From: John Reese <john@noswap.com>
|
||||
Date: Sun, 16 May 2021 14:18:18 -0700
|
||||
Subject: [PATCH] Drop dependency on typing_extensions, fix #114
|
||||
|
||||
---
|
||||
aiosqlite/context.py | 4 +---
|
||||
pyproject.toml | 2 +-
|
||||
2 files changed, 2 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/aiosqlite/context.py b/aiosqlite/context.py
|
||||
index 2a2fa4e..316845f 100644
|
||||
--- a/aiosqlite/context.py
|
||||
+++ b/aiosqlite/context.py
|
||||
@@ -3,9 +3,7 @@
|
||||
|
||||
|
||||
from functools import wraps
|
||||
-from typing import Any, Callable, Coroutine, Generator, TypeVar
|
||||
-
|
||||
-from typing_extensions import AsyncContextManager
|
||||
+from typing import Any, AsyncContextManager, Callable, Coroutine, Generator, TypeVar
|
||||
|
||||
from .cursor import Cursor
|
||||
|
||||
diff --git a/pyproject.toml b/pyproject.toml
|
||||
index 4d44707..16a4013 100644
|
||||
--- a/pyproject.toml
|
||||
+++ b/pyproject.toml
|
||||
@@ -8,7 +8,7 @@ author = "John Reese"
|
||||
author-email = "john@noswap.com"
|
||||
description-file = "README.rst"
|
||||
home-page = "https://aiosqlite.omnilib.dev"
|
||||
-requires = ["typing_extensions>=3.7.2"]
|
||||
+requires = []
|
||||
requires-python = ">=3.6"
|
||||
classifiers = [
|
||||
"Development Status :: 5 - Production/Stable",
|
Loading…
Reference in New Issue
Block a user