[dev-games/StormLib] initial import for ghost++, needs another bump, but im lazy now.

This commit is contained in:
Robert Förster 2012-08-08 09:25:07 +02:00
parent 1bf6074d74
commit d5d51e1671
3 changed files with 53 additions and 0 deletions

View File

@ -0,0 +1 @@
DIST StormLib-8.10.tar.xz 397372 SHA256 c564a3ec3ec7edd875a437921239b0505ebdca95424c12ecfb643d00893506ce SHA512 0d0f503c985bfe9a8d59246d1901be032ff01a71bcc0cb4b13b9a4c066be82108f87f9722efd3bb26aaf370b282dad700eb111cad49606189f89ddf501a8de38 WHIRLPOOL 223731049ac66991083088ec6071302a1b6e95f18725b61b840931bd258eef33b6cd4802eb63f938c9f11b42668c1cc64898bf3a065b8dc307bf4f004bd36134

View File

@ -0,0 +1,33 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $Id$
EAPI="4"
inherit cmake-utils
DESCRIPTION="library to read and write MPQ archives"
HOMEPAGE="http://www.zezula.net/en/mpq/main.html"
SRC_URI="http://people.znc.in/~dessa/ghost/deps/${P}.tar.xz"
RESTRICT="mirror"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="=dev-libs/libtomcrypt-1.17-r7
sys-libs/zlib
app-arch/bzip2"
RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}/${PN}-multilib.patch"
}
src_configure() {
local mycmakeargs="
-DWITH_LIBTOMCRYPT=ON"
cmake-utils_src_configure
}

View File

@ -0,0 +1,19 @@
--- CMakeLists.txt.old 2012-01-02 09:32:42.000000000 +0100
+++ CMakeLists.txt 2012-05-05 00:42:28.000000000 +0200
@@ -237,6 +237,8 @@
test/Test.cpp
)
+set(LIB_SUFFIX "" CACHE STRING "Define suffix of directory name (32/64)")
+
add_definitions(-D_7ZIP_ST -DBZ_STRICT_ANSI)
if(WIN32)
@@ -290,6 +292,6 @@
set_target_properties(storm PROPERTIES OUTPUT_NAME StormLib)
endif()
-install(TARGETS storm RUNTIME DESTINATION bin LIBRARY DESTINATION lib ARCHIVE DESTINATION lib FRAMEWORK DESTINATION /Library/Frameworks)
+install(TARGETS storm RUNTIME DESTINATION bin LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX} FRAMEWORK DESTINATION /Library/Frameworks)
install(FILES src/StormLib.h src/StormPort.h DESTINATION include)