[sys-auth/sssd] bump
This commit is contained in:
parent
f3067850e8
commit
dada1fc5ce
@ -1,2 +1,2 @@
|
|||||||
DIST sssd-2.9.5.tar.gz 8001964 BLAKE2B e9c839e58fbeac9e8cba83b726f075c5db6ce85059546d745672c222b594f4aa26ad103f0eb3a8ff9e2b364c3502fb93c639fe9e621fefd6fecd2319f5cb499a SHA512 d219f12ffc75af233f0e4ffc62c0442acc6da3cd94ed4eab7102a78821af5257c8e4ba0d06b2c99c08e06502f8d0d0bcc80540d63823dbe0f52eb0432ae7e14d
|
DIST sssd-2.9.6.tar.gz 9136447 BLAKE2B 9ba4faa66d56150de58e86588bd0dedb02ff2f155fa118a35cd981885fed6cab5fdf13373f575a41691c87b4d18c586cba717b399e3826675eee1b0f8da967b7 SHA512 d9a35fc12022f0a2aa73be373b396411fc69b2fe5489ab93d17813a4c75b3ec30e598d5748ab202f7588039b465e11d616ce546cd5fe5439fa8edd9ac8cda69a
|
||||||
DIST sssd-2.9.5.tar.gz.asc 833 BLAKE2B eef21b8662007d895ca60eca23fae04d321e62de85a2b3df842b4e125a40fbf6aa8c968ae0f2f376b70f3566bfc06e73218384803164889d6bee8843b76e7950 SHA512 a2eb6cb6b4033e699ed654cdf26da166146ce99e009e4764daec0182ff15a9c73a6bf866dcb8611b6e3a39a5155fa3c9bfc108ed277d5e434b868a9b344959e1
|
DIST sssd-2.9.6.tar.gz.asc 833 BLAKE2B 7edd7e397d2a8c085b312efaf61f88befc4c7a1d36d3c1eb6032dcb42b5d2d3ea0f2d423b44f72a789b01158cd2f2f8550f3e8811653252754b0529dcfa65b6a SHA512 c16229f6eea97c13c1f6a78b641829af9a4c2eed5d448151b7cf4c38a6799f1cecac50c09f9e70099800641ac4c007af02c92ba7b0ef3f2529eac740d280113a
|
||||||
|
@ -1,19 +0,0 @@
|
|||||||
diff --git a/src/tools/analyzer/Makefile.am b/src/tools/analyzer/Makefile.am
|
|
||||||
index b40043d04..dce6b9d36 100644
|
|
||||||
--- a/src/tools/analyzer/Makefile.am
|
|
||||||
+++ b/src/tools/analyzer/Makefile.am
|
|
||||||
@@ -5,7 +5,9 @@ dist_sss_analyze_python_SCRIPTS = \
|
|
||||||
$(NULL)
|
|
||||||
|
|
||||||
pkgpythondir = $(python3dir)/sssd
|
|
||||||
+modulesdir = $(pkgpythondir)/modules
|
|
||||||
|
|
||||||
+if BUILD_PYTHON_BINDINGS
|
|
||||||
dist_pkgpython_DATA = \
|
|
||||||
__init__.py \
|
|
||||||
source_files.py \
|
|
||||||
@@ -20,3 +22,4 @@ dist_modules_DATA = \
|
|
||||||
modules/__init__.py \
|
|
||||||
modules/request.py \
|
|
||||||
$(NULL)
|
|
||||||
+endif
|
|
@ -1,44 +0,0 @@
|
|||||||
From 9efd79b010dbb46d9968c3d3ab073b8e585cb2ad Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alexey Tikhonov <atikhono@redhat.com>
|
|
||||||
Date: Sat, 18 Feb 2023 16:11:10 +0100
|
|
||||||
Subject: [PATCH] SSSDConfig: use 'setuptools' instead of 'distutils'
|
|
||||||
|
|
||||||
The Python standard library distutils module will be removed from Python 3.12+
|
|
||||||
|
|
||||||
Reviewed-by: Alexey Tikhonov <atikhono@redhat.com>
|
|
||||||
Reviewed-by: Justin Stephenson <jstephen@redhat.com>
|
|
||||||
---
|
|
||||||
contrib/sssd.spec.in | 2 +-
|
|
||||||
src/config/setup.py.in | 4 ++--
|
|
||||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/contrib/sssd.spec.in b/contrib/sssd.spec.in
|
|
||||||
index 6431fc9d79..21571bd976 100644
|
|
||||||
--- a/contrib/sssd.spec.in
|
|
||||||
+++ b/contrib/sssd.spec.in
|
|
||||||
@@ -144,7 +144,7 @@ BuildRequires: pcre2-devel
|
|
||||||
BuildRequires: pkgconfig
|
|
||||||
BuildRequires: popt-devel
|
|
||||||
BuildRequires: python3-devel
|
|
||||||
-BuildRequires: (python3-setuptools if python3 >= 3.12)
|
|
||||||
+BuildRequires: python3-setuptools
|
|
||||||
BuildRequires: samba-devel
|
|
||||||
# required for idmap_sss.so
|
|
||||||
BuildRequires: samba-winbind
|
|
||||||
diff --git a/src/config/setup.py.in b/src/config/setup.py.in
|
|
||||||
index 27f63c4061..613b050d53 100644
|
|
||||||
--- a/src/config/setup.py.in
|
|
||||||
+++ b/src/config/setup.py.in
|
|
||||||
@@ -19,10 +19,10 @@
|
|
||||||
#
|
|
||||||
|
|
||||||
"""
|
|
||||||
-Python-level packaging using distutils.
|
|
||||||
+Python-level packaging using setuptools.
|
|
||||||
"""
|
|
||||||
|
|
||||||
-from distutils.core import setup
|
|
||||||
+from setuptools import setup
|
|
||||||
|
|
||||||
setup(
|
|
||||||
name='SSSDConfig',
|
|
@ -15,14 +15,13 @@
|
|||||||
</maintainer>
|
</maintainer>
|
||||||
<use>
|
<use>
|
||||||
<flag name="acl"> Build and use the cifsidmap plugin</flag>
|
<flag name="acl"> Build and use the cifsidmap plugin</flag>
|
||||||
<flag name="locator">Install sssd's Kerberos plugin</flag>
|
|
||||||
<flag name="netlink">Add support for netlink protocol via <pkg>dev-libs/libnl</pkg></flag>
|
<flag name="netlink">Add support for netlink protocol via <pkg>dev-libs/libnl</pkg></flag>
|
||||||
<flag name="nfsv4">Add support for the nfsv4 idmapd plugin provided by <pkg>net-fs/nfs-utils</pkg></flag>
|
<flag name="nfsv4">Add support for the nfsv4 idmapd plugin provided by <pkg>net-fs/nfs-utils</pkg></flag>
|
||||||
<flag name="pac">Add Privileged Attribute Certificate Support for Kerberos</flag>
|
<flag name="passkey">Add support for FIDO2 passkeys"</flag>
|
||||||
<flag name="samba">Add Privileged Attribute Certificate Support for Kerberos</flag>
|
<flag name="samba">Add Privileged Attribute Certificate Support for Kerberos</flag>
|
||||||
<flag name="subid">Support subordinate uid and gid ranges in FreeIPA</flag>
|
<flag name="subid">Support subordinate uid and gid ranges in FreeIPA</flag>
|
||||||
<flag name="sudo">Build helper to let <pkg>app-admin/sudo</pkg> use sssd provided information</flag>
|
<flag name="sudo">Build helper to let <pkg>app-admin/sudo</pkg> use sssd provided information</flag>
|
||||||
<flag name="systemtap">Enable SystemTAP/DTrace tracing</flag>
|
<flag name="systemtap">Enable SystemTap/DTrace tracing</flag>
|
||||||
</use>
|
</use>
|
||||||
<upstream>
|
<upstream>
|
||||||
<remote-id type="cpe">cpe:/a:fedoraproject:sssd</remote-id>
|
<remote-id type="cpe">cpe:/a:fedoraproject:sssd</remote-id>
|
||||||
|
@ -26,10 +26,8 @@ fi
|
|||||||
|
|
||||||
LICENSE="GPL-3"
|
LICENSE="GPL-3"
|
||||||
SLOT="0"
|
SLOT="0"
|
||||||
IUSE="acl doc +netlink nfsv4 nls +man python samba selinux subid sudo systemd systemtap test"
|
IUSE="acl doc +netlink nfsv4 nls passkey samba selinux systemd systemtap test"
|
||||||
REQUIRED_USE="
|
REQUIRED_USE="( ${PYTHON_REQUIRED_USE} )"
|
||||||
python? ( ${PYTHON_REQUIRED_USE} )
|
|
||||||
test? ( sudo )"
|
|
||||||
RESTRICT="!test? ( test )"
|
RESTRICT="!test? ( test )"
|
||||||
|
|
||||||
DEPEND="
|
DEPEND="
|
||||||
@ -53,46 +51,36 @@ DEPEND="
|
|||||||
>=sys-libs/tevent-0.9.16
|
>=sys-libs/tevent-0.9.16
|
||||||
virtual/ldb:=
|
virtual/ldb:=
|
||||||
virtual/libintl
|
virtual/libintl
|
||||||
|
${PYTHON_DEPS}
|
||||||
acl? ( net-fs/cifs-utils[acl] )
|
acl? ( net-fs/cifs-utils[acl] )
|
||||||
netlink? ( dev-libs/libnl:3 )
|
netlink? ( dev-libs/libnl:3 )
|
||||||
nfsv4? ( >=net-fs/nfs-utils-2.3.1-r2 )
|
nfsv4? ( >=net-fs/nfs-utils-2.3.1-r2 )
|
||||||
nls? ( >=sys-devel/gettext-0.18 )
|
nls? ( >=sys-devel/gettext-0.18 )
|
||||||
python? (
|
passkey? ( dev-libs/libfido2:= )
|
||||||
${PYTHON_DEPS}
|
|
||||||
systemd? (
|
|
||||||
$(python_gen_cond_dep '
|
|
||||||
dev-python/python-systemd[${PYTHON_USEDEP}]
|
|
||||||
')
|
|
||||||
)
|
|
||||||
)
|
|
||||||
samba? ( >=net-fs/samba-4.10.2[winbind] )
|
samba? ( >=net-fs/samba-4.10.2[winbind] )
|
||||||
selinux? (
|
selinux? (
|
||||||
>=sys-libs/libselinux-2.1.9
|
>=sys-libs/libselinux-2.1.9
|
||||||
>=sys-libs/libsemanage-2.1
|
>=sys-libs/libsemanage-2.1
|
||||||
)
|
)
|
||||||
subid? ( >=sys-apps/shadow-4.9 )
|
|
||||||
systemd? (
|
systemd? (
|
||||||
sys-apps/systemd:=
|
sys-apps/systemd:=
|
||||||
sys-apps/util-linux
|
sys-apps/util-linux
|
||||||
|
$(python_gen_cond_dep '
|
||||||
|
dev-python/python-systemd[${PYTHON_USEDEP}]
|
||||||
|
')
|
||||||
)
|
)
|
||||||
systemtap? ( dev-debug/systemtap )"
|
systemtap? ( dev-debug/systemtap )"
|
||||||
RDEPEND="${DEPEND}
|
RDEPEND="${DEPEND}
|
||||||
|
passkey? ( sys-apps/pcsc-lite[policykit] )
|
||||||
selinux? ( >=sec-policy/selinux-sssd-2.20120725-r9 )"
|
selinux? ( >=sec-policy/selinux-sssd-2.20120725-r9 )"
|
||||||
BDEPEND="
|
BDEPEND="
|
||||||
virtual/pkgconfig
|
virtual/pkgconfig
|
||||||
|
app-text/docbook-xml-dtd:4.4
|
||||||
|
>=dev-libs/libxslt-1.1.26
|
||||||
${PYTHON_DEPS}
|
${PYTHON_DEPS}
|
||||||
python? (
|
|
||||||
$(python_gen_cond_dep '
|
|
||||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
|
||||||
')
|
|
||||||
)
|
|
||||||
doc? ( app-text/doxygen )
|
doc? ( app-text/doxygen )
|
||||||
man? (
|
nls? ( sys-devel/gettext
|
||||||
app-text/docbook-xml-dtd:4.4
|
app-text/po4a )
|
||||||
>=dev-libs/libxslt-1.1.26
|
|
||||||
nls? ( app-text/po4a )
|
|
||||||
)
|
|
||||||
nls? ( sys-devel/gettext )
|
|
||||||
test? (
|
test? (
|
||||||
dev-libs/check
|
dev-libs/check
|
||||||
dev-libs/softhsm:2
|
dev-libs/softhsm:2
|
||||||
@ -110,8 +98,6 @@ CONFIG_CHECK="~KEYS"
|
|||||||
|
|
||||||
PATCHES=(
|
PATCHES=(
|
||||||
"${FILESDIR}/${PN}-2.8.2-krb5_pw_locked.patch"
|
"${FILESDIR}/${PN}-2.8.2-krb5_pw_locked.patch"
|
||||||
"${FILESDIR}/${PN}-2.9.1-conditional-python-install.patch"
|
|
||||||
"${FILESDIR}/${PN}-2.9.4-SSSDConfig-use-setuptools-instead-of-distutils.patch"
|
|
||||||
)
|
)
|
||||||
|
|
||||||
MULTILIB_WRAPPED_HEADERS=(
|
MULTILIB_WRAPPED_HEADERS=(
|
||||||
@ -216,16 +202,16 @@ multilib_src_configure() {
|
|||||||
$(multilib_native_use_with nfsv4 nfsv4-idmapd-plugin)
|
$(multilib_native_use_with nfsv4 nfsv4-idmapd-plugin)
|
||||||
$(use_enable nls)
|
$(use_enable nls)
|
||||||
$(multilib_native_use_with netlink libnl)
|
$(multilib_native_use_with netlink libnl)
|
||||||
$(multilib_native_use_with man manpages)
|
--with-manpages
|
||||||
$(multilib_native_use_with sudo)
|
--with-sudo
|
||||||
$(multilib_native_with autofs)
|
$(multilib_native_with autofs)
|
||||||
$(multilib_native_with ssh)
|
$(multilib_native_with ssh)
|
||||||
--without-oidc-child
|
--without-oidc-child
|
||||||
--without-passkey
|
$(multilib_native_with passkey)
|
||||||
$(use_with subid)
|
--with-subid
|
||||||
$(use_enable systemtap)
|
$(use_enable systemtap)
|
||||||
--without-python2-bindings
|
--without-python2-bindings
|
||||||
$(multilib_native_use_with python python3-bindings)
|
--with-python3-bindings
|
||||||
# Annoyingly configure requires that you pick systemd XOR sysv
|
# Annoyingly configure requires that you pick systemd XOR sysv
|
||||||
--with-initscript=$(usex systemd systemd sysv)
|
--with-initscript=$(usex systemd systemd sysv)
|
||||||
KRB5_CONFIG="${ESYSROOT}"/usr/bin/krb5-config
|
KRB5_CONFIG="${ESYSROOT}"/usr/bin/krb5-config
|
||||||
@ -281,10 +267,8 @@ multilib_src_test() {
|
|||||||
multilib_src_install() {
|
multilib_src_install() {
|
||||||
if multilib_is_native_abi; then
|
if multilib_is_native_abi; then
|
||||||
emake -j1 DESTDIR="${D}" install
|
emake -j1 DESTDIR="${D}" install
|
||||||
if use python; then
|
python_fix_shebang "${ED}"
|
||||||
python_fix_shebang "${ED}"
|
python_optimize
|
||||||
python_optimize
|
|
||||||
fi
|
|
||||||
else
|
else
|
||||||
# easier than playing with automake...
|
# easier than playing with automake...
|
||||||
dopammod .libs/pam_sss.so
|
dopammod .libs/pam_sss.so
|
Loading…
Reference in New Issue
Block a user