diff --git a/net-fs/nfs-ganesha/Manifest b/net-fs/nfs-ganesha/Manifest
index 03bf266..32cbb9d 100644
--- a/net-fs/nfs-ganesha/Manifest
+++ b/net-fs/nfs-ganesha/Manifest
@@ -1 +1 @@
-DIST nfs-ganesha-4.0.3.tar.gz 1884881 BLAKE2B 8e4d2f7615b63b3e0458bd21c5c42bc9804b5428abf4c0c09e569925d10c4f9112dd8e910ef75c540ae00eae9711c9a3d8468bcb3e8d5a5c5fdd999091e1dd23 SHA512 4c1a5781e5b412003ef7a8fb3fce3bfa380200b61f58c9b9b973b369eff3f5dc367e2417cb69e33353b36baddab70b0cb08687aa9b80d8abd28d462b3b25c32b
+DIST nfs-ganesha-5.9.tar.gz 2019649 BLAKE2B cf4d2dadecbaea60ac0e8cbc6084f4b605984f6d03e96b237f34de4404d75069c377b77fcb3d6261fa46ecfd2702846281657d31e1b91187e2a5d41ee7090c05 SHA512 5446ac8d6b055cf26e588103961c7f5126d6f2da67f99be694ce4ae155a7deec9ccf006df51c246256b547118f77d5cd096a29a480b9dd4af781e6aa9eef11a4
diff --git a/net-fs/nfs-ganesha/metadata.xml b/net-fs/nfs-ganesha/metadata.xml
index 1fc8ac8..fab62b7 100644
--- a/net-fs/nfs-ganesha/metadata.xml
+++ b/net-fs/nfs-ganesha/metadata.xml
@@ -7,7 +7,6 @@
Install Admin scripts
Install GUI Admin scripts
Enable NLM/NFSv3 support
- Use of libnfsidmap for name resolution
Enable rdma storage backend support
Enable AF_VSOCK listener
diff --git a/net-fs/nfs-ganesha/nfs-ganesha-4.0.3.ebuild b/net-fs/nfs-ganesha/nfs-ganesha-5.9.ebuild
similarity index 90%
rename from net-fs/nfs-ganesha/nfs-ganesha-4.0.3.ebuild
rename to net-fs/nfs-ganesha/nfs-ganesha-5.9.ebuild
index 22d2b93..b27d5c6 100644
--- a/net-fs/nfs-ganesha/nfs-ganesha-4.0.3.ebuild
+++ b/net-fs/nfs-ganesha/nfs-ganesha-5.9.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2022 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( python3_12 )
-inherit cmake flag-o-matic python-single-r1
-#inherit cmake flag-o-matic
+inherit cmake python-single-r1
+#inherit cmake
DESCRIPTION="A NFSv3,v4,v4.1 fileserver that runs in user mode on most UNIX/Linux systems"
HOMEPAGE="https://github.com/nfs-ganesha/nfs-ganesha"
@@ -22,17 +22,19 @@ fi
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="btrfs caps dbus debug gssapi gui +nfs3 nfsidmap tools vsock"
-FS_SUPPORT=" ceph glusterfs gpfs lustre mem null proxy-v3 proxy-v4 rgw vfs xfs"
+IUSE="btrfs caps dbus debug gssapi gui +nfs3 tools vsock"
+FS_SUPPORT=" ceph glusterfs gpfs mem null proxy-v3 proxy-v4 rgw vfs xfs"
IUSE+=" ${FS_SUPPORT// / ganesha_fs_}"
REQUIRED_USE="gui? ( tools )
btrfs? ( ganesha_fs_vfs )"
+# add monitoring support at some point
+
RDEPEND="
dev-libs/jemalloc:=
dev-libs/userspace-rcu:=
- >=net-libs/ntirpc-4.0[gssapi]
+ >=net-libs/ntirpc-5.0[gssapi]
sys-apps/acl
sys-apps/util-linux
caps? ( sys-libs/libcap )
@@ -41,9 +43,7 @@ RDEPEND="
dbus? ( sys-apps/dbus )
ganesha_fs_ceph? ( sys-cluster/ceph )
ganesha_fs_glusterfs? ( sys-cluster/glusterfs )
- ganesha_fs_lustre? ( sys-cluster/lustre )
ganesha_fs_xfs? ( sys-fs/xfsprogs )
- nfsidmap? ( net-libs/libnfsidmap )
"
DEPEND="${RDEPEND}
sys-devel/bison
@@ -81,7 +81,6 @@ src_configure() {
-DUSE_BTRFSUTIL=$(usex btrfs)
-DUSE_GSS=$(usex gssapi)
-DUSE_DBUS=$(usex dbus)
- -DUSE_NFSIDMAP=$(usex nfsidmap)
-DENABLE_VFS_DEBUG_ACL=$(usex debug)
-DENABLE_RFC_ACL=$(usex debug)
-DUSE_EFENCE=$(usex debug)
@@ -91,6 +90,7 @@ src_configure() {
-DUSE_NFSACL3=$(usex nfs3)
-DUSE_NLM=$(usex nfs3)
-DUSE_VSOCK=$(usex vsock)
+ -DUSE_LEGACY_PYTHON_INSTALL=OFF
-DUSE_ADMIN_TOOLS=$(usex tools)
-DUSE_GUI_ADMIN_TOOLS=$(usex gui)
@@ -101,7 +101,6 @@ src_configure() {
-DUSE_FSAL_GLUSTER=$(usex ganesha_fs_glusterfs)
-DUSE_FSAL_GPFS=$(usex ganesha_fs_gpfs)
- -DUSE_FSAL_LUSTRE=$(usex ganesha_fs_lustre)
-DUSE_FSAL_MEM=$(usex ganesha_fs_mem)
-DUSE_FSAL_NULL=$(usex ganesha_fs_null)
-DUSE_FSAL_PROXY_V3=$(usex ganesha_fs_proxy-v3)
@@ -110,8 +109,10 @@ src_configure() {
-DUSE_FSAL_VFS=$(usex ganesha_fs_vfs)
-DUSE_FSAL_XFS=$(usex ganesha_fs_xfs)
- -DUSE_FSAL_LIZARDFS=OFF
+ -DUSE_NFSIDMAP=OFF
-DUSE_FSAL_KVSFS=OFF
+ -DUSE_FSAL_LIZARDFS=OFF
+ -DUSE_FSAL_SAUNAFS=OFF
)
if use gui || use tools; then