[dev-db/mongodb] bump, lightly build tested
This commit is contained in:
parent
b7bc74f68e
commit
f6effdf31c
@ -1,2 +1,3 @@
|
||||
DIST mongodb-4.4.29.gh.tar.gz 51651007 BLAKE2B 9e9bd08ce87659fcf788964ec1bff80baef5bb9c2f5bd4968588511d289b9baf9fc68812f72ee89f90fb557dcc8d2ecbb3f607ca8e31c2212ec9633c0b99da37 SHA512 3c32a918c8b5587b04ee9263788c250a9bbd64f34ed2c19939e78607456215697966e596c2cfd160604b629188e4bdf3fff071db268bb3c25de3077a7c2ef335
|
||||
DIST mongodb-5.0.26.gh.tar.gz 57252091 BLAKE2B a4663a4dbac90118b56646816b178680a6bd99be6abb582fdfdb662c8ddf14eb9db18ed97260a37b2d04bf11715e6cfaa34bb12c4f4b08426e3afa90908f0b3c SHA512 efd56649006bb61070a2f255e8d843e4ddab33562ec9454afe55848dcc3ce8ee90431f70c9362b14e52c4a49a162ea3075a869a6fd71f63efdd5f4358703fea4
|
||||
DIST mongodb-6.0.15.gh.tar.gz 91274369 BLAKE2B 2d3b2fc38bf5c47079aac4ec07cec042e4cc22dcde8af58a9ff8f4f64595ab7f587fa6b902ab3c8ff320a167b0d0c803fa545577c7490009e28c89857edc74bd SHA512 d7dd289356b3d64b363660b8160851089dadb8f199bfa7ce2d2bd261ba5f74e821c93af9cc3c7f9553ee1905738ca9e69c1d795be9e237fcafc6a844a336d227
|
||||
|
81
dev-db/mongodb/files/mongodb-6.0.15-boost-1.79.patch
Normal file
81
dev-db/mongodb/files/mongodb-6.0.15-boost-1.79.patch
Normal file
@ -0,0 +1,81 @@
|
||||
https://bugs.gentoo.org/844235
|
||||
--- a/src/mongo/db/auth/security_key_test.cpp
|
||||
+++ b/src/mongo/db/auth/security_key_test.cpp
|
||||
@@ -30,6 +30,7 @@
|
||||
#include "mongo/platform/basic.h"
|
||||
|
||||
#include <boost/filesystem.hpp>
|
||||
+#include <boost/filesystem/fstream.hpp>
|
||||
|
||||
#include "mongo/base/string_data.h"
|
||||
#include "mongo/db/auth/authorization_manager.h"
|
||||
--- a/src/mongo/db/storage/storage_repair_observer.cpp
|
||||
+++ b/src/mongo/db/storage/storage_repair_observer.cpp
|
||||
@@ -41,6 +41,7 @@
|
||||
#include <sys/types.h>
|
||||
#endif
|
||||
|
||||
+#include <boost/filesystem/fstream.hpp>
|
||||
#include <boost/filesystem/path.hpp>
|
||||
|
||||
#include "mongo/db/dbhelpers.h"
|
||||
--- a/src/mongo/db/storage/wiredtiger/wiredtiger_kv_engine_test.cpp
|
||||
+++ b/src/mongo/db/storage/wiredtiger/wiredtiger_kv_engine_test.cpp
|
||||
@@ -34,6 +34,7 @@
|
||||
#include "mongo/db/storage/kv/kv_engine_test_harness.h"
|
||||
|
||||
#include <boost/filesystem.hpp>
|
||||
+#include <boost/filesystem/fstream.hpp>
|
||||
#include <boost/filesystem/path.hpp>
|
||||
#include <memory>
|
||||
|
||||
--- a/src/mongo/db/storage/wiredtiger/wiredtiger_kv_engine.cpp
|
||||
+++ b/src/mongo/db/storage/wiredtiger/wiredtiger_kv_engine.cpp
|
||||
@@ -48,6 +48,7 @@
|
||||
#include "mongo/db/storage/wiredtiger/wiredtiger_kv_engine.h"
|
||||
|
||||
#include <boost/filesystem.hpp>
|
||||
+#include <boost/filesystem/fstream.hpp>
|
||||
#include <boost/filesystem/operations.hpp>
|
||||
#include <boost/filesystem/path.hpp>
|
||||
#include <boost/system/error_code.hpp>
|
||||
--- a/src/mongo/db/storage/wiredtiger/wiredtiger_util.cpp
|
||||
+++ b/src/mongo/db/storage/wiredtiger/wiredtiger_util.cpp
|
||||
@@ -36,6 +36,7 @@
|
||||
#include <limits>
|
||||
|
||||
#include <boost/filesystem.hpp>
|
||||
+#include <boost/filesystem/fstream.hpp>
|
||||
#include <boost/filesystem/path.hpp>
|
||||
|
||||
#include "mongo/base/simple_string_data_comparator.h"
|
||||
--- a/src/mongo/shell/shell_utils_extended.cpp
|
||||
+++ b/src/mongo/shell/shell_utils_extended.cpp
|
||||
@@ -37,6 +37,7 @@
|
||||
#endif
|
||||
|
||||
#include <boost/filesystem.hpp>
|
||||
+#include <boost/filesystem/fstream.hpp>
|
||||
#include <fmt/format.h>
|
||||
#include <fstream>
|
||||
|
||||
--- a/src/mongo/util/stacktrace_threads.cpp
|
||||
+++ b/src/mongo/util/stacktrace_threads.cpp
|
||||
@@ -36,6 +36,7 @@
|
||||
#include <array>
|
||||
#include <atomic>
|
||||
#include <boost/filesystem.hpp>
|
||||
+#include <boost/filesystem/fstream.hpp>
|
||||
#include <cstdint>
|
||||
#include <cstdlib>
|
||||
#include <dirent.h>
|
||||
--- a/src/mongo/util/processinfo_linux.cpp
|
||||
+++ b/src/mongo/util/processinfo_linux.cpp
|
||||
@@ -36,6 +36,7 @@
|
||||
#include <iostream>
|
||||
#include <malloc.h>
|
||||
#include <pcrecpp.h>
|
||||
+#include <fstream>
|
||||
#include <sched.h>
|
||||
#include <stdio.h>
|
||||
#include <sys/mman.h>
|
12
dev-db/mongodb/files/mongodb-6.0.15-gcc-12.patch
Normal file
12
dev-db/mongodb/files/mongodb-6.0.15-gcc-12.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff --git a/src/mongo/db/repl/tenant_file_cloner.h b/src/mongo/db/repl/tenant_file_cloner.h
|
||||
index def0952..0625e46 100644
|
||||
--- a/src/mongo/db/repl/tenant_file_cloner.h
|
||||
+++ b/src/mongo/db/repl/tenant_file_cloner.h
|
||||
@@ -32,6 +32,7 @@
|
||||
#include <boost/filesystem.hpp>
|
||||
#include <memory>
|
||||
#include <vector>
|
||||
+#include <fstream>
|
||||
|
||||
#include "mongo/db/repl/base_cloner.h"
|
||||
#include "mongo/db/repl/task_runner.h"
|
12
dev-db/mongodb/files/mongodb-6.0.15-gcc-13.patch
Normal file
12
dev-db/mongodb/files/mongodb-6.0.15-gcc-13.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff --git a/src/mongo/util/ctype.h b/src/mongo/util/ctype.h
|
||||
index a3880e2..78ee57e 100644
|
||||
--- a/src/mongo/util/ctype.h
|
||||
+++ b/src/mongo/util/ctype.h
|
||||
@@ -67,6 +67,7 @@
|
||||
#pragma once
|
||||
|
||||
#include <array>
|
||||
+#include <cstdint>
|
||||
|
||||
namespace mongo::ctype {
|
||||
namespace detail {
|
93
dev-db/mongodb/files/mongodb-6.0.15-sconstruct-changes.patch
Normal file
93
dev-db/mongodb/files/mongodb-6.0.15-sconstruct-changes.patch
Normal file
@ -0,0 +1,93 @@
|
||||
diff --git a/SConstruct b/SConstruct
|
||||
index 8367691..9061849 100644
|
||||
--- a/SConstruct
|
||||
+++ b/SConstruct
|
||||
@@ -2441,7 +2441,6 @@ if env.TargetOSIs('posix'):
|
||||
|
||||
# -Winvalid-pch Warn if a precompiled header (see Precompiled Headers) is found in the search path but can't be used.
|
||||
env.Append( CCFLAGS=["-fasynchronous-unwind-tables",
|
||||
- "-ggdb" if not env.TargetOSIs('emscripten') else "-g",
|
||||
"-Wall",
|
||||
"-Wsign-compare",
|
||||
"-Wno-unknown-pragmas",
|
||||
@@ -2497,6 +2496,8 @@ if env.TargetOSIs('posix'):
|
||||
|
||||
# env.Append( " -Wconversion" ) TODO: this doesn't really work yet
|
||||
env.Append( CXXFLAGS=["-Woverloaded-virtual"] )
|
||||
+ env.Append( CXXFLAGS=os.environ['CXXFLAGS'] )
|
||||
+ env.Append( LINKFLAGS=os.environ['LDFLAGS'] )
|
||||
|
||||
# On OS X, clang doesn't want the pthread flag at link time, or it
|
||||
# issues warnings which make it impossible for us to declare link
|
||||
@@ -2549,7 +2550,7 @@ if env.TargetOSIs('posix'):
|
||||
)
|
||||
|
||||
#make scons colorgcc friendly
|
||||
- for key in ('HOME', 'TERM'):
|
||||
+ for key in ('HOME', 'TERM', 'PATH'):
|
||||
try:
|
||||
env['ENV'][key] = os.environ[key]
|
||||
except KeyError:
|
||||
@@ -2968,43 +2969,6 @@ def doConfigure(myenv):
|
||||
myenv.AddMethod(
|
||||
functools.partial(var_func, var=var, func=CheckFlag), f"Check{var}Supported")
|
||||
|
||||
- if myenv.ToolchainIs('gcc', 'clang'):
|
||||
- # This tells clang/gcc to use the gold linker if it is available - we prefer the gold linker
|
||||
- # because it is much faster. Don't use it if the user has already configured another linker
|
||||
- # selection manually.
|
||||
- if any(flag.startswith('-fuse-ld=') for flag in env['LINKFLAGS']):
|
||||
- myenv.FatalError(f"Use the '--linker' option instead of modifying the LINKFLAGS directly.")
|
||||
-
|
||||
- linker_ld = get_option('linker')
|
||||
- if linker_ld == 'auto':
|
||||
- # lld has problems with separate debug info on some platforms. See:
|
||||
- # - https://bugzilla.mozilla.org/show_bug.cgi?id=1485556
|
||||
- # - https://bugzilla.mozilla.org/show_bug.cgi?id=1485556
|
||||
- #
|
||||
- # lld also apparently has problems with symbol resolution
|
||||
- # in some esoteric configurations that apply for us when
|
||||
- # using --link-model=dynamic mode, so disable lld there
|
||||
- # too. See:
|
||||
- # - https://bugs.llvm.org/show_bug.cgi?id=46676
|
||||
- #
|
||||
- # We should revisit all of these issues the next time we upgrade our clang minimum.
|
||||
- if get_option('separate-debug') == 'off' and get_option('link-model') != 'dynamic':
|
||||
- if not myenv.AddToLINKFLAGSIfSupported('-fuse-ld=lld'):
|
||||
- myenv.AddToLINKFLAGSIfSupported('-fuse-ld=gold')
|
||||
- else:
|
||||
- myenv.AddToLINKFLAGSIfSupported('-fuse-ld=gold')
|
||||
- elif link_model.startswith("dynamic") and linker_ld == 'bfd':
|
||||
- # BFD is not supported due to issues with it causing warnings from some of
|
||||
- # the third party libraries that mongodb is linked with:
|
||||
- # https://jira.mongodb.org/browse/SERVER-49465
|
||||
- myenv.FatalError(f"Linker {linker_ld} is not supported with dynamic link model builds.")
|
||||
- else:
|
||||
- if not myenv.AddToLINKFLAGSIfSupported(f'-fuse-ld={linker_ld}'):
|
||||
- myenv.FatalError(f"Linker {linker_ld} could not be configured.")
|
||||
-
|
||||
- if has_option('gcov') and myenv.AddToCCFLAGSIfSupported('-fprofile-update=single'):
|
||||
- myenv.AppendUnique(LINKFLAGS=['-fprofile-update=single'])
|
||||
-
|
||||
detectCompiler = Configure(myenv, help=False, custom_tests = {
|
||||
'CheckForCXXLink': CheckForCXXLink,
|
||||
})
|
||||
@@ -4344,17 +4308,11 @@ def doConfigure(myenv):
|
||||
"BOOST_LOG_NO_SHORTHAND_NAMES",
|
||||
"BOOST_LOG_USE_NATIVE_SYSLOG",
|
||||
"BOOST_LOG_WITHOUT_THREAD_ATTR",
|
||||
+ "BOOST_LOG_DYN_LINK",
|
||||
"ABSL_FORCE_ALIGNED_ACCESS",
|
||||
]
|
||||
)
|
||||
|
||||
- if link_model.startswith("dynamic") and not link_model == 'dynamic-sdk':
|
||||
- conf.env.AppendUnique(
|
||||
- CPPDEFINES=[
|
||||
- "BOOST_LOG_DYN_LINK",
|
||||
- ]
|
||||
- )
|
||||
-
|
||||
if use_system_version_of_library("boost"):
|
||||
if not conf.CheckCXXHeader( "boost/filesystem/operations.hpp" ):
|
||||
myenv.ConfError("can't find boost headers")
|
210
dev-db/mongodb/mongodb-6.0.15.ebuild
Normal file
210
dev-db/mongodb/mongodb-6.0.15.ebuild
Normal file
@ -0,0 +1,210 @@
|
||||
# Copyright 1999-2024 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
PYTHON_COMPAT=( python3_{10..12} )
|
||||
|
||||
SCONS_MIN_VERSION="3.3.1"
|
||||
CHECKREQS_DISK_BUILD="2400M"
|
||||
CHECKREQS_DISK_USR="512M"
|
||||
CHECKREQS_MEMORY="1024M"
|
||||
|
||||
inherit check-reqs flag-o-matic multiprocessing pax-utils python-any-r1 scons-utils systemd toolchain-funcs
|
||||
|
||||
MY_PV=r${PV/_rc/-rc}
|
||||
MY_P=mongo-${MY_PV}
|
||||
|
||||
DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
|
||||
HOMEPAGE="https://www.mongodb.com"
|
||||
SRC_URI="https://github.com/mongodb/mongo/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
|
||||
S="${WORKDIR}/${MY_P}"
|
||||
|
||||
LICENSE="Apache-2.0 SSPL-1"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~arm64 -riscv"
|
||||
CPU_FLAGS="cpu_flags_x86_avx"
|
||||
IUSE="debug kerberos mongosh ssl +tools ${CPU_FLAGS}"
|
||||
|
||||
# https://github.com/mongodb/mongo/wiki/Test-The-Mongodb-Server
|
||||
# resmoke needs python packages not yet present in Gentoo
|
||||
RESTRICT="test"
|
||||
|
||||
RDEPEND="acct-group/mongodb
|
||||
acct-user/mongodb
|
||||
>=app-arch/snappy-1.1.7:=
|
||||
>=dev-cpp/yaml-cpp-0.6.2:=
|
||||
dev-libs/boost:=[nls]
|
||||
>=dev-libs/libpcre-8.42[cxx]
|
||||
app-arch/zstd:=
|
||||
dev-libs/snowball-stemmer:=
|
||||
>=sys-libs/zlib-1.2.12:=
|
||||
kerberos? ( dev-libs/cyrus-sasl[kerberos] )
|
||||
ssl? (
|
||||
>=dev-libs/openssl-1.0.1g:0=
|
||||
)"
|
||||
DEPEND="${RDEPEND}
|
||||
${PYTHON_DEPS}
|
||||
sys-libs/ncurses:0=
|
||||
sys-libs/readline:0=
|
||||
debug? ( dev-debug/valgrind )"
|
||||
BDEPEND="
|
||||
$(python_gen_any_dep '
|
||||
>=dev-build/scons-3.1.1[${PYTHON_USEDEP}]
|
||||
dev-python/cheetah3[${PYTHON_USEDEP}]
|
||||
dev-python/psutil[${PYTHON_USEDEP}]
|
||||
dev-python/pymongo[${PYTHON_USEDEP}]
|
||||
dev-python/pyyaml[${PYTHON_USEDEP}]
|
||||
dev-python/regex[${PYTHON_USEDEP}]
|
||||
dev-python/typing-extensions[${PYTHON_USEDEP}]
|
||||
')
|
||||
"
|
||||
PDEPEND="
|
||||
mongosh? ( app-admin/mongosh-bin )
|
||||
tools? ( >=app-admin/mongo-tools-100 )
|
||||
"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-4.4.1-gcc11.patch"
|
||||
"${FILESDIR}/${PN}-5.0.2-no-compass.patch"
|
||||
"${FILESDIR}/${PN}-5.0.2-skip-reqs-check.patch"
|
||||
"${FILESDIR}/${P}-boost-1.79.patch"
|
||||
"${FILESDIR}/${P}-sconstruct-changes.patch"
|
||||
"${FILESDIR}/${P}-gcc-12.patch"
|
||||
"${FILESDIR}/${P}-gcc-13.patch"
|
||||
"${FILESDIR}/${PN}-4.4.10-boost-1.81.patch"
|
||||
"${FILESDIR}/${PN}-5.0.5-boost-1.81-extra.patch"
|
||||
"${FILESDIR}/${PN}-4.4.29-no-enterprise.patch"
|
||||
)
|
||||
|
||||
python_check_deps() {
|
||||
python_has_version -b ">=dev-build/scons-3.1.1[${PYTHON_USEDEP}]" &&
|
||||
python_has_version -b "dev-python/cheetah3[${PYTHON_USEDEP}]" &&
|
||||
python_has_version -b "dev-python/psutil[${PYTHON_USEDEP}]" &&
|
||||
python_has_version -b "dev-python/pymongo[${PYTHON_USEDEP}]" &&
|
||||
python_has_version -b "dev-python/pyyaml[${PYTHON_USEDEP}]" &&
|
||||
python_has_version -b "dev-python/regex[${PYTHON_USEDEP}]" &&
|
||||
python_has_version -b "dev-python/typing-extensions[${PYTHON_USEDEP}]"
|
||||
}
|
||||
|
||||
pkg_pretend() {
|
||||
# Bug 809692 + 890294
|
||||
if use amd64 && ! use cpu_flags_x86_avx; then
|
||||
ewarn "MongoDB 6.0 requires use of the AVX instruction set."
|
||||
ewarn "This ebuild will use --experimental-optimization=-sandybridge which"
|
||||
ewarn "will result in an experimental build of MongoDB as per upstream."
|
||||
ewarn "https://docs.mongodb.com/v6.0/administration/production-notes/"
|
||||
fi
|
||||
|
||||
if [[ -n ${REPLACING_VERSIONS} ]]; then
|
||||
if ver_test "$REPLACING_VERSIONS" -lt 5.0; then
|
||||
ewarn "To upgrade from a version earlier than the 5.0-series, you must"
|
||||
ewarn "successively upgrade major releases until you have upgraded"
|
||||
ewarn "to 5.0-series. Then upgrade to 6.0 series."
|
||||
else
|
||||
ewarn "Be sure to set featureCompatibilityVersion to 5.0 before upgrading."
|
||||
fi
|
||||
fi
|
||||
}
|
||||
|
||||
src_prepare() {
|
||||
default
|
||||
|
||||
# remove bundled libs
|
||||
rm -r src/third_party/{boost,pcre-*,snappy-*,yaml-cpp,zlib-*} || die
|
||||
|
||||
# remove compass
|
||||
rm -r src/mongo/installer/compass || die
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
# https://github.com/mongodb/mongo/wiki/Build-Mongodb-From-Source
|
||||
# --use-system-icu fails tests
|
||||
# --use-system-tcmalloc is strongly NOT recommended:
|
||||
# for MONGO_GIT_HASH use GitOrigin-RevId from the commit of the tag
|
||||
scons_opts=(
|
||||
AR="$(tc-getAR)"
|
||||
CC="$(tc-getCC)"
|
||||
CXX="$(tc-getCXX)"
|
||||
CCFLAGS="${CXXFLAGS}"
|
||||
|
||||
VERBOSE=1
|
||||
VARIANT_DIR=gentoo
|
||||
MONGO_VERSION="${PV}"
|
||||
MONGO_GIT_HASH="0b4f1ea980b5380a66425a90b414106a191365f4"
|
||||
|
||||
--disable-warnings-as-errors
|
||||
--jobs="$(makeopts_jobs)"
|
||||
--use-system-boost
|
||||
--use-system-pcre
|
||||
--use-system-snappy
|
||||
--use-system-stemmer
|
||||
--use-system-yaml
|
||||
--use-system-zlib
|
||||
--use-system-zstd
|
||||
)
|
||||
|
||||
use arm64 && scons_opts+=( --use-hardware-crc32=off ) # Bug 701300
|
||||
use amd64 && scons_opts+=( --experimental-optimization=-sandybridge ) # Bug 890294
|
||||
use debug && scons_opts+=( --dbg=on )
|
||||
use kerberos && scons_opts+=( --use-sasl-client )
|
||||
|
||||
scons_opts+=( --ssl=$(usex ssl on off) )
|
||||
|
||||
# Needed to avoid forcing FORTIFY_SOURCE
|
||||
# Gentoo's toolchain applies these anyway
|
||||
scons_opts+=( --runtime-hardening=off )
|
||||
|
||||
# gold is an option here but we don't really do that anymore
|
||||
if tc-ld-is-lld; then
|
||||
scons_opts+=( --linker=lld )
|
||||
else
|
||||
scons_opts+=( --linker=bfd )
|
||||
fi
|
||||
|
||||
# respect mongoDB upstream's basic recommendations
|
||||
# see bug #536688 and #526114
|
||||
if ! use debug; then
|
||||
filter-flags '-m*'
|
||||
filter-flags '-O?'
|
||||
fi
|
||||
|
||||
default
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
PREFIX="${EPREFIX}/usr" ./buildscripts/scons.py "${scons_opts[@]}" install-devcore || die
|
||||
}
|
||||
|
||||
src_install() {
|
||||
dobin build/install/bin/{mongo,mongod,mongos}
|
||||
|
||||
doman debian/mongo*.{1,5}
|
||||
dodoc README.md docs/building.md
|
||||
|
||||
newinitd "${FILESDIR}/${PN}.initd-r3" ${PN}
|
||||
newconfd "${FILESDIR}/${PN}.confd-r3" ${PN}
|
||||
newinitd "${FILESDIR}/mongos.initd-r3" mongos
|
||||
newconfd "${FILESDIR}/mongos.confd-r3" mongos
|
||||
|
||||
insinto /etc
|
||||
newins "${FILESDIR}/${PN}.conf-r3" ${PN}.conf
|
||||
newins "${FILESDIR}/mongos.conf-r2" mongos.conf
|
||||
|
||||
systemd_newunit "${FILESDIR}/${PN}.service-r1" "${PN}.service"
|
||||
|
||||
insinto /etc/logrotate.d/
|
||||
newins "${FILESDIR}/${PN}.logrotate" ${PN}
|
||||
|
||||
# see bug #526114
|
||||
pax-mark emr "${ED}"/usr/bin/{mongo,mongod,mongos}
|
||||
|
||||
diropts -m0750 -o mongodb -g mongodb
|
||||
keepdir /var/log/${PN}
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
ewarn "Make sure to read the release notes and follow the upgrade process:"
|
||||
ewarn " https://docs.mongodb.com/manual/release-notes/$(ver_cut 1-2)/"
|
||||
ewarn " https://docs.mongodb.com/manual/release-notes/$(ver_cut 1-2)/#upgrade-procedures"
|
||||
}
|
Loading…
Reference in New Issue
Block a user