25 lines
704 B
Diff
25 lines
704 B
Diff
From 0fd2c3d04a17e4957c4b4fcc838de12756de3311 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Albertson <kevin.albertson@mongodb.com>
|
|
Date: Mon, 17 Jun 2024 13:33:40 -0400
|
|
Subject: [PATCH] enable policy CMP0135 (#835)
|
|
|
|
---
|
|
CMakeLists.txt | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 4285f3d39..fe09b8857 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -7,6 +7,10 @@ elseif (DEFINED CMAKE_MSVC_RUNTIME_LIBRARY)
|
|
message (WARNING "The CMAKE_MSVC_RUNTIME_LIBRARY variable is set, but CMake is too old to understand it")
|
|
endif ()
|
|
|
|
+if (POLICY CMP0135)
|
|
+ cmake_policy (SET CMP0135 NEW)
|
|
+endif ()
|
|
+
|
|
project (mongocrypt C)
|
|
|
|
# Used for the csfle-markup util:
|