23 lines
612 B
Diff
23 lines
612 B
Diff
--- a/pyproject.toml 2020-02-02 01:00:00.000000000 +0100
|
|
+++ b/pyproject.toml 2024-06-27 00:04:16.829810520 +0200
|
|
@@ -1,5 +1,5 @@
|
|
[build-system]
|
|
-requires = ["hatchling>1.24","hatch-requirements-txt>=0.4.1"]
|
|
+requires = ["hatchling>1.24"]
|
|
build-backend = "hatchling.build"
|
|
|
|
[project]
|
|
@@ -49,12 +49,6 @@
|
|
# Used to call hatch_build.py
|
|
[tool.hatch.build.hooks.custom]
|
|
|
|
-[tool.hatch.metadata.hooks.requirements_txt]
|
|
-files = ["requirements.txt"]
|
|
-
|
|
-[tool.hatch.metadata.hooks.requirements_txt.optional-dependencies]
|
|
-test = ["requirements-test.txt"]
|
|
-
|
|
[tool.ruff.lint]
|
|
select = [
|
|
"E", "F", "W", # flake8
|