gentoo/net-nds/389-ds-base/files/389-ds-base-1.4.4.11-libxcr...

53 lines
1.6 KiB
Diff

Makefile.am | 2 +-
configure.ac | 3 +--
ldap/servers/plugins/pwdstorage/gost_yescrypt.c | 2 +-
3 files changed, 3 insertions(+), 4 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index 83bde0a9a..acd68cc5a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -193,7 +193,7 @@ LIBDL=@LIBDL@
LIBCSTD=@LIBCSTD@
LIBCRUN=@LIBCRUN@
THREADLIB=@THREADLIB@
-LIBCRYPT=@LIBCRYPT@
+LIBCRYPT=$(LIBXCRYPT_LIBS)
# We need to make sure that libpthread is linked before libc on HP-UX.
if HPUX
diff --git a/configure.ac b/configure.ac
index a951828d6..7b08ac0b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -657,8 +657,6 @@ case $host in
# some programs use the native thread library directly
THREADLIB=-lpthread
AC_SUBST([THREADLIB], [$THREADLIB])
- LIBCRYPT=-lcrypt
- AC_SUBST([LIBCRYPT], [$LIBCRYPT])
AC_DEFINE([USE_POSIX_RWLOCKS], [1], [POSIX rwlocks])
;;
*-*-freebsd*)
@@ -806,6 +804,7 @@ AM_CONDITIONAL([SPARC],[test "x$TARGET" = xSPARC])
# Check for library dependencies
PKG_CHECK_MODULES([EVENT], [libevent])
+PKG_CHECK_MODULES([LIBXCRYPT], [libxcrypt])
if $PKG_CONFIG --exists nspr; then
PKG_CHECK_MODULES([NSPR], [nspr])
diff --git a/ldap/servers/plugins/pwdstorage/gost_yescrypt.c b/ldap/servers/plugins/pwdstorage/gost_yescrypt.c
index 2af1c2919..2ddd30129 100644
--- a/ldap/servers/plugins/pwdstorage/gost_yescrypt.c
+++ b/ldap/servers/plugins/pwdstorage/gost_yescrypt.c
@@ -7,7 +7,7 @@
#include <config.h>
#endif
-#include <crypt.h>
+#include <xcrypt/crypt.h>
#include <errno.h>
#include "pwdstorage.h"