130 lines
4.3 KiB
Diff
130 lines
4.3 KiB
Diff
https://github.com/mongodb/pymongo-auth-aws/commit/40198b0aa9d76657badb1dcf3c60298d005dca5b minus hatch-requirements-txt
|
|
--- a/dev/null 2024-04-07 00:22:51.151700697 +0200
|
|
+++ b/pyproject.toml 2024-06-21 21:07:25.763896995 +0200
|
|
@@ -0,0 +1,59 @@
|
|
+[build-system]
|
|
+requires = ["hatchling>1.24"]
|
|
+build-backend = "hatchling.build"
|
|
+
|
|
+[project]
|
|
+name = "pymongo-auth-aws"
|
|
+dynamic = ["version", "dependencies", "optional-dependencies"]
|
|
+description = "MONGODB-AWS authentication support for PyMongo"
|
|
+readme = "README.rst"
|
|
+license = {file="LICENSE"}
|
|
+requires-python = ">=3.8"
|
|
+authors = [
|
|
+ { name = "Shane Harvey", email = "drivers-python-noreply@mongodb.com" },
|
|
+]
|
|
+keywords = [
|
|
+ "MONGODB-AWS",
|
|
+ "mongo",
|
|
+ "mongodb",
|
|
+ "pymongo",
|
|
+ "pymongo-auth-aws",
|
|
+]
|
|
+classifiers = [
|
|
+ "Development Status :: 5 - Production/Stable",
|
|
+ "Intended Audience :: Developers",
|
|
+ "License :: OSI Approved :: Apache Software License",
|
|
+ "Operating System :: MacOS :: MacOS X",
|
|
+ "Operating System :: Microsoft :: Windows",
|
|
+ "Operating System :: POSIX",
|
|
+ "Programming Language :: Python :: 3",
|
|
+ "Programming Language :: Python :: 3.8",
|
|
+ "Programming Language :: Python :: 3.9",
|
|
+ "Programming Language :: Python :: Implementation :: CPython",
|
|
+ "Programming Language :: Python :: Implementation :: PyPy",
|
|
+ "Programming Language :: Python :: 3.10",
|
|
+ "Programming Language :: Python :: 3.11",
|
|
+ "Programming Language :: Python :: 3.12",
|
|
+ "Topic :: Database",
|
|
+]
|
|
+
|
|
+[project.urls]
|
|
+Homepage = "https://github.com/mongodb/pymongo-auth-aws"
|
|
+
|
|
+[tool.hatch.version]
|
|
+path = "pymongo_auth_aws/version.py"
|
|
+
|
|
+[tool.ruff]
|
|
+target-version = "py37"
|
|
+line-length = 100
|
|
+
|
|
+[tool.ruff.lint]
|
|
+unfixable = [
|
|
+ "RUF100", # Unused noqa
|
|
+ "T20", # Removes print statements
|
|
+ "F401", # Unused imports
|
|
+]
|
|
+
|
|
+[tool.ruff.lint.per-file-ignores]
|
|
+"pymongo_auth_aws/__init__.py" = ["F401"]
|
|
+"test/*.py" = ["E402"]
|
|
--- a/setup.py 2022-09-13 15:56:51.000000000 +0200
|
|
+++ b/dev/null 2024-04-07 00:22:51.151700697 +0200
|
|
@@ -1,53 +0,0 @@
|
|
-import os
|
|
-
|
|
-from setuptools import setup, find_packages
|
|
-
|
|
-with open('README.rst', 'rb') as f:
|
|
- LONG_DESCRIPTION = f.read().decode('utf8')
|
|
-
|
|
-# Single source the version.
|
|
-version_file = os.path.realpath(os.path.join(
|
|
- os.path.dirname(__file__), 'pymongo_auth_aws', 'version.py'))
|
|
-version = {}
|
|
-with open(version_file) as fp:
|
|
- exec(fp.read(), version)
|
|
-
|
|
-setup(
|
|
- name="pymongo-auth-aws",
|
|
- version=version['__version__'],
|
|
- description="MONGODB-AWS authentication support for PyMongo",
|
|
- long_description=LONG_DESCRIPTION,
|
|
- long_description_content_type='text/x-rst',
|
|
- packages=find_packages(exclude=['test']),
|
|
- install_requires=['boto3', 'botocore'],
|
|
- extras_require={
|
|
- "test": ["pymongo"]
|
|
- },
|
|
- author="Shane Harvey",
|
|
- author_email="drivers-python-noreply@mongodb.com",
|
|
- url="https://github.com/mongodb/pymongo-auth-aws",
|
|
- keywords=["mongo", "mongodb", "pymongo-auth-aws", "pymongo", "MONGODB-AWS"],
|
|
- test_suite="test",
|
|
- license="Apache License, Version 2.0",
|
|
- python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*",
|
|
- classifiers=[
|
|
- "Development Status :: 5 - Production/Stable",
|
|
- "Intended Audience :: Developers",
|
|
- "License :: OSI Approved :: Apache Software License",
|
|
- "Operating System :: MacOS :: MacOS X",
|
|
- "Operating System :: Microsoft :: Windows",
|
|
- "Operating System :: POSIX",
|
|
- "Programming Language :: Python :: 2",
|
|
- "Programming Language :: Python :: 2.7",
|
|
- "Programming Language :: Python :: 3",
|
|
- "Programming Language :: Python :: 3.4",
|
|
- "Programming Language :: Python :: 3.5",
|
|
- "Programming Language :: Python :: 3.6",
|
|
- "Programming Language :: Python :: 3.7",
|
|
- "Programming Language :: Python :: 3.8",
|
|
- "Programming Language :: Python :: 3.9",
|
|
- "Programming Language :: Python :: 3.10",
|
|
- "Programming Language :: Python :: Implementation :: CPython",
|
|
- "Programming Language :: Python :: Implementation :: PyPy",
|
|
- "Topic :: Database"]
|
|
-)
|
|
--- a/setup.cfg 2022-09-13 15:57:03.103746400 +0200
|
|
+++ b/dev/null 2024-04-07 00:22:51.151700697 +0200
|
|
@@ -1,7 +0,0 @@
|
|
-[bdist_wheel]
|
|
-universal = 1
|
|
-
|
|
-[egg_info]
|
|
-tag_build =
|
|
-tag_date = 0
|
|
-
|