39 lines
1.1 KiB
Diff
39 lines
1.1 KiB
Diff
From a157e0b7d126daeeda4e5b7dcf2b6cb9cf9ac274 Mon Sep 17 00:00:00 2001
|
|
From: John Reese <john@noswap.com>
|
|
Date: Sun, 16 May 2021 14:18:18 -0700
|
|
Subject: [PATCH] Drop dependency on typing_extensions, fix #114
|
|
|
|
---
|
|
aiosqlite/context.py | 4 +---
|
|
pyproject.toml | 2 +-
|
|
2 files changed, 2 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/aiosqlite/context.py b/aiosqlite/context.py
|
|
index 2a2fa4e..316845f 100644
|
|
--- a/aiosqlite/context.py
|
|
+++ b/aiosqlite/context.py
|
|
@@ -3,9 +3,7 @@
|
|
|
|
|
|
from functools import wraps
|
|
-from typing import Any, Callable, Coroutine, Generator, TypeVar
|
|
-
|
|
-from typing_extensions import AsyncContextManager
|
|
+from typing import Any, AsyncContextManager, Callable, Coroutine, Generator, TypeVar
|
|
|
|
from .cursor import Cursor
|
|
|
|
diff --git a/pyproject.toml b/pyproject.toml
|
|
index 4d44707..16a4013 100644
|
|
--- a/pyproject.toml
|
|
+++ b/pyproject.toml
|
|
@@ -8,7 +8,7 @@ author = "John Reese"
|
|
author-email = "john@noswap.com"
|
|
description-file = "README.rst"
|
|
home-page = "https://aiosqlite.omnilib.dev"
|
|
-requires = ["typing_extensions>=3.7.2"]
|
|
+requires = []
|
|
requires-python = ">=3.6"
|
|
classifiers = [
|
|
"Development Status :: 5 - Production/Stable",
|