gentoo/sci-misc/boinc/files/boinc-7.4.0-fix_subdirs.patch

72 lines
1.9 KiB
Diff

diff --git a/Makefile.am b/Makefile.am
index 3287187..f60ffae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,16 +10,16 @@ ACLOCAL_AMFLAGS = -I m4
if ENABLE_LIBRARIES
API_SUBDIRS = api lib
-if ENABLE_SERVER
- API_SUBDIRS += zip
-endif
-if ENABLE_BOINCZIP
- API_SUBDIRS += zip
-endif
+#if ENABLE_SERVER
+# API_SUBDIRS += zip
+#endif
+#if ENABLE_BOINCZIP
+# API_SUBDIRS += zip
+#endif
endif
if ENABLE_SERVER
- SERVER_SUBDIRS = db test py sched apps tools vda html
+ SERVER_SUBDIRS = db test py sched apps tools vda
## once contained samples/example_app which breaks out-of-source-tree builds
endif
@@ -29,9 +29,9 @@ endif
if ENABLE_MANAGER
CLIENTGUI_SUBDIRS = clientgui locale
-if BUILD_X11_SCREENSAVER
- CLIENTGUI_SUBDIRS += clientscr
-endif
+#if BUILD_X11_SCREENSAVER
+# CLIENTGUI_SUBDIRS += clientscr
+#endif
endif
# ORDER MATTERS below. One must build dependencies FIRST, then things
diff --git a/configure.ac b/configure.ac
index 8b8b84a..93acf0e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1106,7 +1106,6 @@ AC_CONFIG_FILES([
apps/Makefile
clientgui/Makefile
clientgui/res/Makefile
- clientscr/Makefile
client/Makefile
client/win/boinc_path_config.py:py/boinc_path_config.py.in
client/scripts/Makefile
@@ -1114,7 +1113,6 @@ AC_CONFIG_FILES([
db/Makefile
doc/Makefile
doc/manpages/Makefile
- html/Makefile
lib/Makefile
locale/Makefile
Makefile
@@ -1144,9 +1142,6 @@ AC_CONFIG_FILES([
tools/boinc_path_config.py:py/boinc_path_config.py.in
tools/Makefile
vda/Makefile
- zip/Makefile
- zip/zip/Makefile
- zip/unzip/Makefile
m4/Makefile
])