diff --git a/metadata/layout.conf b/metadata/layout.conf
index 6244c28..c448a36 100644
--- a/metadata/layout.conf
+++ b/metadata/layout.conf
@@ -1,6 +1,3 @@
-# we inerhit eclasses from gentoo
-masters = gentoo
-
# This went live Wednesday, July 4, 2012 at 10:00 UTC
# For more details, please see: http://archives.gentoo.org/gentoo-dev-announce/msg_00000.xml
# and/or GLEP 59.
@@ -8,27 +5,33 @@ manifest-hashes = SHA256 SHA512 WHIRLPOOL
# Bug #470670 - gentoo's council says to deprecate EAPIs 1 and 2.
# 2014-02-25 council meeting deprecated EAPIs 0 and 3.
-eapis-deprecated = 0 1 2 3
+# 2015-10-11 council meeting deprecated EAPI 4.
+#eapis-banned 1
+eapis-deprecated = 0 1 2 3 4
# Bug #337853 - gentoo's council says to enable
# --echangelog by default for the "gentoo" repo
-# we don't do it, use git log instead.
+# INFRA NOTE 2015/08/08: No more old ChangeLogs in Git
update-changelog = false
-# Use thin manifests
+# Make egencache generate newer (more reliable)
+# md5-dict cache format (see bug #409445).
+# NOTE: list md5-dict first so clients prefer it
+# INFRA NOTE: Format 'pms' was removed on Aug 6 2012. (Announced prior as Aug 1
+# 2012 was the removal date)
+cache-formats = md5-dict
+
+# Use thin Manifests for Git
thin-manifests = true
-# Dont sign thin manifests. There is no current policy for git commit signing
+# Sign Git commits, and NOT Manifests
+sign-commits = true
sign-manifests = false
+# we inerhit eclasses from gentoo
+masters = gentoo
+
# the default *is* actually pms, but better safe then sorry
# since we don't actually need stuff like package.* as
# directory
profile-formats = pms
-
-# Make egencache generate newer (more reliable)
-# md5-dict cache format (see bug #409445).
-# NOTE: list md5-dict first so clients prefer it
-# INFRA NOTE: Format 'pms' was removed on Aug 6 2012. (Announced prior as Aug 1
-# 2012 was the removal date)
-cache-formats = md5-dict
diff --git a/profiles/eapi b/profiles/eapi
index d00491f..7ed6ff8 100644
--- a/profiles/eapi
+++ b/profiles/eapi
@@ -1 +1 @@
-1
+5
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index f05b83b..249e60f 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -16,3 +16,4 @@ www-apps/froxlor:nginx - use nginx instead of Apache
www-apps/froxlor:pureftpd - use pure-FTPd instead of ProFTPd
www-apps/froxlor:quota - Adds support for Filesystem-Quotas
www-apps/froxlor:tickets - Adds support for the Ticket System
+www-apps/froxlor:vsftpd - use vsFTPd instead of ProFTPd
diff --git a/www-apps/froxlor/froxlor-0.9.34-r1.ebuild b/www-apps/froxlor/froxlor-0.9.34-r1.ebuild
index ee477e9..053268f 100644
--- a/www-apps/froxlor/froxlor-0.9.34-r1.ebuild
+++ b/www-apps/froxlor/froxlor-0.9.34-r1.ebuild
@@ -22,16 +22,14 @@ HOMEPAGE="http://www.froxlor.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="awstats bind domainkey +dovecot fcgid ftpquota fpm lighttpd +log mailquota nginx pureftpd quota ssl +tickets vsftpd"
-
-PHP_REQUIRED_FLAGS="bcmath,cli,ctype,filter,ftp,gd,mysql,nls,pcntl,pdo,posix,session,simplexml,ssl=,tokenizer,unicode,xml,xslt,zlib"
+IUSE="awstats bind domainkey +dovecot fcgid ftpquota fpm libressl lighttpd +log mailquota nginx pureftpd quota ssl +tickets vsftpd"
DEPEND="
!www-apps/syscp
>=mail-mta/postfix-2.4[mysql,ssl=]
virtual/cron
virtual/mysql
- >=dev-lang/php-5.3[${PHP_REQUIRED_FLAGS}]
+ >=dev-lang/php-5.3:*[bcmath,cli,ctype,filter,ftp,gd,mysql,nls,pcntl,pdo,posix,session,simplexml,ssl=,tokenizer,unicode,xml,xslt,zlib]
pureftpd? (
net-ftp/pure-ftpd[mysql,ssl=]
)
@@ -55,21 +53,24 @@ DEPEND="
bind? ( net-dns/bind
domainkey? ( mail-filter/opendkim )
)
- ssl? ( dev-libs/openssl )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-1.0.2:* )
+ libressl? ( dev-libs/libressl:= )
+ )
lighttpd? ( www-servers/lighttpd[php,ssl=] )
nginx? (
- www-servers/nginx[ssl=]
+ www-servers/nginx:*[ssl=]
)
!lighttpd? (
( !nginx? (
www-servers/apache[ssl=]
!fpm? (
- dev-lang/php[apache2]
+ dev-lang/php:*[apache2]
)
)
)
)
- fcgid? ( dev-lang/php[cgi]
+ fcgid? ( dev-lang/php:*[cgi]
sys-auth/libnss-mysql
( !lighttpd? (
!nginx? (
@@ -79,7 +80,7 @@ DEPEND="
)
)
)
- fpm? ( dev-lang/php[fpm]
+ fpm? ( dev-lang/php:*[fpm]
sys-auth/libnss-mysql
)
dovecot? ( >=net-mail/dovecot-2.2.0[mysql,ssl=]
diff --git a/www-apps/froxlor/froxlor-9999.ebuild b/www-apps/froxlor/froxlor-9999.ebuild
index ee477e9..053268f 100644
--- a/www-apps/froxlor/froxlor-9999.ebuild
+++ b/www-apps/froxlor/froxlor-9999.ebuild
@@ -22,16 +22,14 @@ HOMEPAGE="http://www.froxlor.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="awstats bind domainkey +dovecot fcgid ftpquota fpm lighttpd +log mailquota nginx pureftpd quota ssl +tickets vsftpd"
-
-PHP_REQUIRED_FLAGS="bcmath,cli,ctype,filter,ftp,gd,mysql,nls,pcntl,pdo,posix,session,simplexml,ssl=,tokenizer,unicode,xml,xslt,zlib"
+IUSE="awstats bind domainkey +dovecot fcgid ftpquota fpm libressl lighttpd +log mailquota nginx pureftpd quota ssl +tickets vsftpd"
DEPEND="
!www-apps/syscp
>=mail-mta/postfix-2.4[mysql,ssl=]
virtual/cron
virtual/mysql
- >=dev-lang/php-5.3[${PHP_REQUIRED_FLAGS}]
+ >=dev-lang/php-5.3:*[bcmath,cli,ctype,filter,ftp,gd,mysql,nls,pcntl,pdo,posix,session,simplexml,ssl=,tokenizer,unicode,xml,xslt,zlib]
pureftpd? (
net-ftp/pure-ftpd[mysql,ssl=]
)
@@ -55,21 +53,24 @@ DEPEND="
bind? ( net-dns/bind
domainkey? ( mail-filter/opendkim )
)
- ssl? ( dev-libs/openssl )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-1.0.2:* )
+ libressl? ( dev-libs/libressl:= )
+ )
lighttpd? ( www-servers/lighttpd[php,ssl=] )
nginx? (
- www-servers/nginx[ssl=]
+ www-servers/nginx:*[ssl=]
)
!lighttpd? (
( !nginx? (
www-servers/apache[ssl=]
!fpm? (
- dev-lang/php[apache2]
+ dev-lang/php:*[apache2]
)
)
)
)
- fcgid? ( dev-lang/php[cgi]
+ fcgid? ( dev-lang/php:*[cgi]
sys-auth/libnss-mysql
( !lighttpd? (
!nginx? (
@@ -79,7 +80,7 @@ DEPEND="
)
)
)
- fpm? ( dev-lang/php[fpm]
+ fpm? ( dev-lang/php:*[fpm]
sys-auth/libnss-mysql
)
dovecot? ( >=net-mail/dovecot-2.2.0[mysql,ssl=]
diff --git a/www-apps/froxlor/metadata.xml b/www-apps/froxlor/metadata.xml
index 4971c66..0b75237 100644
--- a/www-apps/froxlor/metadata.xml
+++ b/www-apps/froxlor/metadata.xml
@@ -23,6 +23,7 @@
use pure-FTPd instead of ProFTPd
Adds support for Filesystem-Quotas
Adds support for the Ticket System
+ use vsFTPd instead of ProFTPd
Froxlor/Froxlor