[net-im/spectrum2] sync with tree
This commit is contained in:
parent
71220bfa36
commit
1576e7e459
@ -1,13 +0,0 @@
|
||||
--- a/CMakeLists.txt 2018-04-27 12:27:02.000000000 +0200
|
||||
+++ b/CMakeLists.txt 2018-04-29 18:17:42.157170288 +0200
|
||||
@@ -399,10 +399,6 @@
|
||||
endif()
|
||||
|
||||
if(CMAKE_BUILD_TYPE MATCHES Debug)
|
||||
- if (CMAKE_COMPILER_IS_GNUCXX)
|
||||
- ADD_DEFINITIONS(-O0)
|
||||
- ADD_DEFINITIONS(-ggdb)
|
||||
- endif()
|
||||
ADD_DEFINITIONS(-DDEBUG)
|
||||
message("Debug : yes")
|
||||
else(CMAKE_BUILD_TYPE MATCHES Debug)
|
@ -1,7 +1,7 @@
|
||||
# Copyright 1999-2019 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=6
|
||||
EAPI=7
|
||||
|
||||
PYTHON_COMPAT=( python2_7 )
|
||||
|
||||
@ -14,7 +14,7 @@ if [[ ${PV} = "9999" ]] ; then
|
||||
else
|
||||
RESTRICT="mirror"
|
||||
SRC_URI="https://github.com/SpectrumIM/spectrum2/archive/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
KEYWORDS="~amd64"
|
||||
fi
|
||||
|
||||
DESCRIPTION="An open source instant messaging transport"
|
||||
@ -22,11 +22,11 @@ HOMEPAGE="https://www.spectrum.im"
|
||||
|
||||
LICENSE="GPL-2+"
|
||||
SLOT="0"
|
||||
IUSE="debug doc frotz irc mysql postgres purple sms +sqlite test twitter whatsapp xmpp"
|
||||
IUSE="doc frotz irc mysql postgres purple sms +sqlite test twitter whatsapp xmpp"
|
||||
REQUIRED_USE="|| ( mysql postgres sqlite )"
|
||||
|
||||
RDEPEND="
|
||||
dev-libs/boost:=
|
||||
dev-libs/boost:=[nls]
|
||||
dev-libs/expat
|
||||
dev-libs/libev:=
|
||||
dev-libs/log4cxx
|
||||
@ -67,11 +67,6 @@ DEPEND="
|
||||
)
|
||||
"
|
||||
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/remove_debug_cflags.patch"
|
||||
)
|
||||
|
||||
# Tests are currently restricted, as they do completly fail
|
||||
RESTRICT="test"
|
||||
|
||||
@ -86,13 +81,10 @@ src_prepare() {
|
||||
# Respect users LDFLAGS
|
||||
sed -i -e "s/-Wl,-export-dynamic/& ${LDFLAGS}/" spectrum/src/CMakeLists.txt || die
|
||||
|
||||
# Respect users CFLAGS, when compiling for debug mode
|
||||
cmake-utils_src_prepare
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
use debug && CMAKE_BUILD_TYPE="Debug"
|
||||
|
||||
local mycmakeargs=(
|
||||
-DENABLE_DOCS="$(usex doc)"
|
||||
-DENABLE_FROTZ="$(usex frotz)"
|
||||
|
Loading…
Reference in New Issue
Block a user