[sys-process/audit] version bump
This commit is contained in:
parent
8ae35daa62
commit
c8fffc1ee2
@ -1 +1 @@
|
||||
DIST audit-2.4.1.tar.gz 942147 SHA256 059346fa0e922faf4dcc054382b21f4845cd8c4942e82cfd0d4cd52bd2b03026 SHA512 4ca29ee2c784861f75f9e05f5c4dfc3d3ebb9d51e454e8a069ef4d08db3754fb19189714935351e70b26ed44347a266ae6c31e68361d5e9efd89f657f91dbd50 WHIRLPOOL 49ecfdd2363eb8bcf25d40b36bf228c8bd31611804b284dde004d42a250a39c387bd0abff223cf4041f62805d5bb189a19375f5806385344ca219d823d267f2e
|
||||
DIST audit-2.4.3.tar.gz 998974 SHA256 9c914704fecc602e143e37152f3efbab2469692684c1a8cc1b801c1b49c7abc6 SHA512 2bbaa11ed5e2d8138711df325ec1997c4eb955123699fd330b5272b7f3475ca61c9753e1c103abfc9c49e1fc8aaf52dbd55545e3f1874214979ddece64ad79aa WHIRLPOOL 1a0c0a273fddc49d15322a2423d4038488738d6597d0641182befab91646355bbee393a5d09d446dc4cf2f4579dd7ea99928cadd77bc72c355db0a10d4964da5
|
||||
|
@ -4,7 +4,7 @@
|
||||
|
||||
EAPI="5"
|
||||
|
||||
PYTHON_COMPAT=( python2_7 )
|
||||
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
|
||||
|
||||
inherit autotools multilib multilib-minimal toolchain-funcs python-r1 linux-info eutils systemd
|
||||
|
||||
@ -39,6 +39,8 @@ pkg_setup() {
|
||||
}
|
||||
|
||||
src_prepare() {
|
||||
epatch_user
|
||||
|
||||
# Do not build GUI tools
|
||||
sed -i \
|
||||
-e '/AC_CONFIG_SUBDIRS.*system-config-audit/d' \
|
||||
@ -58,16 +60,15 @@ src_prepare() {
|
||||
fi
|
||||
|
||||
# Don't build static version of Python module.
|
||||
epatch "${FILESDIR}"/${PN}-2.4.1-python.patch
|
||||
epatch "${FILESDIR}"/${PN}-2.4.3-python.patch
|
||||
|
||||
# glibc/kernel upstreams suck with both defining ia64_fpreg
|
||||
# This patch is a horribly workaround that is only valid as long as you
|
||||
# don't need the OTHER definitions in fpu.h.
|
||||
epatch "${FILESDIR}"/${PN}-2.1.3-ia64-compile-fix.patch
|
||||
|
||||
# Python bindings are built/installed manually.
|
||||
sed -e "/^SUBDIRS =/s/ python//" -i bindings/Makefile.am
|
||||
sed -e "/^SUBDIRS .*=/s/ swig//" -i Makefile.am
|
||||
# there is no --without-golang conf option
|
||||
sed -e "/^SUBDIRS =/s/ @gobind_dir@//" -i bindings/Makefile.am || die
|
||||
|
||||
# Regenerate autotooling
|
||||
eautoreconf
|
||||
@ -85,6 +86,7 @@ multilib_src_configure() {
|
||||
--enable-systemd \
|
||||
--without-prelude \
|
||||
--without-python \
|
||||
--without-python3 \
|
||||
$(use_with arm64 aarch64) \
|
||||
$(use_with alpha) \
|
||||
$(use_with arm) \
|
||||
@ -95,7 +97,12 @@ multilib_src_configure() {
|
||||
python_configure() {
|
||||
mkdir -p "${BUILD_DIR}" || die
|
||||
cd "${BUILD_DIR}" || die
|
||||
econf --with-python
|
||||
|
||||
if python_is_python3; then
|
||||
econf --without-python --with-python3
|
||||
else
|
||||
econf --with-python --without-python3
|
||||
fi
|
||||
}
|
||||
|
||||
use python && python_foreach_impl python_configure
|
||||
@ -107,15 +114,28 @@ multilib_src_compile() {
|
||||
default
|
||||
|
||||
python_compile() {
|
||||
emake -C "${BUILD_DIR}"/swig \
|
||||
local pysuffix pydef
|
||||
if python_is_python3; then
|
||||
pysuffix=3
|
||||
pydef='USE_PYTHON3=true'
|
||||
else
|
||||
pysuffix=2
|
||||
pydef='HAVE_PYTHON=true'
|
||||
fi
|
||||
|
||||
emake -C "${BUILD_DIR}"/bindings/swig \
|
||||
VPATH="${native_build}/lib" \
|
||||
LIBS="${native_build}/lib/libaudit.la"
|
||||
emake -C "${BUILD_DIR}"/bindings/python \
|
||||
VPATH="${S}/bindings/python:${native_build}/bindings/python" \
|
||||
auparse_la_LIBADD="${native_build}/auparse/libauparse.la ${native_build}/lib/libaudit.la"
|
||||
LIBS="${native_build}/lib/libaudit.la" \
|
||||
_audit_la_LIBADD="${native_build}/lib/libaudit.la" \
|
||||
_audit_la_DEPENDENCIES="${S}/lib/libaudit.h ${native_build}/lib/libaudit.la" \
|
||||
${pydef}
|
||||
emake -C "${BUILD_DIR}"/bindings/python/python${pysuffix} \
|
||||
VPATH="${S}/bindings/python/python${pysuffix}:${native_build}/bindings/python/python${pysuffix}" \
|
||||
auparse_la_LIBADD="${native_build}/auparse/libauparse.la ${native_build}/lib/libaudit.la" \
|
||||
${pydef}
|
||||
}
|
||||
|
||||
local native_build=${BUILD_DIR}
|
||||
local native_build="${BUILD_DIR}"
|
||||
use python && python_foreach_impl python_compile
|
||||
else
|
||||
emake -C lib
|
||||
@ -128,11 +148,26 @@ multilib_src_install() {
|
||||
emake DESTDIR="${D}" initdir="$(systemd_get_unitdir)" install
|
||||
|
||||
python_install() {
|
||||
emake -C "${BUILD_DIR}"/swig \
|
||||
local pysuffix pydef
|
||||
if python_is_python3; then
|
||||
pysuffix=3
|
||||
pydef='USE_PYTHON3=true'
|
||||
else
|
||||
pysuffix=2
|
||||
pydef='HAVE_PYTHON=true'
|
||||
fi
|
||||
|
||||
emake -C "${BUILD_DIR}"/bindings/swig \
|
||||
VPATH="${native_build}/lib" \
|
||||
LIBS="${native_build}/lib/libaudit.la" \
|
||||
_audit_la_LIBADD="${native_build}/lib/libaudit.la" \
|
||||
_audit_la_DEPENDENCIES="${S}/lib/libaudit.h ${native_build}/lib/libaudit.la" \
|
||||
${pydef} \
|
||||
DESTDIR="${D}" install
|
||||
emake -C "${BUILD_DIR}"/bindings/python \
|
||||
VPATH="${S}/bindings/python:${native_build}/bindings/python" \
|
||||
emake -C "${BUILD_DIR}"/bindings/python/python${pysuffix} \
|
||||
VPATH="${S}/bindings/python/python${pysuffix}:${native_build}/bindings/python/python${pysuffix}" \
|
||||
auparse_la_LIBADD="${native_build}/auparse/libauparse.la ${native_build}/lib/libaudit.la" \
|
||||
${pydef} \
|
||||
DESTDIR="${D}" install
|
||||
}
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -Nuar --exclude '*.orig' audit-2.1.3.orig/bindings/python/Makefile.am audit-2.1.3/bindings/python/Makefile.am
|
||||
--- audit-2.1.3.orig/bindings/python/Makefile.am 2011-08-15 17:31:01.000000000 +0000
|
||||
+++ audit-2.1.3/bindings/python/Makefile.am 2011-09-10 19:01:36.974983756 +0000
|
||||
@@ -27,5 +27,6 @@
|
||||
|
||||
auparse_la_SOURCES = auparse_python.c
|
||||
auparse_la_CPPFLAGS = -I$(top_srcdir)/auparse $(AM_CPPFLAGS) -I@PYINCLUDEDIR@ -fno-strict-aliasing
|
||||
-auparse_la_LDFLAGS = -module -avoid-version -Wl,-z,relro
|
||||
+auparse_la_CFLAGS = -shared
|
||||
+auparse_la_LDFLAGS = -module -avoid-version -shared -Wl,-z,relro
|
||||
auparse_la_LIBADD = ${top_builddir}/auparse/libauparse.la ${top_builddir}/lib/libaudit.la
|
||||
diff -Nuar --exclude '*.orig' audit-2.1.3.orig/swig/Makefile.am audit-2.1.3/swig/Makefile.am
|
||||
--- audit-2.1.3.orig/swig/Makefile.am 2011-08-15 17:31:03.000000000 +0000
|
||||
+++ audit-2.1.3/swig/Makefile.am 2011-09-10 19:02:14.095067690 +0000
|
||||
@@ -28,7 +28,8 @@
|
||||
pyexec_PYTHON = audit.py
|
||||
pyexec_LTLIBRARIES = _audit.la
|
||||
pyexec_SOLIBRARIES = _audit.so
|
||||
-_audit_la_LDFLAGS = -module -avoid-version -Wl,-z,relro
|
||||
+_audit_la_CFLAGS = -shared
|
||||
+_audit_la_LDFLAGS = -module -avoid-version -shared -Wl,-z,relro
|
||||
_audit_la_HEADERS: $(top_builddir)/config.h
|
||||
_audit_la_DEPENDENCIES =${top_srcdir}/lib/libaudit.h ${top_builddir}/lib/libaudit.la
|
||||
nodist__audit_la_SOURCES = audit_wrap.c
|
46
sys-process/audit/files/audit-2.4.3-python.patch
Normal file
46
sys-process/audit/files/audit-2.4.3-python.patch
Normal file
@ -0,0 +1,46 @@
|
||||
diff -ur audit-2.4.3.orig/bindings/python/python2/Makefile.am audit-2.4.3/bindings/python/python2/Makefile.am
|
||||
--- audit-2.4.3.orig/bindings/python/python2/Makefile.am 2015-07-22 23:35:24.315424091 +0800
|
||||
+++ audit-2.4.3/bindings/python/python2/Makefile.am 2015-07-22 23:37:16.861510504 +0800
|
||||
@@ -29,5 +29,6 @@
|
||||
|
||||
auparse_la_SOURCES = $(top_srcdir)/bindings/python/auparse_python.c
|
||||
auparse_la_CPPFLAGS = -I$(top_srcdir)/auparse $(AM_CPPFLAGS)
|
||||
-auparse_la_LDFLAGS = -module -avoid-version -Wl,-z,relro
|
||||
+auparse_la_CFLAGS = -shared
|
||||
+auparse_la_LDFLAGS = -module -avoid-version -shared -Wl,-z,relro
|
||||
auparse_la_LIBADD = ${top_builddir}/auparse/libauparse.la ${top_builddir}/lib/libaudit.la
|
||||
diff -ur audit-2.4.3.orig/bindings/python/python3/Makefile.am audit-2.4.3/bindings/python/python3/Makefile.am
|
||||
--- audit-2.4.3.orig/bindings/python/python3/Makefile.am 2015-07-22 23:35:24.315424091 +0800
|
||||
+++ audit-2.4.3/bindings/python/python3/Makefile.am 2015-07-22 23:37:30.395400641 +0800
|
||||
@@ -28,5 +28,6 @@
|
||||
|
||||
auparse_la_SOURCES = $(top_srcdir)/bindings/python/auparse_python.c
|
||||
auparse_la_CPPFLAGS = -I$(top_srcdir)/auparse $(AM_CPPFLAGS)
|
||||
-auparse_la_LDFLAGS = -module -avoid-version -Wl,-z,relro
|
||||
+auparse_la_CFLAGS = -shared
|
||||
+auparse_la_LDFLAGS = -module -avoid-version -shared -Wl,-z,relro
|
||||
auparse_la_LIBADD = ${top_builddir}/auparse/libauparse.la ${top_builddir}/lib/libaudit.la
|
||||
diff -ur audit-2.4.3.orig/bindings/swig/python/Makefile.am audit-2.4.3/bindings/swig/python/Makefile.am
|
||||
--- audit-2.4.3.orig/bindings/swig/python/Makefile.am 2015-07-22 23:35:24.316424083 +0800
|
||||
+++ audit-2.4.3/bindings/swig/python/Makefile.am 2015-07-22 23:35:53.244189263 +0800
|
||||
@@ -28,7 +28,7 @@
|
||||
pyexec_LTLIBRARIES = _audit.la
|
||||
pyexec_SOLIBRARIES = _audit.so
|
||||
_audit_la_CFLAGS = -shared
|
||||
-_audit_la_LDFLAGS = -module -avoid-version -Wl,-z,relro
|
||||
+_audit_la_LDFLAGS = -module -avoid-version -shared -Wl,-z,relro
|
||||
_audit_la_HEADERS: $(top_builddir)/config.h
|
||||
_audit_la_DEPENDENCIES =${top_srcdir}/lib/libaudit.h ${top_builddir}/lib/libaudit.la
|
||||
_audit_la_LIBADD = $(top_builddir)/lib/libaudit.la
|
||||
diff -ur audit-2.4.3.orig/bindings/swig/python3/Makefile.am audit-2.4.3/bindings/swig/python3/Makefile.am
|
||||
--- audit-2.4.3.orig/bindings/swig/python3/Makefile.am 2015-07-22 23:35:24.316424083 +0800
|
||||
+++ audit-2.4.3/bindings/swig/python3/Makefile.am 2015-07-22 23:36:27.833908482 +0800
|
||||
@@ -29,7 +29,7 @@
|
||||
py3exec_LTLIBRARIES = _audit.la
|
||||
py3exec_SOLIBRARIES = _audit.so
|
||||
_audit_la_CFLAGS = -shared
|
||||
-_audit_la_LDFLAGS = -module -avoid-version -Wl,-z,relro
|
||||
+_audit_la_LDFLAGS = -module -avoid-version -shared -Wl,-z,relro
|
||||
_audit_la_HEADERS: $(top_builddir)/config.h
|
||||
_audit_la_DEPENDENCIES =${top_srcdir}/lib/libaudit.h ${top_builddir}/lib/libaudit.la
|
||||
_audit_la_LIBADD = ${top_builddir}/lib/libaudit.la
|
Loading…
Reference in New Issue
Block a user