Browse Source

[dev-java/jansi] version bump from tree, needed for jline bump

master
Robert Förster 10 years ago
parent
commit
e1497b6551
  1. 1
      dev-java/jansi/Manifest
  2. 34
      dev-java/jansi/jansi-1.9.ebuild

1
dev-java/jansi/Manifest

@ -0,0 +1 @@
DIST jansi-1.9.tar.gz 252137 SHA256 94600b4573cbb32d6d9124147cad09e1991de450933eb6b722ece5b499bd80f7 SHA512 b23c98436882b4fd76170684a342798eeb735f18a060da46fba22fee6db5c0f71e0a2bf2f31c218e10828e0d255f64893a8065a5e70c9d7e0ce848d77bde4b17 WHIRLPOOL 9efd3311f557bb9030e5ecf9101489858913ee81617e61cf8e13067d71180669577b8e2c6e69eaa5c46939995759c3812b9ea44f7f174d73187336adcbdd7ec0

34
dev-java/jansi/jansi-1.9.ebuild

@ -0,0 +1,34 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=2
COMMIT="5487ba3"
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-pkg-simple
DESCRIPTION="Jansi is a small java library that allows you to use ANSI escape sequences in your console output"
HOMEPAGE="http://jansi.fusesource.org/"
SRC_URI="https://github.com/fusesource/${PN}/tarball/${PN}-project-${PV} -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
RDEPEND=">=virtual/jre-1.5
dev-java/hawtjni-runtime
dev-java/jansi-native"
DEPEND=">=virtual/jdk-1.5
dev-java/hawtjni-runtime
dev-java/jansi-native"
S="${WORKDIR}/fusesource-${PN}-${COMMIT}/${PN}"
JAVA_SRC_DIR="src/main/java"
JAVA_GENTOO_CLASSPATH="hawtjni-runtime jansi-native"
java_prepare() {
# Easier to use java-pkg-simple.
rm -v pom.xml || die
}
Loading…
Cancel
Save